# TLS/SSL on Elasticsearch (new version 7.1) (Basic License)

**URL:** <https://discuss.elastic.co/t/tls-ssl-on-elasticsearch-new-version-7-1-basic-license/182623>\
**Category:** Elasticsearch\
**Tags:** elastic-stack-security\
**Created:** [May 24, 2019, 11:05am UTC](https://discuss.elastic.co/t/tls-ssl-on-elasticsearch-new-version-7-1-basic-license/182623 "2019-05-24T11:05:17Z")\
**Posts on this page:** 6\
**Page:** 1

<div class="post-metadata">

**Author:** ![Victor\_Vicente](https://avatars.discourse-cdn.com/v4/letter/v/278dde/32.png) [@Victor\_Vicente](https://discuss.elastic.co/u/Victor_Vicente)\
**Post date:** [May 24, 2019, 11:05am UTC](https://discuss.elastic.co/t/tls-ssl-on-elasticsearch-new-version-7-1-basic-license/182623/1 "2019-05-24T11:05:17Z")

</div>

Hi, now with version 7.1 TLS and RBAC are licensed under the free-of-charge Elastic Basic license. I was able to configure TLS from Kibana to Browser.

But in the documentation, to do the same for elasticsearch (HTTPS) the configuration is:

xpack.security.transport.ssl.enabled: true  
xpack.security.transport.ssl.verification\_mode: certificate  
xpack.security.transport.ssl.keystore.path: certs/elastic-certificates.p12  
xpack.security.transport.ssl.truststore.path: certs/elastic-certificates.p12

And when I put that on the elasticsearch YML file, it returns an error because I dont have XPACK.

So my question is: **in Elasticsearch 7.1 with Basic License what is configuration to enable TLS?**

---

<div class="post-metadata">

**Author:** ![TimV](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/timv/32/13162_2.png) [@TimV](https://discuss.elastic.co/u/TimV)\
**Post date:** [May 25, 2019, 1:51am UTC](https://discuss.elastic.co/t/tls-ssl-on-elasticsearch-new-version-7-1-basic-license/182623/2 "2019-05-25T01:51:26Z")

</div>

> [@Victor\_Vicente](#):
>
> when I put that on the elasticsearch YML file, it returns an error because I dont have XPACK.

What's the exact error you get?

---

<div class="post-metadata">

**Author:** ![Victor\_Vicente](https://avatars.discourse-cdn.com/v4/letter/v/278dde/32.png) [@Victor\_Vicente](https://discuss.elastic.co/u/Victor_Vicente)\
**Post date:** [May 27, 2019, 9:58am UTC](https://discuss.elastic.co/t/tls-ssl-on-elasticsearch-new-version-7-1-basic-license/182623/3 "2019-05-27T09:58:58Z")

</div>

This error:

java.lang.IllegalStateException: failed to load plugin class [org.elasticsearch.xpack.core.XPackPlugin]

The configuration is:

xpack.security.enabled: true  
xpack.security.transport.ssl.enabled: true  
xpack.security.transport.ssl.verification\_mode: certificate  
xpack.security.http.ssl.enabled: true  
xpack.security.http.ssl.key: /home/user/10.73.97.66.key.pem  
xpack.security.http.ssl.certificate: /home/user/certificado\_concatenado.cert.pem  
#xpack.http.ssl.certificate\_authorities: /home/user/ca.cert.pem

---

<div class="post-metadata">

**Author:** ![TimV](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/timv/32/13162_2.png) [@TimV](https://discuss.elastic.co/u/TimV)\
**Post date:** [May 27, 2019, 10:37am UTC](https://discuss.elastic.co/t/tls-ssl-on-elasticsearch-new-version-7-1-basic-license/182623/4 "2019-05-27T10:37:28Z")

</div>

> [@Victor\_Vicente](#):
>
> java.lang.IllegalStateException: failed to load plugin class [org.elasticsearch.xpack.core.XPackPlugin]

Keep reading - there will be additional information in the log.

My guess is that the problem will be that you have enabled transport ssl, but haven't configured a certificate or keystore.

---

<div class="post-metadata">

**Author:** ![Victor\_Vicente](https://avatars.discourse-cdn.com/v4/letter/v/278dde/32.png) [@Victor\_Vicente](https://discuss.elastic.co/u/Victor_Vicente)\
**Post date:** [May 27, 2019, 1:13pm UTC](https://discuss.elastic.co/t/tls-ssl-on-elasticsearch-new-version-7-1-basic-license/182623/5 "2019-05-27T13:13:27Z")

</div>

I will try that ... thanks

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [June 24, 2019, 1:13pm UTC](https://discuss.elastic.co/t/tls-ssl-on-elasticsearch-new-version-7-1-basic-license/182623/6 "2019-06-24T13:13:29Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
