# Too many logstash processes are running on server

**URL:** <https://discuss.elastic.co/t/too-many-logstash-processes-are-running-on-server/263391>\
**Category:** Logstash\
**Created:** [February 5, 2021, 1:53pm UTC](https://discuss.elastic.co/t/too-many-logstash-processes-are-running-on-server/263391 "2021-02-05T13:53:46Z")\
**Posts on this page:** 2\
**Page:** 1

<div class="post-metadata">

**Author:** ![hariskhalique](https://avatars.discourse-cdn.com/v4/letter/h/a3d4f5/32.png) [@hariskhalique](https://discuss.elastic.co/u/hariskhalique)\
**Post date:** [February 5, 2021, 1:53pm UTC](https://discuss.elastic.co/t/too-many-logstash-processes-are-running-on-server/263391/1 "2021-02-05T13:53:46Z")

</div>

Hi,  
I am using logstash pipeline to dump data in elastic search. Only two configuration define in pipeline. But when I htop my server there are lots of processes.

following are screen short of htop.

 ![Screenshot 2021-02-05 at 6.46.54 PM](https://us1.discourse-cdn.com/elastic/original/3X/7/7/77cbf7e8541bf2936119cb938b949f3e789c6130.jpeg)

Also getting following errors.

```
Feb 05 07:48:19 prod-v4amb-applicaion systemd[1]: Stopped logstash.
Feb 05 07:48:19 prod-v4amb-applicaion systemd[1]: Started logstash.
Feb 05 07:48:19 prod-v4amb-applicaion logstash[10145]: Using bundled JDK: /usr/share/logstash/jdk
Feb 05 07:48:19 prod-v4amb-applicaion logstash[10145]: OpenJDK 64-Bit Server VM warning: Option UseConcMarkSweepGC was deprecated in version 9.0 and will likely be removed in a future release.
Feb 05 07:48:28 prod-v4amb-applicaion logstash[10145]: WARNING: An illegal reflective access operation has occurred
Feb 05 07:48:28 prod-v4amb-applicaion logstash[10145]: WARNING: Illegal reflective access by org.jruby.ext.openssl.SecurityHelper (file:/tmp/jruby-10145/jruby2370872665350410820jopenssl.jar) to field java.security.MessageDigest.provider
Feb 05 07:48:28 prod-v4amb-applicaion logstash[10145]: WARNING: Please consider reporting this to the maintainers of org.jruby.ext.openssl.SecurityHelper
Feb 05 07:48:28 prod-v4amb-applicaion logstash[10145]: WARNING: Use --illegal-access=warn to enable warnings of further illegal reflective access operations
Feb 05 07:48:28 prod-v4amb-applicaion logstash[10145]: WARNING: All illegal access operations will be denied in a future release
Feb 05 07:48:29 prod-v4amb-applicaion logstash[10145]: Sending Logstash logs to /var/log/logstash which is now configured via log4j2.properties
Feb 05 07:48:29 prod-v4amb-applicaion logstash[10145]: [2021-02-05T07:48:29,667][INFO][logstash.runner] Starting Logstash {"logstash.version"=>"7.10.2", "jruby.version"=>"jruby 9.2.13.0 (2.5.7) 2020-08-03 9a89c94bcc OpenJDK 64-Bit Server VM 11.0.8+10 on 11.0.8+10 +indy +jit [linux-x86_64]"}
Feb 05 07:48:30 prod-v4amb-applicaion logstash[10145]: [2021-02-05T07:48:30,368][INFO][logstash.config.source.local.configpathloader] No config files found in path {:path=>"/etc/logstash/conf.d/*.conf"}
Feb 05 07:48:30 prod-v4amb-applicaion logstash[10145]: [2021-02-05T07:48:30,387][ERROR][logstash.config.sourceloader] No configuration found in the configured sources.
Feb 05 07:48:30 prod-v4amb-applicaion logstash[10145]: [2021-02-05T07:48:30,522][INFO][logstash.agent] Successfully started Logstash API endpoint {:port=>9600}
Feb 05 07:48:35 prod-v4amb-applicaion logstash[10145]: [2021-02-05T07:48:35,578][INFO][logstash.runner] Logstash shut down.
Feb 05 07:48:35 prod-v4amb-applicaion logstash[10145]: [2021-02-05T07:48:35,586][ERROR][org.logstash.Logstash] java.lang.IllegalStateException: Logstash stopped processing because of an error: (SystemExit) exit
Feb 05 07:48:36 prod-v4amb-applicaion systemd[1]: logstash.service: Main process exited, code=exited, status=1/FAILURE
Feb 05 07:48:36 prod-v4amb-applicaion systemd[1]: logstash.service: Unit entered failed state.
Feb 05 07:48:36 prod-v4amb-applicaion systemd[1]: logstash.service: Failed with result 'exit-code'.
Feb 05 07:48:36 prod-v4amb-applicaion systemd[1]: logstash.service: Service hold-off time over, scheduling restart.
Feb 05 07:48:36 prod-v4amb-applicaion systemd[1]: Stopped logstash.
Feb 05 07:48:36 prod-v4amb-applicaion systemd[1]: Started logstash.

```

Question why there is too many logstash processes are running it consume more memory then any other processes. I like to optimize no idea where to start.

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [March 5, 2021, 1:53pm UTC](https://discuss.elastic.co/t/too-many-logstash-processes-are-running-on-server/263391/2 "2021-03-05T13:53:49Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
