# Too many open files /var/lib/elasticsearch doesn't exist on the nodes

**URL:** <https://discuss.elastic.co/t/too-many-open-files-var-lib-elasticsearch-doesnt-exist-on-the-nodes/19267>\
**Category:** Elasticsearch\
**Created:** [August 13, 2014, 7:23pm UTC](https://discuss.elastic.co/t/too-many-open-files-var-lib-elasticsearch-doesnt-exist-on-the-nodes/19267 "2014-08-13T19:23:50Z")\
**Posts on this page:** 3\
**Page:** 1

<div class="post-metadata">

**Author:** ![Jose\_Andres](https://avatars.discourse-cdn.com/v4/letter/j/d78d45/32.png) [@Jose\_Andres](https://discuss.elastic.co/u/Jose_Andres)\
**Post date:** [August 13, 2014, 7:23pm UTC](https://discuss.elastic.co/t/too-many-open-files-var-lib-elasticsearch-doesnt-exist-on-the-nodes/19267/1 "2014-08-13T19:23:50Z")

</div>

Can someone elaborate as to why the exception below is thrown?

[2014-08-11 11:27:41,189][WARN][cluster.action.shard] [mycluster]  
[all][4] received shard failed for [all][4], node[MLNWasasasWi2V58hRA93mg],  
[P], s[INITIALIZING], indexUUID [KSScFASsasas6yTEcK7HqlmA], reason [Failed  
to start shard, message [IndexShardGatewayRecoveryException[[all][4] failed  
recovery]; nested: EngineCreationFailureException[[all][4] failed to open  
reader on writer]; nested:  
FileSystemException[/var/lib/elasticsearch/mycluster/nodes/0/indices/all/4/index/\_  
m4bz\_es090\_0.tim: Too many open files]; ]] 2:11 /var/lib/elasticsearch  
doesn't exist on the nodes

Thank you very much for your feedback.

--  
You received this message because you are subscribed to the Google Groups "elasticsearch" group.  
To unsubscribe from this group and stop receiving emails from it, send an email to [elasticsearch+unsubscribe@googlegroups.com](mailto:elasticsearch+unsubscribe@googlegroups.com).  
To view this discussion on the web visit [https://groups.google.com/d/msgid/elasticsearch/16968aac-dbfe-44c4-b3fe-d25af0dfbe37%40googlegroups.com](https://groups.google.com/d/msgid/elasticsearch/16968aac-dbfe-44c4-b3fe-d25af0dfbe37%40googlegroups.com).  
For more options, visit [https://groups.google.com/d/optout](https://groups.google.com/d/optout).

---

<div class="post-metadata">

**Author:** ![jpountz](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/jpountz/32/45836_2.png) [@jpountz](https://discuss.elastic.co/u/jpountz)\
**Post date:** [August 13, 2014, 8:18pm UTC](https://discuss.elastic.co/t/too-many-open-files-var-lib-elasticsearch-doesnt-exist-on-the-nodes/19267/2 "2014-08-13T20:18:57Z")

</div>

It seems that this particular node is complaining about too many open  
files. This usually happens if you have very low limits on your operating  
system and/or if you have many shards on a single node. When this happens,  
things degrade pretty badly as there is no way to open new files anymore.

Please see

> **[Elasticsearch Platform — Find real-time answers at scale](https://www.elastic.co)**
>
> Power insights and outcomes with the Elasticsearch Platform and AI. See into your data and find answers that matter with enterprise solutions designed to help you build, observe, and protect. Try Elasticsearch free today.

for more information.

On Wed, Aug 13, 2014 at 9:23 PM, José Andrés [japmycroft@gmail.com](mailto:japmycroft@gmail.com) wrote:

> Can someone elaborate as to why the exception below is thrown?
> 
> [2014-08-11 11:27:41,189][WARN][cluster.action.shard] [mycluster]  
> [all][4] received shard failed for [all][4], node[MLNWasasasWi2V58hRA93mg],  
> [P], s[INITIALIZING], indexUUID [KSScFASsasas6yTEcK7HqlmA], reason [Failed  
> to start shard, message [IndexShardGatewayRecoveryException[[all][4] failed  
> recovery]; nested: EngineCreationFailureException[[all][4] failed to open  
> reader on writer]; nested:  
> FileSystemException[/var/lib/elasticsearch/mycluster/nodes/0/indices/all/4/index/\_  
> m4bz\_es090\_0.tim: Too many open files]; ]] 2:11 /var/lib/elasticsearch  
> doesn't exist on the nodes
> 
> Thank you very much for your feedback.
> 
> --  
> You received this message because you are subscribed to the Google Groups  
> "elasticsearch" group.  
> To unsubscribe from this group and stop receiving emails from it, send an  
> email to [elasticsearch+unsubscribe@googlegroups.com](mailto:elasticsearch+unsubscribe@googlegroups.com).  
> To view this discussion on the web visit  
> [https://groups.google.com/d/msgid/elasticsearch/16968aac-dbfe-44c4-b3fe-d25af0dfbe37%40googlegroups.com](https://groups.google.com/d/msgid/elasticsearch/16968aac-dbfe-44c4-b3fe-d25af0dfbe37%40googlegroups.com)  
> [https://groups.google.com/d/msgid/elasticsearch/16968aac-dbfe-44c4-b3fe-d25af0dfbe37%40googlegroups.com?utm\_medium=email&utm\_source=footer](https://groups.google.com/d/msgid/elasticsearch/16968aac-dbfe-44c4-b3fe-d25af0dfbe37%40googlegroups.com?utm_medium=email&utm_source=footer)  
> .  
> For more options, visit [https://groups.google.com/d/optout](https://groups.google.com/d/optout).

--  
Adrien Grand

--  
You received this message because you are subscribed to the Google Groups "elasticsearch" group.  
To unsubscribe from this group and stop receiving emails from it, send an email to [elasticsearch+unsubscribe@googlegroups.com](mailto:elasticsearch+unsubscribe@googlegroups.com).  
To view this discussion on the web visit [https://groups.google.com/d/msgid/elasticsearch/CAL6Z4j5n0x\_zBEYEP1B3a1uf0vCFGoCphZw%3DCZwJF7nuF24ERQ%40mail.gmail.com](https://groups.google.com/d/msgid/elasticsearch/CAL6Z4j5n0x_zBEYEP1B3a1uf0vCFGoCphZw%3DCZwJF7nuF24ERQ%40mail.gmail.com).  
For more options, visit [https://groups.google.com/d/optout](https://groups.google.com/d/optout).

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [July 6, 2017, 1:08am UTC](https://discuss.elastic.co/t/too-many-open-files-var-lib-elasticsearch-doesnt-exist-on-the-nodes/19267/3 "2017-07-06T01:08:47Z")

</div>


