# Topbeat does not start for Windows server 2008 R2 Sp1

**URL:** <https://discuss.elastic.co/t/topbeat-does-not-start-for-windows-server-2008-r2-sp1/37301>\
**Category:** Beats\
**Created:** [December 16, 2015, 5:26am UTC](https://discuss.elastic.co/t/topbeat-does-not-start-for-windows-server-2008-r2-sp1/37301 "2015-12-16T05:26:47Z")\
**Posts on this page:** 7\
**Page:** 1

<div class="post-metadata">

**Author:** ![Rishi\_Singhal](https://avatars.discourse-cdn.com/v4/letter/r/aeb1de/32.png) [@Rishi\_Singhal](https://discuss.elastic.co/u/Rishi_Singhal)\
**Post date:** [December 16, 2015, 5:26am UTC](https://discuss.elastic.co/t/topbeat-does-not-start-for-windows-server-2008-r2-sp1/37301/1 "2015-12-16T05:26:47Z")

</div>

I am trying to start Topbeat (topbeat-1.0.0-windows) on Windows server 2008 R2 Sp1 and I get this error

PS C:\Program Files\Topbeat\> Start-Service topbeat  
Start-Service : Service 'topbeat (topbeat)' cannot be started due to the following error: Cannot start service topbeat  
on computer '.'.  
At line:1 char:14

- Start-Service \<\<\<\< topbeat
  - CategoryInfo : OpenError: (System.ServiceProcess.ServiceController:ServiceController) [Start-Service],  
ServiceCommandException
  - FullyQualifiedErrorId : CouldNotStartService,Microsoft.PowerShell.Commands.StartServiceCommand

Starting it from Services I get  
 ![](https://us1.discourse-cdn.com/elastic/original/2X/7/79ffe462e6a48fa07cc107875f6dcffce4ac167b.jpg)

Any ideas?

Regards,  
Rishi

---

<div class="post-metadata">

**Author:** ![andrewkroh](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/andrewkroh/32/3784_2.png) [@andrewkroh](https://discuss.elastic.co/u/andrewkroh)\
**Post date:** [December 16, 2015, 4:34pm UTC](https://discuss.elastic.co/t/topbeat-does-not-start-for-windows-server-2008-r2-sp1/37301/2 "2015-12-16T16:34:21Z")

</div>

Can you test your configuration file and start Topbeat manually to see if any errors are returned.

```auto
# Test the configuration file.
PS C:\Program Files\Topbeat> .\topbeat.exe -c topbeat.yml -configtest
# Start Topbeat in the foreground and see if there are any errors.
PS C:\Program Files\Topbeat> .\topbeat.exe -c topbeat.yml -e -v -d "*"

```

---

<div class="post-metadata">

**Author:** ![Rishi\_Singhal](https://avatars.discourse-cdn.com/v4/letter/r/aeb1de/32.png) [@Rishi\_Singhal](https://discuss.elastic.co/u/Rishi_Singhal)\
**Post date:** [December 17, 2015, 5:10am UTC](https://discuss.elastic.co/t/topbeat-does-not-start-for-windows-server-2008-r2-sp1/37301/3 "2015-12-17T05:10:15Z")

</div>

PS C:\Program Files\Topbeat\> dir

```
Directory: C:\Program Files\Topbeat

```

Mode LastWriteTime Length Name

* * *

d---- 12/16/2015 11:01 AM log  
-a--- 11/24/2015 7:21 PM 428 install-service-topbeat.ps1  
- **a--- 11/24/2015 7:21 PM 5714649 topbeat.exe**  
-a--- 11/24/2015 7:21 PM 2493 topbeat.template.json  
-a--- 12/16/2015 11:02 AM 8752 topbeat.yml  
-a--- 11/24/2015 7:21 PM 182 uninstall-service-topbeat.ps1

**PS C:\Program Files\Topbeat\> topbeat.exe -c topbeat.yaml -configtest**  
The term 'topbeat.exe' is not recognized as the name of a cmdlet, function, script file, or operable program. Check the spelling of the name, or if a path was included, verify that the path is correct and try again.  
At line:1 char:12

- topbeat.exe \<\<\<\< -c topbeat.yaml -configtest
  - CategoryInfo : ObjectNotFound: (topbeat.exe:String) [], CommandNotFoundException
  - FullyQualifiedErrorId : CommandNotFoundException

Suggestion [3,General]: The command topbeat.exe was not found, but does exist in the current location. Windows PowerShell doesn't load commands from the current location by default. If you trust this command, instead type ".\topbeat.exe". See "get-help about\_Command\_Precedence" for more details.

PS C:\Program Files\Topbeat\> .\topbeat.exe -c topbeat.yaml -configtest  
Loading config file error: Failed to read topbeat.yaml: open topbeat.yaml: The system cannot find the file specified.. Exiting.

**The spelling was wrong. Use yml**  
PS C:\Program Files\Topbeat\> .\topbeat.exe -c topbeat.yml -configtest

**It worked on Command line**  
PS C:\Program Files\Topbeat\> .\topbeat.exe -c topbeat.yml -e -v -d "\*"  
2015/12/17 05:15:44.108088 beat.go:97: DBG Initializing output plugins  
2015/12/17 05:15:44.108088 geolite.go:24: INFO GeoIP disabled: No paths were set under output.geoip.paths  
2015/12/17 05:15:44.108088 client.go:244: DBG ES Ping(url=http://10.42.33.133:9200, timeout=1m30s)  
PS C:\Program Files\Topbeat\>

---

<div class="post-metadata">

**Author:** ![andrewkroh](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/andrewkroh/32/3784_2.png) [@andrewkroh](https://discuss.elastic.co/u/andrewkroh)\
**Post date:** [December 17, 2015, 6:51pm UTC](https://discuss.elastic.co/t/topbeat-does-not-start-for-windows-server-2008-r2-sp1/37301/5 "2015-12-17T18:51:44Z")

</div>

Can you try version 1.0.1 that was released today. There was [a change](https://github.com/elastic/beats-packer/pull/32) to the installation powershell script.

---

<div class="post-metadata">

**Author:** ![karantikku](https://avatars.discourse-cdn.com/v4/letter/k/22d042/32.png) [@karantikku](https://discuss.elastic.co/u/karantikku)\
**Post date:** [April 16, 2016, 2:57pm UTC](https://discuss.elastic.co/t/topbeat-does-not-start-for-windows-server-2008-r2-sp1/37301/6 "2016-04-16T14:57:54Z")

</div>

I'm trying to start topbeat-1.2.1 on Windows 10 and I'm getting the following error, kindly help.

Start-Service : Service 'topbeat (topbeat)' cannot be started due to the following error: Cannot start service topbeat  
on computer '.'.  
At line:1 char:1

- Start-Service topbeat
- 

```auto
  + CategoryInfo : OpenError: (System.ServiceProcess.ServiceController:ServiceController) [Start-Service],
 ServiceCommandException
  + FullyQualifiedErrorId : CouldNotStartService,Microsoft.PowerShell.Commands.StartServiceCommand
```

---

<div class="post-metadata">

**Author:** ![andrewkroh](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/andrewkroh/32/3784_2.png) [@andrewkroh](https://discuss.elastic.co/u/andrewkroh)\
**Post date:** [April 16, 2016, 4:34pm UTC](https://discuss.elastic.co/t/topbeat-does-not-start-for-windows-server-2008-r2-sp1/37301/7 "2016-04-16T16:34:11Z")

</div>

Please try the steps posted above by me.

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [July 5, 2017, 9:53pm UTC](https://discuss.elastic.co/t/topbeat-does-not-start-for-windows-server-2008-r2-sp1/37301/8 "2017-07-05T21:53:10Z")

</div>


