# Tracking down issue - Elasticsearch server returned no response. Is it running?

**URL:** <https://discuss.elastic.co/t/tracking-down-issue-elasticsearch-server-returned-no-response-is-it-running/6898>\
**Category:** Elasticsearch\
**Created:** [March 6, 2012, 12:56am UTC](https://discuss.elastic.co/t/tracking-down-issue-elasticsearch-server-returned-no-response-is-it-running/6898 "2012-03-06T00:56:51Z")\
**Posts on this page:** 5\
**Page:** 1

<div class="post-metadata">

**Author:** ![Slavik](https://avatars.discourse-cdn.com/v4/letter/s/db5fbb/32.png) [@Slavik](https://discuss.elastic.co/u/Slavik)\
**Post date:** [March 6, 2012, 12:56am UTC](https://discuss.elastic.co/t/tracking-down-issue-elasticsearch-server-returned-no-response-is-it-running/6898/1 "2012-03-06T00:56:51Z")

</div>

Hi there guys,

I currently run a forum with 1.4 million posts indexed by  
Elasticsearch on XenForo.

The issue several of us are experiencing is very occasionally (maybe 1  
or 2 times per day on my forum with about 1000-2000 searches per day)  
a search result will come back with an empty result and generate the  
error in the admin log of XenForo of

XenForo\_Exception: Elasticsearch server returned no response. Is it  
running? - library/XenES/Search/SourceHandler/ElasticSearch.php:721

However, as quickly as the error shows it it disappears, and  
everything carries on. Now, I have caught the error once on my board,  
and logging into SSH and checking the services showed ES was runing  
away happily.

I thought maybe it could be due to some timeout or idle setting, that  
the first search after X ammount of time that it just needs waking up  
and that may be the first result, however we tried creating a cron  
script to run the curl 127.0.0.1:9200 command as well as one handing  
and actual search query to the service to keep it alive and if  
anything it caused more errors.

You can see what we have tried here: [http://xenforo.com/community/threads/empty-result-sets.28580/](http://xenforo.com/community/threads/empty-result-sets.28580/)

However I believe this is now venturing out of my knowledge and skill  
to locate the cause of the problem (as minimal as it is, we would  
still like to resolve it!) so would like any suggestions you may have.

Thankyou.

//Slav

---

<div class="post-metadata">

**Author:** ![Radu\_Gheorghe1](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/radu_gheorghe1/32/2688_2.png) [@Radu\_Gheorghe1](https://discuss.elastic.co/u/Radu_Gheorghe1)\
**Post date:** [March 6, 2012, 5:53am UTC](https://discuss.elastic.co/t/tracking-down-issue-elasticsearch-server-returned-no-response-is-it-running/6898/2 "2012-03-06T05:53:07Z")

</div>

Hi,

Did you see anything relevant in Elasticsearch's logs?

Also, it would be nice if you could find out what was the actual reply  
from Elasticsearch, if any (eg: return code 500, connection refused,  
connection timed out...).

On 6 mar., 02:56, Slavik [neosis...@gmail.com](mailto:neosis...@gmail.com) wrote:

> Hi there guys,
> 
> I currently run a forum with 1.4 million posts indexed by  
> Elasticsearch on XenForo.
> 
> The issue several of us are experiencing is very occasionally (maybe 1  
> or 2 times per day on my forum with about 1000-2000 searches per day)  
> a search result will come back with an empty result and generate the  
> error in the admin log of XenForo of
> 
> XenForo\_Exception: Elasticsearch server returned no response. Is it  
> running? - library/XenES/Search/SourceHandler/Elasticsearch.php:721
> 
> However, as quickly as the error shows it it disappears, and  
> everything carries on. Now, I have caught the error once on my board,  
> and logging into SSH and checking the services showed ES was runing  
> away happily.
> 
> I thought maybe it could be due to some timeout or idle setting, that  
> the first search after X ammount of time that it just needs waking up  
> and that may be the first result, however we tried creating a cron  
> script to run the curl 127.0.0.1:9200 command as well as one handing  
> and actual search query to the service to keep it alive and if  
> anything it caused more errors.
> 
> You can see what we have tried here:[Empty result sets? | XenForo community](http://xenforo.com/community/threads/empty-result-sets.28580/)
> 
> However I believe this is now venturing out of my knowledge and skill  
> to locate the cause of the problem (as minimal as it is, we would  
> still like to resolve it!) so would like any suggestions you may have.
> 
> Thankyou.
> 
> //Slav

---

<div class="post-metadata">

**Author:** ![Slavik](https://avatars.discourse-cdn.com/v4/letter/s/db5fbb/32.png) [@Slavik](https://discuss.elastic.co/u/Slavik)\
**Post date:** [March 6, 2012, 6:28pm UTC](https://discuss.elastic.co/t/tracking-down-issue-elasticsearch-server-returned-no-response-is-it-running/6898/3 "2012-03-06T18:28:07Z")

</div>

I have had a look and nothing seems to show up in logs.

I have enabled the commented out "gateway" log options to see if that helps.

On Tuesday, 6 March 2012 05:53:07 UTC, Radu Gheorghe wrote:

> Hi,
> 
> Did you see anything relevant in Elasticsearch's logs?
> 
> Also, it would be nice if you could find out what was the actual reply  
> from Elasticsearch, if any (eg: return code 500, connection refused,  
> connection timed out...).
> 
> On 6 mar., 02:56, Slavik [neosis...@gmail.com](mailto:neosis...@gmail.com) wrote:
> 
> > Hi there guys,
> > 
> > I currently run a forum with 1.4 million posts indexed by  
> > Elasticsearch on XenForo.
> > 
> > The issue several of us are experiencing is very occasionally (maybe 1  
> > or 2 times per day on my forum with about 1000-2000 searches per day)  
> > a search result will come back with an empty result and generate the  
> > error in the admin log of XenForo of
> > 
> > XenForo\_Exception: Elasticsearch server returned no response. Is it  
> > running? - library/XenES/Search/SourceHandler/Elasticsearch.php:721
> > 
> > However, as quickly as the error shows it it disappears, and  
> > everything carries on. Now, I have caught the error once on my board,  
> > and logging into SSH and checking the services showed ES was runing  
> > away happily.
> > 
> > I thought maybe it could be due to some timeout or idle setting, that  
> > the first search after X ammount of time that it just needs waking up  
> > and that may be the first result, however we tried creating a cron  
> > script to run the curl 127.0.0.1:9200 command as well as one handing  
> > and actual search query to the service to keep it alive and if  
> > anything it caused more errors.
> > 
> > You can see what we have tried here:  
> > [Empty result sets? | XenForo community](http://xenforo.com/community/threads/empty-result-sets.28580/)
> > 
> > However I believe this is now venturing out of my knowledge and skill  
> > to locate the cause of the problem (as minimal as it is, we would  
> > still like to resolve it!) so would like any suggestions you may have.
> > 
> > Thankyou.
> > 
> > //Slav

---

<div class="post-metadata">

**Author:** ![kimchy](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/kimchy/32/44952_2.png) [@kimchy](https://discuss.elastic.co/u/kimchy)\
**Post date:** [March 6, 2012, 9:08pm UTC](https://discuss.elastic.co/t/tracking-down-issue-elasticsearch-server-returned-no-response-is-it-running/6898/4 "2012-03-06T21:08:33Z")

</div>

It would be great to understand what the actual error is in the no response message. Is it a timeout (connect timeout, receive timeout), what is the error code that is returned if returned.

On Tuesday, March 6, 2012 at 2:56 AM, Slavik wrote:

> Hi there guys,
> 
> I currently run a forum with 1.4 million posts indexed by  
> Elasticsearch on XenForo.
> 
> The issue several of us are experiencing is very occasionally (maybe 1  
> or 2 times per day on my forum with about 1000-2000 searches per day)  
> a search result will come back with an empty result and generate the  
> error in the admin log of XenForo of
> 
> XenForo\_Exception: Elasticsearch server returned no response. Is it  
> running? - library/XenES/Search/SourceHandler/Elasticsearch.php:721
> 
> However, as quickly as the error shows it it disappears, and  
> everything carries on. Now, I have caught the error once on my board,  
> and logging into SSH and checking the services showed ES was runing  
> away happily.
> 
> I thought maybe it could be due to some timeout or idle setting, that  
> the first search after X ammount of time that it just needs waking up  
> and that may be the first result, however we tried creating a cron  
> script to run the curl 127.0.0.1:9200 command as well as one handing  
> and actual search query to the service to keep it alive and if  
> anything it caused more errors.
> 
> You can see what we have tried here: [Empty result sets? | XenForo community](http://xenforo.com/community/threads/empty-result-sets.28580/)
> 
> However I believe this is now venturing out of my knowledge and skill  
> to locate the cause of the problem (as minimal as it is, we would  
> still like to resolve it!) so would like any suggestions you may have.
> 
> Thankyou.
> 
> //Slav

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [July 6, 2017, 3:37am UTC](https://discuss.elastic.co/t/tracking-down-issue-elasticsearch-server-returned-no-response-is-it-running/6898/5 "2017-07-06T03:37:02Z")

</div>


