# Transport client error after installing x-pack on es-5-5-1

**URL:** <https://discuss.elastic.co/t/transport-client-error-after-installing-x-pack-on-es-5-5-1/97021>\
**Category:** Elasticsearch\
**Created:** [August 14, 2017, 8:32pm UTC](https://discuss.elastic.co/t/transport-client-error-after-installing-x-pack-on-es-5-5-1/97021 "2017-08-14T20:32:18Z")\
**Posts on this page:** 5\
**Page:** 1

<div class="post-metadata">

**Author:** ![akshaymaniyar](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/akshaymaniyar/32/45836_2.png) [@akshaymaniyar](https://discuss.elastic.co/u/akshaymaniyar)\
**Post date:** [August 14, 2017, 8:32pm UTC](https://discuss.elastic.co/t/transport-client-error-after-installing-x-pack-on-es-5-5-1/97021/1 "2017-08-14T20:32:18Z")

</div>

I have the following configs related to xpack:  
xpack.security.enabled: false  
xpack.monitoring.enabled: true  
xpack.ml.enabled: false  
xpack.graph.enabled: false  
xpack.watcher.enabled: false

Also have the below:  
[node.ml](http://node.ml): false

Still getting the below error. (Note Everything works as soon as I remove x-pack)

Caused by: java.lang.IllegalArgumentException: Unknown NamedWriteable [org.elasticsearch.cluster.metadata.MetaData$Custom][ml]  
at org.elasticsearch.common.io.stream.NamedWriteableRegistry.getReader(NamedWriteableRegistry.java:112)  
at org.elasticsearch.common.io.stream.NamedWriteableAwareStreamInput.readNamedWriteable(NamedWriteableAwareStreamInput.java:45)  
at org.elasticsearch.common.io.stream.NamedWriteableAwareStreamInput.readNamedWriteable(NamedWriteableAwareStreamInput.java:39)  
at org.elasticsearch.cluster.metadata.MetaData.readFrom(MetaData.java:682)  
at org.elasticsearch.cluster.ClusterState.readFrom(ClusterState.java:659)  
at org.elasticsearch.action.admin.cluster.state.ClusterStateResponse.readFrom(ClusterStateResponse.java:58)  
at org.elasticsearch.transport.TcpTransport.handleResponse(TcpTransport.java:1428)  
... 23 more

---

<div class="post-metadata">

**Author:** ![TimV](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/timv/32/13162_2.png) [@TimV](https://discuss.elastic.co/u/TimV)\
**Post date:** [August 15, 2017, 12:04am UTC](https://discuss.elastic.co/t/transport-client-error-after-installing-x-pack-on-es-5-5-1/97021/2 "2017-08-15T00:04:28Z")

</div>

Are you using the X-Pack transport client?

- [https://www.elastic.co/guide/en/x-pack/5.5/java-clients.html](https://www.elastic.co/guide/en/x-pack/5.5/java-clients.html)

---

<div class="post-metadata">

**Author:** ![dkyle](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/dkyle/32/59114_2.png) [@dkyle](https://discuss.elastic.co/u/dkyle)\
**Post date:** [August 15, 2017, 8:01am UTC](https://discuss.elastic.co/t/transport-client-error-after-installing-x-pack-on-es-5-5-1/97021/3 "2017-08-15T08:01:47Z")

</div>

Machine Learning adds custom fields the the Elasticsearch metadata. From the stack trace I can see that ML has added its custom fields and so must have been enabled at some point. X-Pack knows how to parse the metadata and should be installed on every node. The X-Pack features don't have to be enabled but you must install X-Pack on every node in your cluster.

---

<div class="post-metadata">

**Author:** ![akshaymaniyar](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/akshaymaniyar/32/45836_2.png) [@akshaymaniyar](https://discuss.elastic.co/u/akshaymaniyar)\
**Post date:** [August 15, 2017, 8:39am UTC](https://discuss.elastic.co/t/transport-client-error-after-installing-x-pack-on-es-5-5-1/97021/4 "2017-08-15T08:39:14Z")

</div>

Hi,

@Tim: Was not using the x-pack-transport client. I was using the org.elasticsearch.client:transport client. Was of the impression that x-pack-transport client is only required when security feature is being used. Since I had disabled the security feature, was using the normal transport client. The code is working perfectly after using the x-pack-transport client. Perhaps the same could be mentioned in the documentation that if you are using x-pack then always x-pack-transport client should be used. (Note this was not the case in es-5-2-2, normal transport client used to work with x-pack)

@dkyle: That explains why normal transport client used to work earlier and doesn't work now. FYI: X-pack was installed in all the machines. It seems just the normal transport client cannot be used now if you are using x-pack .

Thanks all!

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [September 12, 2017, 8:39am UTC](https://discuss.elastic.co/t/transport-client-error-after-installing-x-pack-on-es-5-5-1/97021/5 "2017-09-12T08:39:51Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
