# Transport client node failure

**URL:** <https://discuss.elastic.co/t/transport-client-node-failure/8802>\
**Category:** Elasticsearch\
**Created:** [August 21, 2012, 3:59pm UTC](https://discuss.elastic.co/t/transport-client-node-failure/8802 "2012-08-21T15:59:28Z")\
**Posts on this page:** 2\
**Page:** 1

<div class="post-metadata">

**Author:** ![shengcer](https://avatars.discourse-cdn.com/v4/letter/s/41988e/32.png) [@shengcer](https://discuss.elastic.co/u/shengcer)\
**Post date:** [August 21, 2012, 3:59pm UTC](https://discuss.elastic.co/t/transport-client-node-failure/8802/1 "2012-08-21T15:59:28Z")

</div>

If the elastic search is configured to run on two nodes, both are of type data/master. I then write my program to initialize a transport client to listen to both of these two nodes. For some reason, either due to network is slow or the node itself is dead, anyway one node is failed. Meanwhile elasticsearch is executing a scheduled job of indexing a great amount of data to the cluster. The transport client, in this case, would of course complain one node is dead. Now what I am really concerned is the whole cluster would be messed up. Below is one sample of the messages I got in this case. What can I do to avoid this from happening?

WARNING: [Blackout] [coverage-elastic1345266122391][0] failed to start shard  
org.elasticsearch.index.gateway.IndexShardGatewayRecoveryException: [coverage-elastic1345266122391][0] shard allocated for local recovery (post api), should exists, but doesn't  
at org.elasticsearch.index.gateway.local.LocalIndexShardGateway.recover(LocalIndexShardGateway.java:120)  
at org.elasticsearch.index.gateway.IndexShardGatewayService$1.run(IndexShardGatewayService.java:177)  
at java.util.concurrent.ThreadPoolExecutor$Worker.runTask(ThreadPoolExecutor.java:886)  
at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:908)  
at java.lang.Thread.run(Thread.java:662)

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [July 6, 2017, 3:15am UTC](https://discuss.elastic.co/t/transport-client-node-failure/8802/2 "2017-07-06T03:15:38Z")

</div>


