# Transport.go:125: ssl client failed to connect

**URL:** <https://discuss.elastic.co/t/transport-go-125-ssl-client-failed-to-connect/119475>\
**Category:** Beats\
**Created:** [February 12, 2018, 1:34pm UTC](https://discuss.elastic.co/t/transport-go-125-ssl-client-failed-to-connect/119475 "2018-02-12T13:34:55Z")\
**Posts on this page:** 5\
**Page:** 1

<div class="post-metadata">

**Author:** ![Pierre\_What\_s\_Up\_Sca](https://avatars.discourse-cdn.com/v4/letter/p/a9adbd/32.png) [@Pierre\_What\_s\_Up\_Sca](https://discuss.elastic.co/u/Pierre_What_s_Up_Sca)\
**Post date:** [February 12, 2018, 1:34pm UTC](https://discuss.elastic.co/t/transport-go-125-ssl-client-failed-to-connect/119475/1 "2018-02-12T13:34:55Z")

</div>

I am trying to connect filebeat to logstash but I have this error :  
● filebeat.service - filebeat  
Loaded: loaded (/usr/lib/systemd/system/filebeat.service; enabled; vendor preset: disabled)  
Active: active (running) since Mon 2018-02-12 14:04:27 CET; 9min ago  
Docs: [https://www.elastic.co/guide/en/beats/filebeat/current/index.html](https://www.elastic.co/guide/en/beats/filebeat/current/index.html)  
Main PID: 56013 (filebeat)  
CGroup: /system.slice/filebeat.service  
└─56013 /usr/bin/filebeat -c /etc/filebeat/filebeat.yml

Feb 12 14:04:58 localhost.localdomain /usr/bin/filebeat[56013]: transport.go:125: SSL client failed to connect with: dial tcp 192.168.1.117:5044: getsockopt: connection refused  
Feb 12 14:05:30 localhost.localdomain /usr/bin/filebeat[56013]: transport.go:125: SSL client failed to connect with: dial tcp 192.168.1.117:5044: getsockopt: connection refused  
Feb 12 14:06:30 localhost.localdomain /usr/bin/filebeat[56013]: transport.go:125: SSL client failed to connect with: dial tcp 192.168.1.117:5044: getsockopt: connection refused  
Feb 12 14:07:30 localhost.localdomain /usr/bin/filebeat[56013]: transport.go:125: SSL client failed to connect with: dial tcp 192.168.1.117:5044: getsockopt: connection refused  
Feb 12 14:08:30 localhost.localdomain /usr/bin/filebeat[56013]: transport.go:125: SSL client failed to connect with: dial tcp 192.168.1.117:5044: getsockopt: connection refused  
Feb 12 14:09:30 localhost.localdomain /usr/bin/filebeat[56013]: transport.go:125: SSL client failed to connect with: dial tcp 192.168.1.117:5044: getsockopt: connection refused  
Feb 12 14:10:30 localhost.localdomain /usr/bin/filebeat[56013]: transport.go:125: SSL client failed to connect with: dial tcp 192.168.1.117:5044: getsockopt: connection refused  
Feb 12 14:11:30 localhost.localdomain /usr/bin/filebeat[56013]: transport.go:125: SSL client failed to connect with: dial tcp 192.168.1.117:5044: getsockopt: connection refused  
Feb 12 14:12:30 localhost.localdomain /usr/bin/filebeat[56013]: transport.go:125: SSL client failed to connect with: dial tcp 192.168.1.117:5044: getsockopt: connection refused  
Feb 12 14:13:30 localhost.localdomain /usr/bin/filebeat[56013]: transport.go:125: SSL client failed to connect with: dial tcp 192.168.1.117:5044: getsockopt: connection refused

I have configured my filebeat like this :  
tls:

```
  certificate_authorities: ["/etc/ssl/logstash_frwrd.crt"]

  # Certificate for TLS client authentication
  #certificate: "/etc/pki/client/cert.pem"

  # Client Certificate Key
  #certificate_key: "/etc/pki/client/cert.key"

```

and my logstash :  
#input section  
input{  
beats{  
port=\>5044  
ssl=\>true  
ssl\_certificate=\>"/etc/ssl/logstash\_frwrd.crt"  
ssl\_key=\>"/etc/ssl/logstash-forwarder.key"  
}  
}

---

<div class="post-metadata">

**Author:** ![tudor](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/tudor/32/3753_2.png) [@tudor](https://discuss.elastic.co/u/tudor)\
**Post date:** [February 12, 2018, 8:46pm UTC](https://discuss.elastic.co/t/transport-go-125-ssl-client-failed-to-connect/119475/2 "2018-02-12T20:46:21Z")

</div>

Can you run the following:

```auto
filebeat test output

```

From the error, it seems that you get a connection refused error, so perhaps Logstash is not actually running or running on a different IP?

---

<div class="post-metadata">

**Author:** ![Pierre\_What\_s\_Up\_Sca](https://avatars.discourse-cdn.com/v4/letter/p/a9adbd/32.png) [@Pierre\_What\_s\_Up\_Sca](https://discuss.elastic.co/u/Pierre_What_s_Up_Sca)\
**Post date:** [February 13, 2018, 7:10am UTC](https://discuss.elastic.co/t/transport-go-125-ssl-client-failed-to-connect/119475/3 "2018-02-13T07:10:30Z")

</div>

I have this error :  
diap up... ERROR dial tcp 192.168.1.117:5044: getsockopt : connection refused

And the status of logstash is running ...

---

<div class="post-metadata">

**Author:** ![tudor](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/tudor/32/3753_2.png) [@tudor](https://discuss.elastic.co/u/tudor)\
**Post date:** [February 13, 2018, 12:51pm UTC](https://discuss.elastic.co/t/transport-go-125-ssl-client-failed-to-connect/119475/4 "2018-02-13T12:51:30Z")

</div>

I assume also `telnet 192.168.1.117 5044` gives a connection refused, right? It looks like a connectivity issue. I'd recommend first trying `telnet localhost 5044` on the LS machine to make sure the port is locally reachable. Then run `netstat -nlp | grep 5044` on the LS machine to check that LS is listening on the right IP address.

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [March 5, 2018, 1:35pm UTC](https://discuss.elastic.co/t/transport-go-125-ssl-client-failed-to-connect/119475/5 "2018-03-05T13:35:16Z")

</div>

This topic was automatically closed after 21 days. New replies are no longer allowed.
