# TransportNodesStatsAction

**URL:** <https://discuss.elastic.co/t/transportnodesstatsaction/162215>\
**Category:** Elasticsearch\
**Created:** [December 27, 2018, 9:11am UTC](https://discuss.elastic.co/t/transportnodesstatsaction/162215 "2018-12-27T09:11:40Z")\
**Posts on this page:** 4\
**Page:** 1

<div class="post-metadata">

**Author:** ![surprise](https://avatars.discourse-cdn.com/v4/letter/s/e19b73/32.png) [@surprise](https://discuss.elastic.co/u/surprise)\
**Post date:** [December 27, 2018, 9:11am UTC](https://discuss.elastic.co/t/transportnodesstatsaction/162215/1 "2018-12-27T09:11:41Z")

</div>

Hi, everyone. I hava a cluster with seven nodes, four of them are used to store data, and the others are node.master. The elasticsearch version is 5.6.8.  
Recently, we find an exception in log file of node.master. When the exception occurred, the health status of elasticsearch cluster turned to yellow.  
After a period, health status changed to green automically and we did nothing.  
The exception is caused by network connections or other reasons, can anyone help find the reason. Thanks.

log files show the belowing error:  
[DEBUG][o.e.a.a.c.n.s.TransportNodesStatsAction] [node-es1] failed to execute on node [-hY6GENLR32KD-1mIkXgog]  
org.elasticsearch.transport.ReceiveTimeoutTransportException: [node-es1][10.12.10.19:9300][cluster:monitor/nodes/stats[n]] request\_id [41150994] timed out after [15001ms]  
at org.elasticsearch.transport.TransportService$TimeoutHandler.run(TransportService.java:961) [elasticsearch-5.6.8.jar:5.6.8]  
at org.elasticsearch.common.util.concurrent.ThreadContext$ContextPreservingRunnable.run(ThreadContext.java:575) [elasticsearch-5.6.8.jar:5.6.8]  
at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1149) [?:1.8.0\_161]  
at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:624) [?:1.8.0\_161]  
at java.lang.Thread.run(Thread.java:748) [?:1.8.0\_161]  
[2018-12-26T00:26:56,426][DEBUG][o.e.a.a.c.n.s.TransportNodesStatsAction] [node-es1] failed to execute on node [-hY6GENLR32KD-1mIkXgog]  
org.elasticsearch.transport.ReceiveTimeoutTransportException: [node-es1][10.12.10.19:9300][cluster:monitor/nodes/stats[n]] request\_id [41151002] timed out after [15000ms]  
at org.elasticsearch.transport.TransportService$TimeoutHandler.run(TransportService.java:961) [elasticsearch-5.6.8.jar:5.6.8]  
at org.elasticsearch.common.util.concurrent.ThreadContext$ContextPreservingRunnable.run(ThreadContext.java:575) [elasticsearch-5.6.8.jar:5.6.8]  
at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1149) [?:1.8.0\_161]  
at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:624) [?:1.8.0\_161]  
at java.lang.Thread.run(Thread.java:748) [?:1.8.0\_161]

---

<div class="post-metadata">

**Author:** ![DavidTurner](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/davidturner/32/22453_2.png) [@DavidTurner](https://discuss.elastic.co/u/DavidTurner)\
**Post date:** [December 27, 2018, 10:05am UTC](https://discuss.elastic.co/t/transportnodesstatsaction/162215/2 "2018-12-27T10:05:40Z")

</div>

> [@surprise](#):
>
> The exception is caused by network connections or other reasons

This exception could be caused by a transient problem like a connectivity failure or perhaps a long GC pause. In either case the cluster would return to green once the problem went away.

---

<div class="post-metadata">

**Author:** ![surprise](https://avatars.discourse-cdn.com/v4/letter/s/e19b73/32.png) [@surprise](https://discuss.elastic.co/u/surprise)\
**Post date:** [December 28, 2018, 7:01am UTC](https://discuss.elastic.co/t/transportnodesstatsaction/162215/3 "2018-12-28T07:01:32Z")

</div>

Thank you, we will check the network connection and jvm.

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [January 25, 2019, 7:01am UTC](https://discuss.elastic.co/t/transportnodesstatsaction/162215/4 "2019-01-25T07:01:48Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
