# Tribe node set up

**URL:** <https://discuss.elastic.co/t/tribe-node-set-up/48621>\
**Category:** Elasticsearch\
**Created:** [April 28, 2016, 4:28am UTC](https://discuss.elastic.co/t/tribe-node-set-up/48621 "2016-04-28T04:28:29Z")\
**Posts on this page:** 3\
**Page:** 1

<div class="post-metadata">

**Author:** ![chinmoyd](https://avatars.discourse-cdn.com/v4/letter/c/e495f1/32.png) [@chinmoyd](https://discuss.elastic.co/u/chinmoyd)\
**Post date:** [April 28, 2016, 4:28am UTC](https://discuss.elastic.co/t/tribe-node-set-up/48621/1 "2016-04-28T04:28:29Z")

</div>

Hello,

I am trying to set up a tribe node. My elasticsearch.yml is as below. Elastic search version is 2.2.0:

tribe:

t1:  
[cluster.name](http://cluster.name): pr\_site  
discovery.zen.ping.multicast.enabled: false  
discovery.zen.ping.unicast.hosts: ["192.168.192.131:9200"]  
t2:  
[cluster.name](http://cluster.name): ha\_site  
discovery.zen.ping.multicast.enabled: false  
discovery.zen.ping.unicast.hosts: ["192.168.192.195:9200"]

# tribe.on\_conflict: prefer\_t1

# 

**elasticsearch is not getting started due to the below error:**

Exception in thread "main" SettingsException[Failed to load settings from [elasticsearch.yml]]; nested: ElasticsearchParseException[duplicate settings key [[cluster.name](http://cluster.name)] found at line number [106], column number [15], previous value [pr\_site], current value [ha\_site]];  
Likely root cause: ElasticsearchParseException[duplicate settings key [[cluster.name](http://cluster.name)] found at line number [106], column number [15], previous value [pr\_site], current value [ha\_site]]  
at org.elasticsearch.common.settings.loader.XContentSettingsLoader.serializeValue(XContentSettingsLoader.java:147)  
at org.elasticsearch.common.settings.loader.XContentSettingsLoader.serializeObject(XContentSettingsLoader.java:109)  
at org.elasticsearch.common.settings.loader.XContentSettingsLoader.load(XContentSettingsLoader.java:67)  
at org.elasticsearch.common.settings.loader.XContentSettingsLoader.load(XContentSettingsLoader.java:45)  
at org.elasticsearch.common.settings.loader.YamlSettingsLoader.load(YamlSettingsLoader.java:46)  
at org.elasticsearch.common.settings.Settings$Builder.loadFromStream(Settings.java:1074)  
at org.elasticsearch.common.settings.Settings$Builder.loadFromPath(Settings.java:1061)  
at org.elasticsearch.node.internal.InternalSettingsPreparer.prepareEnvironment(InternalSettingsPreparer.java:88)  
at org.elasticsearch.common.cli.CliTool.(CliTool.java:107)  
at org.elasticsearch.common.cli.CliTool.(CliTool.java:100)  
at org.elasticsearch.bootstrap.BootstrapCLIParser.(BootstrapCLIParser.java:48)  
at org.elasticsearch.bootstrap.Bootstrap.init(Bootstrap.java:241)  
at org.elasticsearch.bootstrap.Elasticsearch.main(Elasticsearch.java:35)  
Refer to the log for complete error details.

Please help.

---

<div class="post-metadata">

**Author:** ![chinmoyd](https://avatars.discourse-cdn.com/v4/letter/c/e495f1/32.png) [@chinmoyd](https://discuss.elastic.co/u/chinmoyd)\
**Post date:** [April 28, 2016, 6:41pm UTC](https://discuss.elastic.co/t/tribe-node-set-up/48621/2 "2016-04-28T18:41:57Z")

</div>

Now the earlier error is gone, by re-aligning the text in elasticsearch.yml in tribe as below:  
t1:  
[cluster.name](http://cluster.name): pr\_site  
t2:  
[cluster.name](http://cluster.name): ha\_site

But while starting Kibana I am getting the error -- Unable to create Kibana index ".Kibana". Please help.

Is tribe a full proof feature for production?

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [July 5, 2017, 10:55pm UTC](https://discuss.elastic.co/t/tribe-node-set-up/48621/3 "2017-07-05T22:55:27Z")

</div>


