# Trouble running the ELK-8.3.3 docker-compose instructions. failed to retrieve password hash

**URL:** <https://discuss.elastic.co/t/trouble-running-the-elk-8-3-3-docker-compose-instructions-failed-to-retrieve-password-hash/312403>\
**Category:** Elasticsearch\
**Tags:** docker\
**Created:** [August 18, 2022, 6:26pm UTC](https://discuss.elastic.co/t/trouble-running-the-elk-8-3-3-docker-compose-instructions-failed-to-retrieve-password-hash/312403 "2022-08-18T18:26:41Z")\
**Posts on this page:** 2\
**Page:** 1

<div class="post-metadata">

**Author:** ![Mike\_MacHenry](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/mike_machenry/32/109805_2.png) [@Mike\_MacHenry](https://discuss.elastic.co/u/Mike_MacHenry)\
**Post date:** [August 18, 2022, 6:26pm UTC](https://discuss.elastic.co/t/trouble-running-the-elk-8-3-3-docker-compose-instructions-failed-to-retrieve-password-hash/312403/1 "2022-08-18T18:26:41Z")

</div>

Hey folks,

I have copied the tutorial from [here](https://www.elastic.co/guide/en/elasticsearch/reference/current/docker.html#docker-cli-run-prod-mode) and I have been unable to make the basic tutorial work. I have followed it by copying the docker-compose.yaml and .env file, updating my passwords in the .env, and also vp.max\_map\_count instructions. I'm not sure why it's still not working.

I'm getting some errors in my elasticsearch nodes. docker-compose logs shows me these:

```auto
es02_1 | 17:43:56.701 [elasticsearch[es02][generic][T#2]] DEBUG org.elasticsearch.discovery.PeerFinder - address [172.22.0.3:9300], node [null], requesting [false] discovery result
es02_1 | org.elasticsearch.transport.ConnectTransportException: [][172.22.0.3:9300] connect_exception

```

```auto
es01_1 | 17:44:31.773 [elasticsearch[es01][transport_worker][T#2]] ERROR org.elasticsearch.xpack.security.authc.esnative.ReservedRealm - failed to retrieve password hash for reserved user [kibana_system]
es01_1 | org.elasticsearch.action.UnavailableShardsException: at least one primary shard for the index [.security-7] is unavailable

```

```auto
es03_1 | 17:43:56.261 [elasticsearch[es03][generic][T#3]] DEBUG org.elasticsearch.discovery.PeerFinder - address [172.22.0.3:9300], node [null], requesting [false] discovery result
es03_1 | org.elasticsearch.transport.ConnectTransportException: [][172.22.0.3:9300] connect_exception
... stack trace ...
es03_1 | Caused by: io.netty.channel.AbstractChannel$AnnotatedConnectException: Connection refused: es01/172.22.0.3:9300
es03_1 | Caused by: java.net.ConnectException: Connection refused

```

My files are identical to the docker-compose.yaml and .env used on the tutorial linked above but I have made a couple changes to start it up and then to try to debug.

1. I added some passwords as per the tutorial
2. I changed the ES\_PORT in order to follow a previous post with my same error but no luck
3. I added a log4j2.properties and linked it inside the docker-compose.yaml file just to eliminate all the DEBUG and INFO clouding the logs so I could see and post the errors more easily.

Full logs and files are here: [Elasticsearch demo errors · GitHub](https://gist.github.com/mmachenry/8ad7fcdf102a2074668de7088b3564b5)

I've seen this issue report in this forum but not with my underlying cause and I've not gotten anything to work from those threads. For example one similar issue on this forum suggests changing ES\_PORT from 9200 to 127.0.0.1:9200 which solved the OP's issue. This did not work for me.

Anyone know what I'm doing wrong here?

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [September 15, 2022, 6:26pm UTC](https://discuss.elastic.co/t/trouble-running-the-elk-8-3-3-docker-compose-instructions-failed-to-retrieve-password-hash/312403/2 "2022-09-15T18:26:52Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
