# Trouble Starting up Kibana

**URL:** https://discuss.elastic.co/t/trouble-starting-up-kibana/90316
**Category:** Kibana
**Created:** [June 21, 2017, 3:01pm UTC](https://discuss.elastic.co/t/trouble-starting-up-kibana/90316 "2017-06-21T15:01:15Z")
**Posts on this page:** 3
**Page:** 1

<div class="post-metadata">

### Author: ![tman](https://avatars.discourse-cdn.com/v4/letter/t/d78d45/32.png) [@tman](https://discuss.elastic.co/u/tman)
#### Post date: [June 21, 2017, 3:01pm UTC](https://discuss.elastic.co/t/trouble-starting-up-kibana/90316/1 "2017-06-21T15:01:15Z")

</div>

I am setting up an ELK stack in AWS. I have the kibana server ready. When I started it up initially, it ran fine.

I then made a few changes to the /etc/kibana/kibana.yml config file, to allow remote connections instead of proxying via nginx...

After the changes, I can no longer do a service kibana restart, but I can start it manually via  
./kibana -c /etc/kibana/kibana.yml

My only changes are the following:  
I uncommented 4 lines in the file, I specified logging destination, pid file, and logging.verbose

server.host: "0.0.0.0"  
pid.file: /var/run/kibana.pid  
logging.dest: /var/log/kibana/kibana.log  
logging.verbose: true

If anyone can help me understand why I'm now unable to run kibana, I would appreciate it.

Output of service kibana status...

> kibana.service - Kibana  
> Loaded: loaded (/etc/systemd/system/kibana.service; enabled; vendor preset: enabled)  
> Active: inactive (dead) (Result: exit-code) since Tue 2017-06-20 16:22:25 UTC; 22h ago  
> Process: 1244 ExecStart=/usr/share/kibana/bin/kibana -c /etc/kibana/kibana.yml (code=exited, status=1/FAILURE)  
> Main PID: 1244 (code=exited, status=1/FAILURE)

> Jun 20 16:22:25 ip-10-5-5-188 systemd[1]: kibana.service: Main process exited, code=exited, status=1/FAILURE  
> Jun 20 16:22:25 ip-10-5-5-188 systemd[1]: kibana.service: Unit entered failed state.  
> Jun 20 16:22:25 ip-10-5-5-188 systemd[1]: kibana.service: Failed with result 'exit-code'.  
> Jun 20 16:22:25 ip-10-5-5-188 systemd[1]: kibana.service: Service hold-off time over, scheduling restart.  
> Jun 20 16:22:25 ip-10-5-5-188 systemd[1]: Stopped Kibana.  
> Jun 20 16:22:25 ip-10-5-5-188 systemd[1]: kibana.service: Start request repeated too quickly.  
> Jun 20 16:22:25 ip-10-5-5-188 systemd[1]: Failed to start Kibana.

---

<div class="post-metadata">

### Author: ![tsullivan](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/tsullivan/32/31077_2.png) [@tsullivan](https://discuss.elastic.co/u/tsullivan)
#### Post date: [June 21, 2017, 9:55pm UTC](https://discuss.elastic.co/t/trouble-starting-up-kibana/90316/2 "2017-06-21T21:55:30Z")

</div>

This looks like a similar problem to: [https://github.com/elastic/kibana/issues/7041](https://github.com/elastic/kibana/issues/7041)

Make sure the kibana user of the unix system has write permission to the log file.

Hope that helps!

---

<div class="post-metadata">

### Author: ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)
#### Post date: [July 19, 2017, 9:55pm UTC](https://discuss.elastic.co/t/trouble-starting-up-kibana/90316/3 "2017-07-19T21:55:49Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
