# Trouble with x-pack trial-version on ELK 7

**URL:** https://discuss.elastic.co/t/trouble-with-x-pack-trial-version-on-elk-7/177665
**Category:** Elasticsearch
**Tags:** license
**Created:** [April 19, 2019, 7:55pm UTC](https://discuss.elastic.co/t/trouble-with-x-pack-trial-version-on-elk-7/177665 "2019-04-19T19:55:31Z")
**Posts on this page:** 2
**Page:** 1

<div class="post-metadata">

### Author: ![abc345](https://avatars.discourse-cdn.com/v4/letter/a/ba9def/32.png) [@abc345](https://discuss.elastic.co/u/abc345)
#### Post date: [April 19, 2019, 7:55pm UTC](https://discuss.elastic.co/t/trouble-with-x-pack-trial-version-on-elk-7/177665/1 "2019-04-19T19:55:31Z")

</div>

I installed ELK docker v7.0 and activated the trial version of xpack. I have mentioned "xpack.security.enabled: true" in the elasticsearch.yml.  
when I check through the get /license, it shows that my trial-license is activated. The same message is reflected in the Kibana UI too, but when I try to setup the passwords for the built-in-users, I get the following error:

/# /opt/elasticsearch/bin/elasticsearch-setup-passwords interactive

Unexpected response code [500] from calling GET [http://172.17.0.2:9200/\_security/\_authenticate?pretty](http://172.17.0.2:9200/_security/_authenticate?pretty)  
It doesn't look like the X-Pack security feature is enabled on this Elasticsearch node.  
Please check if you have enabled X-Pack security in your elasticsearch.yml configuration file.  
ERROR: X-Pack Security is disabled by configuration.

---

<div class="post-metadata">

### Author: ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)
#### Post date: [May 17, 2019, 7:55pm UTC](https://discuss.elastic.co/t/trouble-with-x-pack-trial-version-on-elk-7/177665/2 "2019-05-17T19:55:34Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
