# Troubles starting kibana.service after the upgrade from 6.8.22 to 7.14.2

**URL:** <https://discuss.elastic.co/t/troubles-starting-kibana-service-after-the-upgrade-from-6-8-22-to-7-14-2/294919>\
**Category:** Kibana\
**Created:** [January 20, 2022, 9:47am UTC](https://discuss.elastic.co/t/troubles-starting-kibana-service-after-the-upgrade-from-6-8-22-to-7-14-2/294919 "2022-01-20T09:47:10Z")\
**Posts on this page:** 5\
**Page:** 1

<div class="post-metadata">

**Author:** ![Penchev](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/penchev/32/100328_2.png) [@Penchev](https://discuss.elastic.co/u/Penchev)\
**Post date:** [January 20, 2022, 9:47am UTC](https://discuss.elastic.co/t/troubles-starting-kibana-service-after-the-upgrade-from-6-8-22-to-7-14-2/294919/1 "2022-01-20T09:47:10Z")

</div>

Hi,

I have the following errors when starting Kibana:

```auto
Jan 20 03:22:59 myserver kibana[30701]: Cannot update parameter [index] from [true] to [false],
Jan 20 03:22:59 myserver kibana[30701]: FATAL Error: Unable to complete saved object migrations for the [.kibana] index. Please check the health of your Elasticsearch cluster and try again. Unexpected Elasticsearch ResponseError

```

I have tried this [7.12.0 upgrade migrations fail with timeout\_exception or receive\_timeout\_transport\_exception · Issue #95321 · elastic/kibana · GitHub](https://github.com/elastic/kibana/issues/95321), but it doesn't help.

Any ideas how to solve this?

Thanks!  
P

---

<div class="post-metadata">

**Author:** ![Penchev](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/penchev/32/100328_2.png) [@Penchev](https://discuss.elastic.co/u/Penchev)\
**Post date:** [January 20, 2022, 2:05pm UTC](https://discuss.elastic.co/t/troubles-starting-kibana-service-after-the-upgrade-from-6-8-22-to-7-14-2/294919/2 "2022-01-20T14:05:01Z")

</div>

This is more detailed version of the error message I receive;

{"type":"log","@timestamp":"2022-01-20T08:57:12-05:00","tags":["fatal","root"],"pid":21219,"message":"Error: **Unable to complete saved object migrations for the [.kibana] index. Please check the health of your Elasticsearch cluster and try again. Unexpected Elasticsearch ResponseError: statusCode: 400, method: PUT, url: /.kibana\_7.14.2\_001/\_mapping?timeout=60s error: [illegal\_argument\_exception]: Mapper for [visualization.uiStateJSON] conflicts with existing mapper:\n\tCannot update parameter [index] from [true] to [false],\n at migrationStateActionMachine** (/usr/share/kibana/src/core/server/saved\_objects/migrationsv2/migrations\_state\_action\_machine.js:172:13)\n at processTicksAndRejections (internal/process/task\_queues.js:95:5)\n at async Promise.all (index 0)\n at SavedObjectsService.start (/usr/share/kibana/src/core/server/saved\_objects/saved\_objects\_service.js:164:7)\n at Server.start (/usr/share/kibana/src/core/server/server.js:274:31)\n at Root.start (/usr/share/kibana/src/core/server/root/index.js:55:14)\n at bootstrap (/usr/share/kibana/src/core/server/bootstrap.js:98:5)\n at Command. (/usr/share/kibana/src/cli/serve/serve.js:224:5)"}

---

<div class="post-metadata">

**Author:** ![Penchev](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/penchev/32/100328_2.png) [@Penchev](https://discuss.elastic.co/u/Penchev)\
**Post date:** [January 24, 2022, 3:54pm UTC](https://discuss.elastic.co/t/troubles-starting-kibana-service-after-the-upgrade-from-6-8-22-to-7-14-2/294919/3 "2022-01-24T15:54:05Z")

</div>

Ping... 🙂

---

<div class="post-metadata">

**Author:** ![Penchev](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/penchev/32/100328_2.png) [@Penchev](https://discuss.elastic.co/u/Penchev)\
**Post date:** [January 27, 2022, 7:52am UTC](https://discuss.elastic.co/t/troubles-starting-kibana-service-after-the-upgrade-from-6-8-22-to-7-14-2/294919/4 "2022-01-27T07:52:32Z")

</div>

Solved.  
If nobody helps you help yourself.  
Deleted all .kibana indices, restarted the kibana.service and Kibana UI is accessible.

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [February 24, 2022, 7:53am UTC](https://discuss.elastic.co/t/troubles-starting-kibana-service-after-the-upgrade-from-6-8-22-to-7-14-2/294919/5 "2022-02-24T07:53:05Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
