# Trying to configure dedicated elasticsearch server with production server and getting below issue

**URL:** <https://discuss.elastic.co/t/trying-to-configure-dedicated-elasticsearch-server-with-production-server-and-getting-below-issue/21597>\
**Category:** Elasticsearch\
**Created:** [January 13, 2015, 6:43am UTC](https://discuss.elastic.co/t/trying-to-configure-dedicated-elasticsearch-server-with-production-server-and-getting-below-issue/21597 "2015-01-13T06:43:47Z")\
**Posts on this page:** 5\
**Page:** 1

<div class="post-metadata">

**Author:** ![Rikhi](https://avatars.discourse-cdn.com/v4/letter/r/838e76/32.png) [@Rikhi](https://discuss.elastic.co/u/Rikhi)\
**Post date:** [January 13, 2015, 6:43am UTC](https://discuss.elastic.co/t/trying-to-configure-dedicated-elasticsearch-server-with-production-server-and-getting-below-issue/21597/1 "2015-01-13T06:43:47Z")

</div>

_Java code -_  
m.put("cluster.name", elasticclustername);  
Settings s = ImmutableSettings.settingsBuilder().put(m).build();  
client = new TransportClient(s).addTransportAddress(new  
InetSocketTransportAddress(elastichost, elasticport));

_issue on elasticsearch server log -_

[2015-01-12 22:10:10,664][WARN][river.rabbitmq] [Hitman]  
[rabbitmq][my\_river] failed to created a connection / channel  
java.net.ConnectException: Connection refused

\*issue on production server - \*

2015-01-12 22:20:53 DEBUG netty:94 - [Dansen Macabre] connected to node  
[[#transport#-1][inet[/:9300]]]  
2015-01-12 22:20:53 WARN netty:114 - [Dansen Macabre] Message not fully  
read (response) for [10] handler  
future(org.elasticsearch.client.transport.TransportClientNodesService$SimpleNodeSampler$1@3c08e293),  
error [true], resetting  
2015-01-12 22:20:53 INFO transport:109 - [Dansen Macabre] failed to get  
node info for [#transport#-1][inet[/:9300]],  
disconnecting...  
org.elasticsearch.transport.RemoteTransportException: Failed to deserialize  
exception response from stream  
Caused by: org.elasticsearch.transport.TransportSerializationException:  
Failed to deserialize exception response from stream  
at  
org.elasticsearch.transport.netty.MessageChannelHandler.handlerResponseError(MessageChannelHandler.java:171)  
at  
org.elasticsearch.transport.netty.MessageChannelHandler.messageReceived(MessageChannelHandler.java:125).......

as i am new to elasticsearch, i can't get where i am wrong.  
any help will be appreciated.

--  
You received this message because you are subscribed to the Google Groups "elasticsearch" group.  
To unsubscribe from this group and stop receiving emails from it, send an email to [elasticsearch+unsubscribe@googlegroups.com](mailto:elasticsearch+unsubscribe@googlegroups.com).  
To view this discussion on the web visit [https://groups.google.com/d/msgid/elasticsearch/b2a5b247-89ec-473c-8601-d04d0ffc67bb%40googlegroups.com](https://groups.google.com/d/msgid/elasticsearch/b2a5b247-89ec-473c-8601-d04d0ffc67bb%40googlegroups.com).  
For more options, visit [https://groups.google.com/d/optout](https://groups.google.com/d/optout).

---

<div class="post-metadata">

**Author:** ![dadoonet](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/dadoonet/32/137187_2.png) [@dadoonet](https://discuss.elastic.co/u/dadoonet)\
**Post date:** [January 13, 2015, 6:55am UTC](https://discuss.elastic.co/t/trying-to-configure-dedicated-elasticsearch-server-with-production-server-and-getting-below-issue/21597/2 "2015-01-13T06:55:15Z")

</div>

1. remove any plugin. Just try to make your Java client connecting to your cluster.
2. Use exactly the same Java version and the same elasticsearch version on both ends.

HTH

--  
David 😉  
Twitter : @dadoonet / @elasticsearchfr / @scrutmydocs

> Le 13 janv. 2015 à 07:43, Rikhi [rikhi.05@gmail.com](mailto:rikhi.05@gmail.com) a écrit :
> 
> Java code -
> 
> m.put("cluster.name", elasticclustername);  
> Settings s = ImmutableSettings.settingsBuilder().put(m).build();  
> client = new TransportClient(s).addTransportAddress(new InetSocketTransportAddress(elastichost, elasticport));
> 
> issue on elasticsearch server log -
> 
> [2015-01-12 22:10:10,664][WARN][river.rabbitmq] [Hitman] [rabbitmq][my\_river] failed to created a connection / channel  
> java.net.ConnectException: Connection refused
> 
> issue on production server -
> 
> 2015-01-12 22:20:53 DEBUG netty:94 - [Dansen Macabre] connected to node [[#transport#-1][inet[/:9300]]]  
> 2015-01-12 22:20:53 WARN netty:114 - [Dansen Macabre] Message not fully read (response) for [10] handler future(org.elasticsearch.client.transport.TransportClientNodesService$SimpleNodeSampler$1@3c08e293), error [true], resetting  
> 2015-01-12 22:20:53 INFO transport:109 - [Dansen Macabre] failed to get node info for [#transport#-1][inet[/:9300]], disconnecting...  
> org.elasticsearch.transport.RemoteTransportException: Failed to deserialize exception response from stream  
> Caused by: org.elasticsearch.transport.TransportSerializationException: Failed to deserialize exception response from stream  
> at org.elasticsearch.transport.netty.MessageChannelHandler.handlerResponseError(MessageChannelHandler.java:171)  
> at org.elasticsearch.transport.netty.MessageChannelHandler.messageReceived(MessageChannelHandler.java:125).......
> 
> ## as i am new to elasticsearch, i can't get where i am wrong. any help will be appreciated.
> 
> You received this message because you are subscribed to the Google Groups "elasticsearch" group.  
> To unsubscribe from this group and stop receiving emails from it, send an email to [elasticsearch+unsubscribe@googlegroups.com](mailto:elasticsearch+unsubscribe@googlegroups.com).  
> To view this discussion on the web visit [https://groups.google.com/d/msgid/elasticsearch/b2a5b247-89ec-473c-8601-d04d0ffc67bb%40googlegroups.com](https://groups.google.com/d/msgid/elasticsearch/b2a5b247-89ec-473c-8601-d04d0ffc67bb%40googlegroups.com).  
> For more options, visit [https://groups.google.com/d/optout](https://groups.google.com/d/optout).

--  
You received this message because you are subscribed to the Google Groups "elasticsearch" group.  
To unsubscribe from this group and stop receiving emails from it, send an email to [elasticsearch+unsubscribe@googlegroups.com](mailto:elasticsearch+unsubscribe@googlegroups.com).  
To view this discussion on the web visit [https://groups.google.com/d/msgid/elasticsearch/1E009870-82E1-4695-B474-09FFB2FA0F5D%40pilato.fr](https://groups.google.com/d/msgid/elasticsearch/1E009870-82E1-4695-B474-09FFB2FA0F5D%40pilato.fr).  
For more options, visit [https://groups.google.com/d/optout](https://groups.google.com/d/optout).

---

<div class="post-metadata">

**Author:** ![Rikhi](https://avatars.discourse-cdn.com/v4/letter/r/838e76/32.png) [@Rikhi](https://discuss.elastic.co/u/Rikhi)\
**Post date:** [January 13, 2015, 1:16pm UTC](https://discuss.elastic.co/t/trying-to-configure-dedicated-elasticsearch-server-with-production-server-and-getting-below-issue/21597/3 "2015-01-13T13:16:45Z")

</div>

Hi David,

```
 changed the version of elasticsearch now i have same version of jvm 

```

and elasticsearch on both server but now i have below issue

- 

```
Issue on elasticsearch server* - 

```

[2015-01-13 05:02:16,737][WARN][cluster.metadata]  
[Blindside] [test005] failed to create  
org.elasticsearch.indices.IndexCreationException: [test005] failed to  
create index  
at  
org.elasticsearch.indices.InternalIndicesService.createIndex(InternalIndicesService.java:289)  
....

\*issue on production server - \*

2015-01-13 04:47:22 DEBUG RabbitMqRiverIndexer:46 - :::  
createindexresponseactionGet :::  
2015-01-13 04:47:22 ERROR RabbitMqRiverIndexer:121 -  
org.elasticsearch.indices.IndexCreationException: [test005] failed to  
create index  
2015-01-13 04:47:22 ERROR BusinessLogic:141 -  
com.arosys.customexception.CustomException: Error  
ClassName--com.arosys.doqeap.esearch.RabbitMqRiverIndexer : :  
ErrorMessage-[test005] failed to create index  
2015-01-13 04:47:22 DEBUG BusinessLogic:159 - map--{errormessage=Error  
ClassName--com.arosys.doqeap.esearch.RabbitMqRiverIndexer : :  
ErrorMessage-[test005] failed to create index, instanceid=null,  
processid=null, responseexchangename=exchange\_LifeCycleProcess--2.0--8,  
responsemessageheader=elasticmessageheader, responsequeuename=null,  
responseroutekeyname=routekey\_LifeCycleProcess--2.0--8, status=FAIL,  
taskid=null}

what should i do now please help.

On Tuesday, January 13, 2015 at 12:25:36 PM UTC+5:30, David Pilato wrote:

> 1. remove any plugin. Just try to make your Java client connecting to your  
> cluster.
> 2. Use exactly the same Java version and the same elasticsearch version on  
> both ends.
> 
> HTH
> 
> --  
> David 😉  
> Twitter : @dadoonet / @elasticsearchfr / @scrutmydocs
> 
> Le 13 janv. 2015 à 07:43, Rikhi \<[rikh...@gmail.com](mailto:rikh...@gmail.com) \<javascript:\>\> a  
> écrit :
> 
> _Java code -_  
> m.put("cluster.name", elasticclustername);  
> Settings s = ImmutableSettings.settingsBuilder().put(m).build();  
> client = new TransportClient(s).addTransportAddress(new  
> InetSocketTransportAddress(elastichost, elasticport));
> 
> _issue on elasticsearch server log -_
> 
> [2015-01-12 22:10:10,664][WARN][river.rabbitmq] [Hitman]  
> [rabbitmq][my\_river] failed to created a connection / channel  
> java.net.ConnectException: Connection refused
> 
> \*issue on production server - \*
> 
> 2015-01-12 22:20:53 DEBUG netty:94 - [Dansen Macabre] connected to node  
> [[#transport#-1][inet[/:9300]]]  
> 2015-01-12 22:20:53 WARN netty:114 - [Dansen Macabre] Message not fully  
> read (response) for [10] handler  
> future(org.elasticsearch.client.transport.TransportClientNodesService$SimpleNodeSampler$1@3c08e293),  
> error [true], resetting  
> 2015-01-12 22:20:53 INFO transport:109 - [Dansen Macabre] failed to get  
> node info for [#transport#-1][inet[/:9300]],  
> disconnecting...  
> org.elasticsearch.transport.RemoteTransportException: Failed to  
> deserialize exception response from stream  
> Caused by: org.elasticsearch.transport.TransportSerializationException:  
> Failed to deserialize exception response from stream  
> at  
> org.elasticsearch.transport.netty.MessageChannelHandler.handlerResponseError(MessageChannelHandler.java:171)  
> at  
> org.elasticsearch.transport.netty.MessageChannelHandler.messageReceived(MessageChannelHandler.java:125).......
> 
> as i am new to elasticsearch, i can't get where i am wrong.  
> any help will be appreciated.
> 
> --  
> You received this message because you are subscribed to the Google Groups  
> "elasticsearch" group.  
> To unsubscribe from this group and stop receiving emails from it, send an  
> email to [elasticsearc...@googlegroups.com](mailto:elasticsearc...@googlegroups.com) \<javascript:\>.  
> To view this discussion on the web visit  
> [https://groups.google.com/d/msgid/elasticsearch/b2a5b247-89ec-473c-8601-d04d0ffc67bb%40googlegroups.com](https://groups.google.com/d/msgid/elasticsearch/b2a5b247-89ec-473c-8601-d04d0ffc67bb%40googlegroups.com)  
> [https://groups.google.com/d/msgid/elasticsearch/b2a5b247-89ec-473c-8601-d04d0ffc67bb%40googlegroups.com?utm\_medium=email&utm\_source=footer](https://groups.google.com/d/msgid/elasticsearch/b2a5b247-89ec-473c-8601-d04d0ffc67bb%40googlegroups.com?utm_medium=email&utm_source=footer)  
> .  
> For more options, visit [https://groups.google.com/d/optout](https://groups.google.com/d/optout).

--  
You received this message because you are subscribed to the Google Groups "elasticsearch" group.  
To unsubscribe from this group and stop receiving emails from it, send an email to [elasticsearch+unsubscribe@googlegroups.com](mailto:elasticsearch+unsubscribe@googlegroups.com).  
To view this discussion on the web visit [https://groups.google.com/d/msgid/elasticsearch/64ccdc02-a25d-4d10-b39a-b0337f8d9bd9%40googlegroups.com](https://groups.google.com/d/msgid/elasticsearch/64ccdc02-a25d-4d10-b39a-b0337f8d9bd9%40googlegroups.com).  
For more options, visit [https://groups.google.com/d/optout](https://groups.google.com/d/optout).

---

<div class="post-metadata">

**Author:** ![dadoonet](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/dadoonet/32/137187_2.png) [@dadoonet](https://discuss.elastic.co/u/dadoonet)\
**Post date:** [January 13, 2015, 2:32pm UTC](https://discuss.elastic.co/t/trying-to-configure-dedicated-elasticsearch-server-with-production-server-and-getting-below-issue/21597/4 "2015-01-13T14:32:18Z")

</div>

I have no idea based on the details you are giving.  
May be you could explain what you are exactly doing and how?

It sounds like you can not create your index. But no clues on the reason.

--  
David Pilato | Technical Advocate | [Elasticsearch.com](http://Elasticsearch.com)  
@dadoonet [https://twitter.com/dadoonet](https://twitter.com/dadoonet) | @elasticsearchfr [https://twitter.com/elasticsearchfr](https://twitter.com/elasticsearchfr) | @scrutmydocs [https://twitter.com/scrutmydocs](https://twitter.com/scrutmydocs)

> Le 13 janv. 2015 à 14:16, Rikhi [rikhi.05@gmail.com](mailto:rikhi.05@gmail.com) a écrit :
> 
> Hi David,
> 
> ```
> changed the version of elasticsearch now i have same version of jvm and elasticsearch on both server but now i have below issue
>  
> Issue on elasticsearch server - 
> 
> [2015-01-13 05:02:16,737][WARN][cluster.metadata] [Blindside] [test005] failed to create
> 
> ```
> 
> org.elasticsearch.indices.IndexCreationException: [test005] failed to create index  
> at org.elasticsearch.indices.InternalIndicesService.createIndex(InternalIndicesService.java:289)  
> ....
> 
> ```
> issue on production server - 
> 
> 2015-01-13 04:47:22 DEBUG RabbitMqRiverIndexer:46 - ::: createindexresponseactionGet :::
> 2015-01-13 04:47:22 ERROR RabbitMqRiverIndexer:121 - org.elasticsearch.indices.IndexCreationException: [test005] failed to create index
> 2015-01-13 04:47:22 ERROR BusinessLogic:141 - com.arosys.customexception.CustomException: Error ClassName--com.arosys.doqeap.esearch.RabbitMqRiverIndexer : : ErrorMessage-[test005] failed to create index
> 2015-01-13 04:47:22 DEBUG BusinessLogic:159 - map--{errormessage=Error ClassName--com.arosys.doqeap.esearch.RabbitMqRiverIndexer : : ErrorMessage-[test005] failed to create index, instanceid=null, processid=null, responseexchangename=exchange_LifeCycleProcess--2.0--8, responsemessageheader=elasticmessageheader, responsequeuename=null, responseroutekeyname=routekey_LifeCycleProcess--2.0--8, status=FAIL, taskid=null}
> 
> ```
> 
> what should i do now please help.
> 
> On Tuesday, January 13, 2015 at 12:25:36 PM UTC+5:30, David Pilato wrote:
> 
> 1. remove any plugin. Just try to make your Java client connecting to your cluster.
> 2. Use exactly the same Java version and the same elasticsearch version on both ends.
> 
> HTH
> 
> --  
> David 😉  
> Twitter : @dadoonet / @elasticsearchfr / @scrutmydocs
> 
> Le 13 janv. 2015 à 07:43, Rikhi \<[rikh...@gmail.com](mailto:rikh...@gmail.com) \<javascript:\>\> a écrit :
> 
> > Java code -
> > 
> > m.put("cluster.name [http://cluster.name/](http://cluster.name/)", elasticclustername);  
> > Settings s = ImmutableSettings.settingsBuilder().put(m).build();  
> > client = new TransportClient(s).addTransportAddress(new InetSocketTransportAddress(elastichost, elasticport));
> > 
> > issue on elasticsearch server log -
> > 
> > [2015-01-12 22:10:10,664][WARN][river.rabbitmq] [Hitman] [rabbitmq][my\_river] failed to created a connection / channel  
> > java.net.ConnectException: Connection refused
> > 
> > issue on production server -
> > 
> > 2015-01-12 22:20:53 DEBUG netty:94 - [Dansen Macabre] connected to node [[#transport#-1][inet[/:9300]]]  
> > 2015-01-12 22:20:53 WARN netty:114 - [Dansen Macabre] Message not fully read (response) for [10] handler future(org.elasticsearch.client.transport.TransportClientNodesService$SimpleNodeSampler$1@3c08e293), error [true], resetting  
> > 2015-01-12 22:20:53 INFO transport:109 - [Dansen Macabre] failed to get node info for [#transport#-1][inet[/:9300]], disconnecting...  
> > org.elasticsearch.transport.RemoteTransportException: Failed to deserialize exception response from stream  
> > Caused by: org.elasticsearch.transport.TransportSerializationException: Failed to deserialize exception response from stream  
> > at org.elasticsearch.transport.netty.MessageChannelHandler.handlerResponseError(MessageChannelHandler.java:171)  
> > at org.elasticsearch.transport.netty.MessageChannelHandler.messageReceived(MessageChannelHandler.java:125).......
> > 
> > as i am new to elasticsearch, i can't get where i am wrong.  
> > any help will be appreciated.
> > 
> > --  
> > You received this message because you are subscribed to the Google Groups "elasticsearch" group.  
> > To unsubscribe from this group and stop receiving emails from it, send an email to [elasticsearc...@googlegroups.com](mailto:elasticsearc...@googlegroups.com) \<javascript:\>.  
> > To view this discussion on the web visit [https://groups.google.com/d/msgid/elasticsearch/b2a5b247-89ec-473c-8601-d04d0ffc67bb%40googlegroups.com](https://groups.google.com/d/msgid/elasticsearch/b2a5b247-89ec-473c-8601-d04d0ffc67bb%40googlegroups.com) [https://groups.google.com/d/msgid/elasticsearch/b2a5b247-89ec-473c-8601-d04d0ffc67bb%40googlegroups.com?utm\_medium=email&utm\_source=footer](https://groups.google.com/d/msgid/elasticsearch/b2a5b247-89ec-473c-8601-d04d0ffc67bb%40googlegroups.com?utm_medium=email&utm_source=footer).  
> > For more options, visit [https://groups.google.com/d/optout](https://groups.google.com/d/optout) [https://groups.google.com/d/optout](https://groups.google.com/d/optout).
> 
> --  
> You received this message because you are subscribed to the Google Groups "elasticsearch" group.  
> To unsubscribe from this group and stop receiving emails from it, send an email to [elasticsearch+unsubscribe@googlegroups.com](mailto:elasticsearch+unsubscribe@googlegroups.com) [mailto:elasticsearch+unsubscribe@googlegroups.com](mailto:elasticsearch+unsubscribe@googlegroups.com).  
> To view this discussion on the web visit [https://groups.google.com/d/msgid/elasticsearch/64ccdc02-a25d-4d10-b39a-b0337f8d9bd9%40googlegroups.com](https://groups.google.com/d/msgid/elasticsearch/64ccdc02-a25d-4d10-b39a-b0337f8d9bd9%40googlegroups.com) [https://groups.google.com/d/msgid/elasticsearch/64ccdc02-a25d-4d10-b39a-b0337f8d9bd9%40googlegroups.com?utm\_medium=email&utm\_source=footer](https://groups.google.com/d/msgid/elasticsearch/64ccdc02-a25d-4d10-b39a-b0337f8d9bd9%40googlegroups.com?utm_medium=email&utm_source=footer).  
> For more options, visit [https://groups.google.com/d/optout](https://groups.google.com/d/optout) [https://groups.google.com/d/optout](https://groups.google.com/d/optout).

--  
You received this message because you are subscribed to the Google Groups "elasticsearch" group.  
To unsubscribe from this group and stop receiving emails from it, send an email to [elasticsearch+unsubscribe@googlegroups.com](mailto:elasticsearch+unsubscribe@googlegroups.com).  
To view this discussion on the web visit [https://groups.google.com/d/msgid/elasticsearch/5B0D3162-9E74-43FC-A9B9-1E53DEDB5A54%40pilato.fr](https://groups.google.com/d/msgid/elasticsearch/5B0D3162-9E74-43FC-A9B9-1E53DEDB5A54%40pilato.fr).  
For more options, visit [https://groups.google.com/d/optout](https://groups.google.com/d/optout).

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [July 6, 2017, 12:39am UTC](https://discuss.elastic.co/t/trying-to-configure-dedicated-elasticsearch-server-with-production-server-and-getting-below-issue/21597/5 "2017-07-06T00:39:22Z")

</div>


