# Trying to start the bitbucket server, but throwing an error stating "BIND TRANSPORT EXCEPTION"

**URL:** <https://discuss.elastic.co/t/trying-to-start-the-bitbucket-server-but-throwing-an-error-stating-bind-transport-exception/168859>\
**Category:** Elasticsearch\
**Created:** [February 18, 2019, 3:32pm UTC](https://discuss.elastic.co/t/trying-to-start-the-bitbucket-server-but-throwing-an-error-stating-bind-transport-exception/168859 "2019-02-18T15:32:29Z")\
**Posts on this page:** 5\
**Page:** 1

<div class="post-metadata">

**Author:** ![manoharreddy](https://avatars.discourse-cdn.com/v4/letter/m/c67d28/32.png) [@manoharreddy](https://discuss.elastic.co/u/manoharreddy)\
**Post date:** [February 18, 2019, 3:32pm UTC](https://discuss.elastic.co/t/trying-to-start-the-bitbucket-server-but-throwing-an-error-stating-bind-transport-exception/168859/1 "2019-02-18T15:32:29Z")

</div>

I'm getting below error. Kindly help me in resolving the same.

[2019-02-18T15:18:21,418][ERROR][o.e.b.Bootstrap] [bitbucket\_bundled] Exception  
org.elasticsearch.transport.BindTransportException: Failed to bind to [7993]  
at org.elasticsearch.transport.TcpTransport.bindToPort(TcpTransport.java:793) ~[elasticsearch-5.5.3.jar:5.5.3]  
at org.elasticsearch.transport.TcpTransport.bindServer(TcpTransport.java:758) ~[elasticsearch-5.5.3.jar:5.5.3]  
at org.elasticsearch.transport.netty4.Netty4Transport.doStart(Netty4Transport.java:173) ~[?:?]  
at org.elasticsearch.common.component.AbstractLifecycleComponent.start(AbstractLifecycleComponent.java:69) ~[elasticsearch-5.5.3.jar:5.5.3]  
at org.elasticsearch.transport.TransportService.doStart(TransportService.java:209) ~[elasticsearch-5.5.3.jar:5.5.3]  
at org.elasticsearch.common.component.AbstractLifecycleComponent.start(AbstractLifecycleComponent.java:69) ~[elasticsearch-5.5.3.jar:5.5.3]  
at org.elasticsearch.node.Node.start(Node.java:692) ~[elasticsearch-5.5.3.jar:5.5.3]  
at org.elasticsearch.bootstrap.Bootstrap.start(Bootstrap.java:277) ~[elasticsearch-5.5.3.jar:5.5.3]  
at org.elasticsearch.bootstrap.Bootstrap.init(Bootstrap.java:360) [elasticsearch-5.5.3.jar:5.5.3]  
at org.elasticsearch.bootstrap.Elasticsearch.init(Elasticsearch.java:123) [elasticsearch-5.5.3.jar:5.5.3]  
at org.elasticsearch.bootstrap.Elasticsearch.execute(Elasticsearch.java:114) [elasticsearch-5.5.3.jar:5.5.3]  
at org.elasticsearch.cli.EnvironmentAwareCommand.execute(EnvironmentAwareCommand.java:67) [elasticsearch-5.5.3.jar:5.5.3]  
at org.elasticsearch.cli.Command.mainWithoutErrorHandling(Command.java:122) [elasticsearch-5.5.3.jar:5.5.3]  
at org.elasticsearch.cli.Command.main(Command.java:88) [elasticsearch-5.5.3.jar:5.5.3]  
at org.elasticsearch.bootstrap.Elasticsearch.main(Elasticsearch.java:91) [elasticsearch-5.5.3.jar:5.5.3]  
at org.elasticsearch.bootstrap.Elasticsearch.main(Elasticsearch.java:84) [elasticsearch-5.5.3.jar:5.5.3]  
Caused by: java.net.BindException: Address already in use  
at sun.nio.ch.Net.bind0(Native Method) ~[?:?]  
at sun.nio.ch.Net.bind(Net.java:433) ~[?:?]  
at sun.nio.ch.Net.bind(Net.java:425) ~[?:?]  
at sun.nio.ch.ServerSocketChannelImpl.bind(ServerSocketChannelImpl.java:223) ~[?:?]  
at io.netty.channel.socket.nio.NioServerSocketChannel.doBind(NioServerSocketChannel.java:128) ~[?:?]  
at io.netty.channel.AbstractChannel$AbstractUnsafe.bind(AbstractChannel.java:554) ~[?:?]  
at io.netty.channel.DefaultChannelPipeline$HeadContext.bind(DefaultChannelPipeline.java:1258) ~[?:?]  
at io.netty.channel.AbstractChannelHandlerContext.invokeBind(AbstractChannelHandlerContext.java:501) ~[?:?]  
at io.netty.channel.AbstractChannelHandlerContext.bind(AbstractChannelHandlerContext.java:486) ~[?:?]  
at io.netty.channel.DefaultChannelPipeline.bind(DefaultChannelPipeline.java:980) ~[?:?]  
at io.netty.channel.AbstractChannel.bind(AbstractChannel.java:250) ~[?:?]  
at io.netty.bootstrap.AbstractBootstrap$2.run(AbstractBootstrap.java:365) ~[?:?]  
at io.netty.util.concurrent.AbstractEventExecutor.safeExecute(AbstractEventExecutor.java:163) ~[?:?]  
at io.netty.util.concurrent.SingleThreadEventExecutor.runAllTasks(SingleThreadEventExecutor.java:403) ~[?:?]  
at io.netty.channel.nio.NioEventLoop.run(NioEventLoop.java:462) ~[?:?]  
at io.netty.util.concurrent.SingleThreadEventExecutor$5.run(SingleThreadEventExecutor.java:858) ~[?:?]  
at java.lang.Thread.run(Thread.java:748) ~[?:1.8.0\_191]  
[2019-02-18T15:18:21,443][WARN][o.e.b.ElasticsearchUncaughtExceptionHandler] [bitbucket\_bundled] uncaught exception in thread [main]  
org.elasticsearch.bootstrap.StartupException: BindTransportException[Failed to bind to [7993]]; nested: BindException[Address already in use];  
at org.elasticsearch.bootstrap.Elasticsearch.init(Elasticsearch.java:127) ~[elasticsearch-5.5.3.jar:5.5.3]  
at org.elasticsearch.bootstrap.Elasticsearch.execute(Elasticsearch.java:114) ~[elasticsearch-5.5.3.jar:5.5.3]  
at org.elasticsearch.cli.EnvironmentAwareCommand.execute(EnvironmentAwareCommand.java:67) ~[elasticsearch-5.5.3.jar:5.5.3]  
at org.elasticsearch.cli.Command.mainWithoutErrorHandling(Command.java:122) ~[elasticsearch-5.5.3.jar:5.5.3]  
at org.elasticsearch.cli.Command.main(Command.java:88) ~[elasticsearch-5.5.3.jar:5.5.3]  
at org.elasticsearch.bootstrap.Elasticsearch.main(Elasticsearch.java:91) ~[elasticsearch-5.5.3.jar:5.5.3]  
at org.elasticsearch.bootstrap.Elasticsearch.main(Elasticsearch.java:84) ~[elasticsearch-5.5.3.jar:5.5.3]  
Caused by: org.elasticsearch.transport.BindTransportException: Failed to bind to [7993]  
at org.elasticsearch.transport.TcpTransport.bindToPort(TcpTransport.java:793) ~[elasticsearch-5.5.3.jar:5.5.3]  
at org.elasticsearch.transport.TcpTransport.bindServer(TcpTransport.java:758) ~[elasticsearch-5.5.3.jar:5.5.3]  
at org.elasticsearch.transport.netty4.Netty4Transport.doStart(Netty4Transport.java:173) ~[?:?]  
at org.elasticsearch.common.component.AbstractLifecycleComponent.start(AbstractLifecycleComponent.java:69) ~[elasticsearch-5.5.3.jar:5.5.3]  
at org.elasticsearch.transport.TransportService.doStart(TransportService.java:209) ~[elasticsearch-5.5.3.jar:5.5.3]  
at org.elasticsearch.common.component.AbstractLifecycleComponent.start(AbstractLifecycleComponent.java:69) ~[elasticsearch-5.5.3.jar:5.5.3]  
at org.elasticsearch.node.Node.start(Node.java:692) ~[elasticsearch-5.5.3.jar:5.5.3]  
at org.elasticsearch.bootstrap.Bootstrap.start(Bootstrap.java:277) ~[elasticsearch-5.5.3.jar:5.5.3]  
at org.elasticsearch.bootstrap.Bootstrap.init(Bootstrap.java:360) ~[elasticsearch-5.5.3.jar:5.5.3]  
at org.elasticsearch.bootstrap.Elasticsearch.init(Elasticsearch.java:123) ~[elasticsearch-5.5.3.jar:5.5.3]  
... 6 more  
Caused by: java.net.BindException: Address already in use  
at sun.nio.ch.Net.bind0(Native Method) ~[?:?]  
at sun.nio.ch.Net.bind(Net.java:433) ~[?:?]  
at sun.nio.ch.Net.bind(Net.java:425) ~[?:?]  
at sun.nio.ch.ServerSocketChannelImpl.bind(ServerSocketChannelImpl.java:223) ~[?:?]  
at io.netty.channel.socket.nio.NioServerSocketChannel.doBind(NioServerSocketChannel.java:128) ~[?:?]  
at io.netty.channel.AbstractChannel$AbstractUnsafe.bind(AbstractChannel.java:554) ~[?:?]  
at io.netty.channel.DefaultChannelPipeline$HeadContext.bind(DefaultChannelPipeline.java:1258) ~[?:?]  
at io.netty.channel.AbstractChannelHandlerContext.invokeBind(AbstractChannelHandlerContext.java:501) ~[?:?]  
at io.netty.channel.AbstractChannelHandlerContext.bind(AbstractChannelHandlerContext.java:486) ~[?:?]  
at io.netty.channel.DefaultChannelPipeline.bind(DefaultChannelPipeline.java:980) ~[?:?]  
at io.netty.channel.AbstractChannel.bind(AbstractChannel.java:250) ~[?:?]  
at io.netty.bootstrap.AbstractBootstrap$2.run(AbstractBootstrap.java:365) ~[?:?]  
at io.netty.util.concurrent.AbstractEventExecutor.safeExecute(AbstractEventExecutor.java:163) ~

---

<div class="post-metadata">

**Author:** ![dadoonet](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/dadoonet/32/137187_2.png) [@dadoonet](https://discuss.elastic.co/u/dadoonet)\
**Post date:** [February 18, 2019, 3:47pm UTC](https://discuss.elastic.co/t/trying-to-start-the-bitbucket-server-but-throwing-an-error-stating-bind-transport-exception/168859/2 "2019-02-18T15:47:05Z")

</div>

A service is already running on that port.

---

<div class="post-metadata">

**Author:** ![manoharreddy](https://avatars.discourse-cdn.com/v4/letter/m/c67d28/32.png) [@manoharreddy](https://discuss.elastic.co/u/manoharreddy)\
**Post date:** [February 19, 2019, 8:55am UTC](https://discuss.elastic.co/t/trying-to-start-the-bitbucket-server-but-throwing-an-error-stating-bind-transport-exception/168859/3 "2019-02-19T08:55:35Z")

</div>

What needs to be done in that case for bitbucket to be up and running?

Can i change port ?

Is there any standard procedure to overcome the current issue and kill running port ?

---

<div class="post-metadata">

**Author:** ![dadoonet](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/dadoonet/32/137187_2.png) [@dadoonet](https://discuss.elastic.co/u/dadoonet)\
**Post date:** [February 19, 2019, 9:09am UTC](https://discuss.elastic.co/t/trying-to-start-the-bitbucket-server-but-throwing-an-error-stating-bind-transport-exception/168859/4 "2019-02-19T09:09:41Z")

</div>

I don't know the tools you are using. `7993` is not a standard port for elasticsearch.

> Can i change port ?

In elasticsearch, yes with `transport.port: 9300` and `http.port: 9200`. But is it your question?

> Is there any standard procedure to overcome the current issue and kill running port ?

It depends on how you started elasticsearch. If you did that manually on the command line, then a `CTRL+C` would work.  
If you started it as a service, stop the service...  
Or kill the process.

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [March 19, 2019, 9:09am UTC](https://discuss.elastic.co/t/trying-to-start-the-bitbucket-server-but-throwing-an-error-stating-bind-transport-exception/168859/5 "2019-03-19T09:09:45Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
