# TTL Error

**URL:** <https://discuss.elastic.co/t/ttl-error/61050>\
**Category:** Elasticsearch\
**Created:** [September 20, 2016, 9:27pm UTC](https://discuss.elastic.co/t/ttl-error/61050 "2016-09-20T21:27:47Z")\
**Posts on this page:** 2\
**Page:** 1

<div class="post-metadata">

**Author:** ![Anjana\_Regula](https://avatars.discourse-cdn.com/v4/letter/a/ecccb3/32.png) [@Anjana\_Regula](https://discuss.elastic.co/u/Anjana_Regula)\
**Post date:** [September 20, 2016, 9:27pm UTC](https://discuss.elastic.co/t/ttl-error/61050/1 "2016-09-20T21:27:48Z")

</div>

Hi All,

I am newbie to the Elastic search.

I am using Elastic dump tool to export and import data into elastic search.,

The error that i am facing is - Caused by: java.lang.IllegalStateException: Mixing up field types: class org.elasticsearch.index.mapper.core.LongFieldMapper$LongFieldType != class org.elasticsearch.index.mapper.internal.TTLFieldMapper$TTLFieldType on field \_ttl

our new ES search is running version - 2.4 in which ttl field is deprecated.

can you please let me know the process how to import data without ttl field.

ex:

elasticdump   
--input=http://production.es.com:9200/my\_index   
--output=http://staging.es.com:9200/my\_index   
--type=analyzer  
elasticdump   
--input=http://production.es.com:9200/my\_index   
--output=http://staging.es.com:9200/my\_index   
--type=mapping  
elasticdump   
--input=http://production.es.com:9200/my\_index   
--output=http://staging.es.com:9200/my\_index   
--type=data ----\> this is the step where i am facign ttl error.

can you please suggest.

Regards,  
Anjana

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [July 5, 2017, 10:18pm UTC](https://discuss.elastic.co/t/ttl-error/61050/2 "2017-07-05T22:18:42Z")

</div>


