# Unable perform incremental selection operation using $metrics.lastexecutionstart in Sql Server

**URL:** <https://discuss.elastic.co/t/unable-perform-incremental-selection-operation-using-metrics-lastexecutionstart-in-sql-server/29009>\
**Category:** Elasticsearch\
**Created:** [September 10, 2015, 9:42am UTC](https://discuss.elastic.co/t/unable-perform-incremental-selection-operation-using-metrics-lastexecutionstart-in-sql-server/29009 "2015-09-10T09:42:39Z")\
**Posts on this page:** 2\
**Page:** 1

<div class="post-metadata">

**Author:** ![vsreddy](https://avatars.discourse-cdn.com/v4/letter/v/ac91a4/32.png) [@vsreddy](https://discuss.elastic.co/u/vsreddy)\
**Post date:** [September 10, 2015, 9:42am UTC](https://discuss.elastic.co/t/unable-perform-incremental-selection-operation-using-metrics-lastexecutionstart-in-sql-server/29009/1 "2015-09-10T09:42:39Z")

</div>

Unable perform incremental selection operation using $metrics.lastexecutionstart in Sql Server.

My code:  
PUT /\_river/file\_river/\_meta  
{  
"type" : "jdbc",  
"jdbc" : {  
"url" : "jdbc:sqlserver://localhost;databaseName=AdventureWorks2008R2",  
"user" : "",  
"password" : "",  
"sql" : [  
{  
"statement" : " SELECT TOP 1000 ShipMethod.ShipMethodID,ShipMethod.ShipRate,ShipMethod.ModifiedDate,ShipMethod.ShipBase,ShipMethod.rowguid,ShipMethod.Name FROM ShipMethod where ShipMethod.ModifiedDate \> ?",  
"parameter" : ["$metrics.lastexecutionstart"]  
}  
],  
"index" : "file",  
"type" : "file\_stat",  
"schedule": "0/5 0-59 \* \* \* ?"  
}  
}

ShipMethod.ModifiedDate format is : '2008-03-11 10:01:36.827'

Elasticsearch throws an exception saying below exception.

**Error Logs:**

[2015-08-28 10:24:35,227][ERROR][river.jdbc.RiverPipeline] com.microsoft.sqlserver.jdbc.SQLServerException: Conversion failed when converting date and/or time from character string.  
java.io.IOException: com.microsoft.sqlserver.jdbc.SQLServerException: Conversion failed when converting date and/or time from character string.  
at

**But am able to perform same operation in My Sql successfully.**

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [July 5, 2017, 11:51pm UTC](https://discuss.elastic.co/t/unable-perform-incremental-selection-operation-using-metrics-lastexecutionstart-in-sql-server/29009/2 "2017-07-05T23:51:20Z")

</div>


