# Unable to access elasticsearch opendistro from browser

**URL:** https://discuss.elastic.co/t/unable-to-access-elasticsearch-opendistro-from-browser/196454
**Category:** Elasticsearch
**Created:** [August 23, 2019, 6:44am UTC](https://discuss.elastic.co/t/unable-to-access-elasticsearch-opendistro-from-browser/196454 "2019-08-23T06:44:55Z")
**Posts on this page:** 4
**Page:** 1

<div class="post-metadata">

### Author: ![cool\_guy99](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/cool_guy99/32/46406_2.png) [@cool\_guy99](https://discuss.elastic.co/u/cool_guy99)
#### Post date: [August 23, 2019, 6:44am UTC](https://discuss.elastic.co/t/unable-to-access-elasticsearch-opendistro-from-browser/196454/1 "2019-08-23T06:44:55Z")

</div>

Hi Guys,

I'm trying to install opendistro elasticsearch [https://opendistro.github.io/for-elasticsearch-docs/docs/install/rpm/](https://opendistro.github.io/for-elasticsearch-docs/docs/install/rpm/) on a centos machine and I was able to perform that. I even removed the security plugins mentioned here: [https://opendistro.github.io/for-elasticsearch-docs/docs/security-configuration/disable/](https://opendistro.github.io/for-elasticsearch-docs/docs/security-configuration/disable/)  
When I use: curl -k [http://localhost:9200](http://localhost:9200) Im able to access the api of elasticsearch  
However, I'm unable to view the api output from my browser using  
http://:9200

Has anyone seen this issue? How should I resolve this? My elasticsearch service is up and running.  
But I'm unable to view things from my browser. My ports are open too for the machine.

---

<div class="post-metadata">

### Author: ![Christian\_Dahlqvist](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/christian_dahlqvist/32/4617_2.png) [@Christian\_Dahlqvist](https://discuss.elastic.co/u/Christian_Dahlqvist)
#### Post date: [August 23, 2019, 6:49am UTC](https://discuss.elastic.co/t/unable-to-access-elasticsearch-opendistro-from-browser/196454/2 "2019-08-23T06:49:54Z")

</div>

Elasticsearch by default binds to localhost so you need to update your config to change that.

---

<div class="post-metadata">

### Author: ![elemus](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/elemus/32/61976_2.png) [@elemus](https://discuss.elastic.co/u/elemus)
#### Post date: [August 23, 2019, 11:43pm UTC](https://discuss.elastic.co/t/unable-to-access-elasticsearch-opendistro-from-browser/196454/3 "2019-08-23T23:43:13Z")

</div>

Can you see here

> [@Unable to connect to Elasticsearch at http://localhost:9200](https://discuss.elastic.co/t/unable-to-connect-to-elasticsearch-at-http-localhost-9200/48633/8):
>
> I have solved this issue in macOS sierra by starting elasticsearch you can also check your elasticsearch is running or not. brew services start elasticsearch

---

<div class="post-metadata">

### Author: ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)
#### Post date: [September 20, 2019, 11:43pm UTC](https://discuss.elastic.co/t/unable-to-access-elasticsearch-opendistro-from-browser/196454/4 "2019-09-20T23:43:17Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
