# Unable to access Kibana on http://MYDOMAIN.com:5601

**URL:** <https://discuss.elastic.co/t/unable-to-access-kibana-on-http-mydomain-com-5601/107145>\
**Category:** Kibana\
**Created:** [November 10, 2017, 7:33am UTC](https://discuss.elastic.co/t/unable-to-access-kibana-on-http-mydomain-com-5601/107145 "2017-11-10T07:33:46Z")\
**Posts on this page:** 18\
**Page:** 1

<div class="post-metadata">

**Author:** ![quitr](https://avatars.discourse-cdn.com/v4/letter/q/76d3ee/32.png) [@quitr](https://discuss.elastic.co/u/quitr)\
**Post date:** [November 10, 2017, 7:33am UTC](https://discuss.elastic.co/t/unable-to-access-kibana-on-http-mydomain-com-5601/107145/1 "2017-11-10T07:33:46Z")

</div>

I am new to the ELK Stack. I have installed all the components (filebeat, logstash, elasticsearch and kibana), and all services are running. I am able to test elasticsearch by running curl localhost:9200. However I am unable to access kibana on 5601. curl localhost 5601 fails with the error  
curl: (7) Failed connect to localhost:6501; Connection refused  
My kibana server is on the cloud, so I cannot point my web browser to [http://localhost:5601](http://localhost:5601) to test it that way.  
In the kibana.yml file I have modified the server.host parameter to point to my domain..  
On googling, some suggestions were to setup a reverse proxy using nginx. Is this necessary??

---

<div class="post-metadata">

**Author:** ![Christian\_Dahlqvist](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/christian_dahlqvist/32/4617_2.png) [@Christian\_Dahlqvist](https://discuss.elastic.co/u/Christian_Dahlqvist)\
**Post date:** [November 10, 2017, 7:36am UTC](https://discuss.elastic.co/t/unable-to-access-kibana-on-http-mydomain-com-5601/107145/2 "2017-11-10T07:36:45Z")

</div>

> [@quitr](#):
>
> curl: (7) Failed connect to localhost:6501; Connection refused

Looks like you have mistyped the port number: `6501` instead of `5601`.

---

<div class="post-metadata">

**Author:** ![quitr](https://avatars.discourse-cdn.com/v4/letter/q/76d3ee/32.png) [@quitr](https://discuss.elastic.co/u/quitr)\
**Post date:** [November 10, 2017, 7:48am UTC](https://discuss.elastic.co/t/unable-to-access-kibana-on-http-mydomain-com-5601/107145/3 "2017-11-10T07:48:17Z")

</div>

sorry typo!  
I do get the same error for 5601!  
curl: (7) Failed connect to localhost:5601; Connection refused

---

<div class="post-metadata">

**Author:** ![Christian\_Dahlqvist](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/christian_dahlqvist/32/4617_2.png) [@Christian\_Dahlqvist](https://discuss.elastic.co/u/Christian_Dahlqvist)\
**Post date:** [November 10, 2017, 7:53am UTC](https://discuss.elastic.co/t/unable-to-access-kibana-on-http-mydomain-com-5601/107145/4 "2017-11-10T07:53:35Z")

</div>

If you have specified `server.host` setting, it may not be listening to the loopback interface. can you access via `<your domain>:5601`? What happens if you comment out the `server.host` setting and let Kibana bind to all interfaces?

---

<div class="post-metadata">

**Author:** ![quitr](https://avatars.discourse-cdn.com/v4/letter/q/76d3ee/32.png) [@quitr](https://discuss.elastic.co/u/quitr)\
**Post date:** [November 10, 2017, 7:59am UTC](https://discuss.elastic.co/t/unable-to-access-kibana-on-http-mydomain-com-5601/107145/5 "2017-11-10T07:59:15Z")

</div>

ok! commented server.host and now curl localhost:5601 returns  
curl localhost:5601

var hashRoute = '/app/kibana'; var defaultRoute = '/app/kibana'; var hash = window.location.hash; if (hash.length) { window.location = hashRoute + hash; } else { window.location = defaultRoute; But this doesn't help me access my kibana instance remotely as I cannot do http://localhost:5601 for that server! How should I set it up to access Kibana?

---

<div class="post-metadata">

**Author:** ![Christian\_Dahlqvist](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/christian_dahlqvist/32/4617_2.png) [@Christian\_Dahlqvist](https://discuss.elastic.co/u/Christian_Dahlqvist)\
**Post date:** [November 10, 2017, 8:02am UTC](https://discuss.elastic.co/t/unable-to-access-kibana-on-http-mydomain-com-5601/107145/6 "2017-11-10T08:02:11Z")

</div>

Can you point a browser to it? What does being able to curl it from localhost have to do with accessing it remotely?

---

<div class="post-metadata">

**Author:** ![quitr](https://avatars.discourse-cdn.com/v4/letter/q/76d3ee/32.png) [@quitr](https://discuss.elastic.co/u/quitr)\
**Post date:** [November 10, 2017, 8:09am UTC](https://discuss.elastic.co/t/unable-to-access-kibana-on-http-mydomain-com-5601/107145/7 "2017-11-10T08:09:53Z")

</div>

if I point a browser to [http://xx.xx.xx.xx:5601](http://xx.xx.xx.xx:5601) I get a Connection Time Out error:

This site can’t be reached

xx.xx.xx.xx took too long to respond.  
Search Google for xx.xx.xx.xx 5601  
ERR\_CONNECTION\_TIMED\_OUT

I CAN access the apache server on my IP:  
[http://xx.xx.xx.xx](http://xx.xx.xx.xx) takes me to the test page of Apache. How else can I access the Kibana instance?

---

<div class="post-metadata">

**Author:** ![Christian\_Dahlqvist](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/christian_dahlqvist/32/4617_2.png) [@Christian\_Dahlqvist](https://discuss.elastic.co/u/Christian_Dahlqvist)\
**Post date:** [November 10, 2017, 8:11am UTC](https://discuss.elastic.co/t/unable-to-access-kibana-on-http-mydomain-com-5601/107145/8 "2017-11-10T08:11:03Z")

</div>

Has firewall/iptables been configured to allow traffic on the 5601 port?

---

<div class="post-metadata">

**Author:** ![quitr](https://avatars.discourse-cdn.com/v4/letter/q/76d3ee/32.png) [@quitr](https://discuss.elastic.co/u/quitr)\
**Post date:** [November 10, 2017, 8:13am UTC](https://discuss.elastic.co/t/unable-to-access-kibana-on-http-mydomain-com-5601/107145/9 "2017-11-10T08:13:27Z")

</div>

I have not allowed public access to 5601, but all the servers/IPs on our network have been given access to it

---

<div class="post-metadata">

**Author:** ![Christian\_Dahlqvist](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/christian_dahlqvist/32/4617_2.png) [@Christian\_Dahlqvist](https://discuss.elastic.co/u/Christian_Dahlqvist)\
**Post date:** [November 10, 2017, 8:14am UTC](https://discuss.elastic.co/t/unable-to-access-kibana-on-http-mydomain-com-5601/107145/10 "2017-11-10T08:14:27Z")

</div>

Does that include the machine you are using the browser?

---

<div class="post-metadata">

**Author:** ![quitr](https://avatars.discourse-cdn.com/v4/letter/q/76d3ee/32.png) [@quitr](https://discuss.elastic.co/u/quitr)\
**Post date:** [November 10, 2017, 8:14am UTC](https://discuss.elastic.co/t/unable-to-access-kibana-on-http-mydomain-com-5601/107145/11 "2017-11-10T08:14:48Z")

</div>

yes it does

---

<div class="post-metadata">

**Author:** ![quitr](https://avatars.discourse-cdn.com/v4/letter/q/76d3ee/32.png) [@quitr](https://discuss.elastic.co/u/quitr)\
**Post date:** [November 10, 2017, 8:16am UTC](https://discuss.elastic.co/t/unable-to-access-kibana-on-http-mydomain-com-5601/107145/12 "2017-11-10T08:16:41Z")

</div>

Is there a way I can test this from another server on the same cloud? curl xx.xx.xx.xx:5601 from this other server should work, right? (It doesnt) . Is that a good test? Or is there something else I should try

---

<div class="post-metadata">

**Author:** ![Christian\_Dahlqvist](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/christian_dahlqvist/32/4617_2.png) [@Christian\_Dahlqvist](https://discuss.elastic.co/u/Christian_Dahlqvist)\
**Post date:** [November 10, 2017, 8:16am UTC](https://discuss.elastic.co/t/unable-to-access-kibana-on-http-mydomain-com-5601/107145/13 "2017-11-10T08:16:42Z")

</div>

Check which interface Kibana is bound to on the Kibana host. If that is all interfaces, this still sounds to me like a networking/firewall issue. What about iptables on the host itself?

---

<div class="post-metadata">

**Author:** ![quitr](https://avatars.discourse-cdn.com/v4/letter/q/76d3ee/32.png) [@quitr](https://discuss.elastic.co/u/quitr)\
**Post date:** [November 10, 2017, 8:17am UTC](https://discuss.elastic.co/t/unable-to-access-kibana-on-http-mydomain-com-5601/107145/14 "2017-11-10T08:17:48Z")

</div>

> [@Christian\_Dahlqvist](#):
>
> Check which interface Kibana is bound to on the Kibana host. If that is all interfaces, this still sounds to me like a networking/firewall issue

Sorry .. could you explain this??

---

<div class="post-metadata">

**Author:** ![Christian\_Dahlqvist](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/christian_dahlqvist/32/4617_2.png) [@Christian\_Dahlqvist](https://discuss.elastic.co/u/Christian_Dahlqvist)\
**Post date:** [November 10, 2017, 8:42am UTC](https://discuss.elastic.co/t/unable-to-access-kibana-on-http-mydomain-com-5601/107145/15 "2017-11-10T08:42:18Z")

</div>

On the Kibana host, use `netstat` (assuming linux), e.g. `netstat -an | grep 5601`, to see which host/port Kibana binds to.

---

<div class="post-metadata">

**Author:** ![quitr](https://avatars.discourse-cdn.com/v4/letter/q/76d3ee/32.png) [@quitr](https://discuss.elastic.co/u/quitr)\
**Post date:** [November 10, 2017, 9:46am UTC](https://discuss.elastic.co/t/unable-to-access-kibana-on-http-mydomain-com-5601/107145/16 "2017-11-10T09:46:02Z")

</div>

netstat -an | grep 5601  
tcp 0 0 127.0.0.1:5601 0.0.0.0:\* LISTEN

Is this output OK or should I make some config changes?

---

<div class="post-metadata">

**Author:** ![Christian\_Dahlqvist](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/christian_dahlqvist/32/4617_2.png) [@Christian\_Dahlqvist](https://discuss.elastic.co/u/Christian_Dahlqvist)\
**Post date:** [November 10, 2017, 10:56am UTC](https://discuss.elastic.co/t/unable-to-access-kibana-on-http-mydomain-com-5601/107145/17 "2017-11-10T10:56:36Z")

</div>

It is only bound to localhost, as that seem to be the default for the `server.host` parameter. If you set this to `0.0.0.0` it should bind to all interfaces so you can access it both locally and remotely.

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [December 8, 2017, 10:56am UTC](https://discuss.elastic.co/t/unable-to-access-kibana-on-http-mydomain-com-5601/107145/18 "2017-12-08T10:56:49Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
