# Unable to access kibana shows HTTP 503 error in kibana logs

**URL:** <https://discuss.elastic.co/t/unable-to-access-kibana-shows-http-503-error-in-kibana-logs/180317>\
**Category:** Kibana\
**Created:** [May 9, 2019, 8:54am UTC](https://discuss.elastic.co/t/unable-to-access-kibana-shows-http-503-error-in-kibana-logs/180317 "2019-05-09T08:54:03Z")\
**Posts on this page:** 6\
**Page:** 1

<div class="post-metadata">

**Author:** ![ksunil](https://avatars.discourse-cdn.com/v4/letter/k/439d5e/32.png) [@ksunil](https://discuss.elastic.co/u/ksunil)\
**Post date:** [May 9, 2019, 8:54am UTC](https://discuss.elastic.co/t/unable-to-access-kibana-shows-http-503-error-in-kibana-logs/180317/1 "2019-05-09T08:54:03Z")

</div>

Hi,  
I have been using Kibana and Elastic Search, whereas elastic search service is up and running and kibana was down due to below error because of this unable to access the kibana and health URL shows red  
"tags":["warning","stats-collection"],"pid":16426,"message":"Unable to fetch data from rollups collector"}  
{"type":"error","@timestamp":"2019-05-09T08:44:56Z","tags":["warning","stats-collection"],"pid":16426,"level":"error","error":{"message":"[no\_shard\_available\_action\_exception] No shard available for [get [.kibana][doc][config:6.6.2]: routing [null]]","name":"Error","stack":"[no\_shard\_available\_action\_exception] No shard available for [get [.kibana][doc][config:6.6.2]: routing [null]] :: {"path":"/.kibana/doc/config%3A6.6.2","query":{},"statusCode":503,"response":"{\"error\":{\"root\_cause\":[{\"type\":\"no\_shard\_available\_action\_exception\",\"reason\":\"No shard available for [get [.kibana][doc][config:6.6.2]: routing [null]]\"}],\"type\":\"no\_shard\_available\_action\_exception\",\"reason\":\"No shard available for [get [.kibana][doc][config:6.6.2]: routing [null]]\"},\"status\":503}"}\n at respond (/usr/share/kibana/node\_modules/elasticsearch/src/lib/transport.js:308:15)\n at checkRespForFailure (/usr/share/kibana/node\_modules/elasticsearch/src/lib/transport.js:267:7)\n at HttpConnector. (/usr/share/kibana/node\_modules/elasticsearch/src/lib/connectors/http.js:166:7)\n at IncomingMessage.wrapper (/usr/share/kibana/node\_modules/elasticsearch/node\_modules/lodash/lodash.js:4935:19)\n at IncomingMessage.emit (events.js:194:15)\n at endReadableNT (\_stream\_readable.js:1103:12)\n at process.\_tickCallback (internal/process/next\_tick.js:63:19)"},"message":"[no\_shard\_available\_action\_exception] No shard available for [get [.kibana][doc][config:6.6.2]: routing [null]]"}  
{"type":"log","@timestamp":"2019-05-09T08:44:56Z","tags":["warning","stats-collection"],"pid":16426,"message":"Unable to fetch data from kibana\_settings collector"}  
{"type":"error","@timestamp":"2019-05-09T08:44:56Z","tags":["warning","stats-collection"],"pid":16426,"level":"error","error":{"message":"[search\_phase\_execution\_exception] all shards failed","name":"Error","stack":"[search\_phase\_execution\_exception] all shards failed :: {"path":"/.kibana/\_search","query":{"ignore\_unavailable":true,"filter\_path":"aggregations.types.buckets"},"body":"{\"size\":0,\"query\":{\"terms\":{\"type\":[\"dashboard\",\"visualization\",\"search\",\"index-pattern\",\"graph-workspace\",\"timelion-sheet\"]}},\"aggs\":{\"types\":{\"terms\":{\"field\":\"type\",\"size\":6}}}}","statusCode":503,"response":"{\"error\":{\"root\_cause\":,\"type\":\"search\_phase\_execution\_exception\",\"reason\":\"all shards failed\",\"phase\":\"query\",\"grouped\":true,\"failed\_shards\":},\"status\":503}"}\n at respond (/usr/share/kibana/node\_modules/elasticsearch/src/lib/transport.js:308:15)\n at checkRespForFailure (/usr/share/kibana/node\_modules/elasticsearch/src/lib/transport.js:267:7)\n at HttpConnector. (/usr/share/kibana/node\_modules/elasticsearch/src/lib/connectors/http.js:166:7)\n at IncomingMessage.wrapper (/usr/share/kibana/node\_modules/elasticsearch/node\_modules/lodash/lodash.js:4935:19)\n at IncomingMessage.emit (events.js:194:15)\n at endReadableNT (\_stream\_readable.js:1103:12)\n at process.\_tickCallback (internal/process/next\_tick.js:63:19)"},"message":"[search\_phase\_execution\_exception] all shards failed"}  
{"type":"log","@timestamp":"2019-05-09T08:44:56Z","tags":["warning","stats-collection"],"pid":16426,"message":"Unable to fetch data from kibana collector"}  
{"type":"log","@timestamp":"2019-05-09T08:44:57Z","tags":["status","plugin:spaces@6.6.2","error"],"pid":16426,"state":"red","message":"Status changed from red to red - all shards failed: [search\_phase\_execution\_exception] all shards failed","prevState":"red","prevMsg":"[data] Elasticsearch cluster did not respond with license information."}  
{"type":"log","@timestamp":"2019-05-09T08:44:57Z","tags":["fatal","root"],"pid":16426,"message":"{ [search\_phase\_execution\_exception] all shards failed :: {"path":"/.kibana/doc/\_count","query":{},"body":"{\"query\":{\"bool\":{\"should\":[{\"bool\":{\"must\":[{\"exists\":{\"field\":\"index-pattern\"}},{\"bool\":{\"must\_not\":{\"term\":{\"migrationVersion.index-pattern\":\"6.5.0\"}}}}]}}]}}}","statusCode":503,"response":"{\"error\":{\"root\_cause\":,\"type\":\"search\_phase\_execution\_exception\",\"reason\":\"all shards failed\",\"phase\":\"query\",\"grouped\":true,\"failed\_shards\":},\"status\":503}"}\n at respond (/usr/share/kibana/node\_modules/elasticsearch/src/lib/transport.js:308:15)\n at checkRespForFailure (/usr/share/kibana/node\_modules/elasticsearch/src/lib/transport.js:267:7)\n at HttpConnector. (/usr/share/kibana/node\_modules/elasticsearch/src/lib/connectors/http.js:166:7)\n at IncomingMessage.wrapper (/usr/share/kibana/node\_modules/elasticsearch/node\_modules/lodash/lodash.js:4935:19)\n at IncomingMessage.emit (events.js:194:15)\n at endReadableNT (\_stream\_readable.js:1103:12)\n at process.\_tickCallback (internal/process/next\_tick.js:63:19)\n status: 503,\n displayName: 'ServiceUnavailable',\n message:\n 'all shards failed: [search\_phase\_execution\_exception] all shards failed',\n path: '/.kibana/doc/\_count',\n query: {},\n body:\n { error:\n { root\_cause: ,\n type: 'search\_phase\_execution\_exception',\n reason: 'all shards failed',\n phase: 'query',\n grouped: true,\n failed\_shards: },\n status: 503 },\n statusCode: 503,\n response:\n '{"error":{"root\_cause":,"type":"search\_phase\_execution\_exception","reason":"all shards failed","phase":"query","grouped":true,"failed\_shards":},"status":503}',\n toString: [Function],\n toJSON: [Function],\n isBoom: true,\n isServer: true,\n data: null,\n output:\n { statusCode: 503,\n payload:\n { message:\n 'all shards failed: [search\_phase\_execution\_exception] all shards failed',\n statusCode: 503,\n error: 'Service Unavailable' },\n headers: {} },\n reformat: [Function],\n [Symbol(SavedObjectsClientErrorCode)]: 'SavedObjectsClient/esUnavailable' }"}

curl -X GET [http://X.X.X.X:9200/\_cluster/health](http://X.X.X.X:9200/_cluster/health)  
{"cluster\_name":"XXX-apm-cluster","status":"red","timed\_out":false,"number\_of\_nodes":2,"number\_of\_data\_nodes":2,"active\_primary\_shards":0,"active\_shards":0,"relocating\_shards":0,"initializing\_shards":0,"unassigned\_shards":0,"delayed\_unassigned\_shards":0,"number\_of\_pending\_tasks":0,"number\_of\_in\_flight\_fetch":0,"task\_max\_waiting\_in\_queue\_millis":0,"active\_shards\_percent\_as\_number":"NaN"}

---

<div class="post-metadata">

**Author:** ![Nathan\_Reese](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/nathan_reese/32/84829_2.png) [@Nathan\_Reese](https://discuss.elastic.co/u/Nathan_Reese)\
**Post date:** [May 9, 2019, 5:23pm UTC](https://discuss.elastic.co/t/unable-to-access-kibana-shows-http-503-error-in-kibana-logs/180317/2 "2019-05-09T17:23:09Z")

</div>

What steps have you taken to install Kibana and Elasticsearch? What does your environment look like?

---

<div class="post-metadata">

**Author:** ![ksunil](https://avatars.discourse-cdn.com/v4/letter/k/439d5e/32.png) [@ksunil](https://discuss.elastic.co/u/ksunil)\
**Post date:** [May 10, 2019, 6:18am UTC](https://discuss.elastic.co/t/unable-to-access-kibana-shows-http-503-error-in-kibana-logs/180317/3 "2019-05-10T06:18:35Z")

</div>

Hi,

Set up was done before i started working on kibana/elasticsearch and 2 instances of kibana and elastic search are running on different hosts that means 1 kibana and elasticsearch running on each of two hosts. 2 instances of elastic search are in cluster.

---

<div class="post-metadata">

**Author:** ![Nathan\_Reese](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/nathan_reese/32/84829_2.png) [@Nathan\_Reese](https://discuss.elastic.co/u/Nathan_Reese)\
**Post date:** [May 10, 2019, 1:18pm UTC](https://discuss.elastic.co/t/unable-to-access-kibana-shows-http-503-error-in-kibana-logs/180317/4 "2019-05-10T13:18:30Z")

</div>

Why do you have 2 kibana servers for such a small cluster?

---

<div class="post-metadata">

**Author:** ![ksunil](https://avatars.discourse-cdn.com/v4/letter/k/439d5e/32.png) [@ksunil](https://discuss.elastic.co/u/ksunil)\
**Post date:** [May 13, 2019, 3:12am UTC](https://discuss.elastic.co/t/unable-to-access-kibana-shows-http-503-error-in-kibana-logs/180317/5 "2019-05-13T03:12:02Z")

</div>

Hi,

We are started using kibana recently as the intial set up started with 2 instances

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [June 10, 2019, 3:12am UTC](https://discuss.elastic.co/t/unable-to-access-kibana-shows-http-503-error-in-kibana-logs/180317/6 "2019-06-10T03:12:02Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
