# Unable to access 'path.repo'

**URL:** <https://discuss.elastic.co/t/unable-to-access-path-repo/291633>\
**Category:** Elasticsearch\
**Created:** [December 13, 2021, 11:12am UTC](https://discuss.elastic.co/t/unable-to-access-path-repo/291633 "2021-12-13T11:12:54Z")\
**Posts on this page:** 2\
**Page:** 1

<div class="post-metadata">

**Author:** ![WTrois](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/wtrois/32/98813_2.png) [@WTrois](https://discuss.elastic.co/u/WTrois)\
**Post date:** [December 13, 2021, 11:12am UTC](https://discuss.elastic.co/t/unable-to-access-path-repo/291633/1 "2021-12-13T11:12:55Z")

</div>

Hi,

I'm having problems uploading indices from a snapshot. I'm running Elasticsearch version 7.16.0

I have: `path.repo: ["/home/user/Downloads/snapshot1"]` in my yml file.

The Elasticsearch cluster fails to start. The error is below:

```auto
systemd-entrypoint[123815]: java.lang.IllegalStateException: Unable to access 'path.repo' (/home/crux/Downloads/snapshot1)
Likely root cause: java.nio.file.AccessDeniedException: /home/user/Downloads

```

Permissions for the the snapshot1 directory are set recursively, with 777 permissions  
and Elasticsearch:Elasticsearch as the owner/group.

I don't know what other permissions need setting which would allow my cluster to start?

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [January 10, 2022, 11:13am UTC](https://discuss.elastic.co/t/unable-to-access-path-repo/291633/2 "2022-01-10T11:13:37Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
