# Unable to access 'path.repo'

**URL:** <https://discuss.elastic.co/t/unable-to-access-path-repo/95453>\
**Category:** Elasticsearch\
**Created:** [August 2, 2017, 5:09am UTC](https://discuss.elastic.co/t/unable-to-access-path-repo/95453 "2017-08-02T05:09:33Z")\
**Posts on this page:** 3\
**Page:** 1

<div class="post-metadata">

**Author:** ![pk.241011](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/pk.241011/32/86285_2.png) [@pk.241011](https://discuss.elastic.co/u/pk.241011)\
**Post date:** [August 2, 2017, 5:09am UTC](https://discuss.elastic.co/t/unable-to-access-path-repo/95453/1 "2017-08-02T05:09:33Z")

</div>

I have been trying to configure snapshot on my cluster. But I am stumped at this error.

```
org.elasticsearch.bootstrap.StartupException: java.lang.IllegalStateException: Unable to access 'path.repo' (/home/elastic/mount/backups)
    at org.elasticsearch.bootstrap.Elasticsearch.init(Elasticsearch.java:125) ~[elasticsearch-5.2.2.jar:5.2.2]
    ......
    ......
    at org.elasticsearch.bootstrap.Elasticsearch.main(Elasticsearch.java:82) ~[elasticsearch-5.2.2.jar:5.2.2]
Caused by: java.lang.IllegalStateException: Unable to access 'path.repo' (/home/elastic/mount/backups)
    at org.elasticsearch.bootstrap.Security.addPath(Security.java:379) ~[elasticsearch-5.2.2.jar:5.2.2]
    ......
    ......
    ... 6 more
Caused by: java.nio.file.AccessDeniedException: /home/elastic/mount
    ......
    ......

```

The elasticsearch is running as a service on my RHEL cluster.  
The user used is elasticsearch belonging to group elasticsearch.

Just for sake of trying out I have given full permissions on the mount folder and changed the owner to elasticsearch too on each of the nodes.

```
drwxrwxrwx 3 elasticsearch elasticsearch 20 Aug 1 11:55 mount

```

Entry in elasticsearch.yml is:

```
path.repo: ["/home/elastic/mount/backups"]

```

More details:  
I have create a nfs based shared filestore. And it is mounted on each of the nodes at this location

```
/home/elastic/mount/backups

```

Even the nfs shared filestore location which I have configured on one of the nodes only (uat cluster and hence the experimenting) is

```
/Data/backups 

```

is now owned by elasticsearch with full permissions.

```
drwxrwxrwx 2 elasticsearch elasticsearch 6 Aug 1 15:22 backups

```

What I am missing here? Any thing else to check?

---

<div class="post-metadata">

**Author:** ![pk.241011](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/pk.241011/32/86285_2.png) [@pk.241011](https://discuss.elastic.co/u/pk.241011)\
**Post date:** [August 2, 2017, 6:48am UTC](https://discuss.elastic.co/t/unable-to-access-path-repo/95453/2 "2017-08-02T06:48:44Z")

</div>

My bad. Yes it was a permission issue. Things working fine now.

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [August 30, 2017, 6:48am UTC](https://discuss.elastic.co/t/unable-to-access-path-repo/95453/3 "2017-08-30T06:48:51Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
