# Unable to access /tmp/jna--1985354563/jna1905218698016583564.tmp:

**URL:** https://discuss.elastic.co/t/unable-to-access-tmp-jna-1985354563-jna1905218698016583564-tmp/100760
**Category:** Elasticsearch
**Created:** [September 16, 2017, 11:50am UTC](https://discuss.elastic.co/t/unable-to-access-tmp-jna-1985354563-jna1905218698016583564-tmp/100760 "2017-09-16T11:50:36Z")
**Posts on this page:** 3
**Page:** 1

<div class="post-metadata">

### Author: ![vaddanam](https://avatars.discourse-cdn.com/v4/letter/v/7bcc69/32.png) [@vaddanam](https://discuss.elastic.co/u/vaddanam)
#### Post date: [September 16, 2017, 11:50am UTC](https://discuss.elastic.co/t/unable-to-access-tmp-jna-1985354563-jna1905218698016583564-tmp/100760/1 "2017-09-16T11:50:36Z")

</div>

Hi Team,

I am running elastic search as service in linux. I am receiving the below error message **"[2017-09-16T11:13:10,538][WARN][o.e.b.Natives] unable to load JNA native support library, native methods will be disabled.**  
**java.lang.UnsatisfiedLinkError: /tmp/jna--1985354563/jna1905218698016583564.tmp: /tmp/jna--1985354563/jna1905218698016583564.tmp: failed to map segment from shared object: Operation not permitted"**

My linux admin is not ready to give full permissions on /temp.

Can any one help me in resolving this issue.

Thanks  
sri

---

<div class="post-metadata">

### Author: ![vaddanam](https://avatars.discourse-cdn.com/v4/letter/v/7bcc69/32.png) [@vaddanam](https://discuss.elastic.co/u/vaddanam)
#### Post date: [September 25, 2017, 5:47am UTC](https://discuss.elastic.co/t/unable-to-access-tmp-jna-1985354563-jna1905218698016583564-tmp/100760/2 "2017-09-25T05:47:53Z")

</div>

does any one know how to overcome this situation? Is there any way we can run the es?

---

<div class="post-metadata">

### Author: ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)
#### Post date: [October 23, 2017, 5:47am UTC](https://discuss.elastic.co/t/unable-to-access-tmp-jna-1985354563-jna1905218698016583564-tmp/100760/3 "2017-10-23T05:47:54Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
