# Unable to add event filter exception

**URL:** <https://discuss.elastic.co/t/unable-to-add-event-filter-exception/319764>\
**Category:** Kibana\
**Tags:** docker\
**Created:** [November 24, 2022, 2:26pm UTC](https://discuss.elastic.co/t/unable-to-add-event-filter-exception/319764 "2022-11-24T14:26:14Z")\
**Posts on this page:** 6\
**Page:** 1

<div class="post-metadata">

**Author:** ![gyterpena](https://avatars.discourse-cdn.com/v4/letter/g/a9a28c/32.png) [@gyterpena](https://discuss.elastic.co/u/gyterpena)\
**Post date:** [November 24, 2022, 2:26pm UTC](https://discuss.elastic.co/t/unable-to-add-event-filter-exception/319764/1 "2022-11-24T14:26:14Z")

</div>

I'm trying to drop some events and I'm not able to select any fields in Security\>manage\>Event Filters  
This is on 8.5.2 run in docker. No error is shown.

 ![image](https://us1.discourse-cdn.com/elastic/original/3X/c/6/c66ffc626271c837b38fbcf7bff4371cc467944e.png)

---

<div class="post-metadata">

**Author:** ![Dzmitry](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/dzmitry/32/65026_2.png) [@Dzmitry](https://discuss.elastic.co/u/Dzmitry)\
**Post date:** [November 25, 2022, 2:38pm UTC](https://discuss.elastic.co/t/unable-to-add-event-filter-exception/319764/2 "2022-11-25T14:38:08Z")

</div>

Hey @gyterpena ,

I think you should check your [security integrations](https://www.elastic.co/guide/en/security/current/install-endpoint.html) first and then check docs regarding [filters](https://www.elastic.co/guide/en/security/current/event-filters.html) creation.

If integrations are in place, the other reason could be missing user permissions: You must have the `superuser` [built-in user role](https://www.elastic.co/guide/en/elasticsearch/reference/8.5/built-in-roles.html) to access this feature.

Regards, Dima

---

<div class="post-metadata">

**Author:** ![gyterpena](https://avatars.discourse-cdn.com/v4/letter/g/a9a28c/32.png) [@gyterpena](https://discuss.elastic.co/u/gyterpena)\
**Post date:** [November 27, 2022, 1:53pm UTC](https://discuss.elastic.co/t/unable-to-add-event-filter-exception/319764/3 "2022-11-27T13:53:52Z")

</div>

Hello, thx for reply.  
This was/is actually caused by  
"Http.cpp:327 CURL error 60: Error [SSL: no alternative certificate subject name matches target host name 'XXX.XXX.XXX.XXX']"

Basically, docker-compose.yml only creates cert for 127.0.0.1.

I'm unable to set "windows|Linux|Mac.advanced.elasticsearch.tls.verify\_hostname" under defend advanced settings to false as it needs platinum license.

---

<div class="post-metadata">

**Author:** ![Dzmitry](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/dzmitry/32/65026_2.png) [@Dzmitry](https://discuss.elastic.co/u/Dzmitry)\
**Post date:** [November 28, 2022, 10:28am UTC](https://discuss.elastic.co/t/unable-to-add-event-filter-exception/319764/4 "2022-11-28T10:28:57Z")

</div>

Hey @gyterpena

I can only reference the detailed comparison of [licences](https://www.elastic.co/subscriptions), so you can see what is available for you in a Basic one.

Regards, Dima

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [December 26, 2022, 5:38am UTC](https://discuss.elastic.co/t/unable-to-add-event-filter-exception/319764/5 "2022-12-26T05:38:04Z")

</div>



---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [January 23, 2023, 5:38am UTC](https://discuss.elastic.co/t/unable-to-add-event-filter-exception/319764/6 "2023-01-23T05:38:32Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
