# Unable to authenticate as any built-in user (elastic, kibana)

**URL:** <https://discuss.elastic.co/t/unable-to-authenticate-as-any-built-in-user-elastic-kibana/157921>\
**Category:** Elasticsearch\
**Tags:** elastic-stack-security\
**Created:** [November 22, 2018, 4:58pm UTC](https://discuss.elastic.co/t/unable-to-authenticate-as-any-built-in-user-elastic-kibana/157921 "2018-11-22T16:58:56Z")\
**Posts on this page:** 3\
**Page:** 1

<div class="post-metadata">

**Author:** ![bradut](https://avatars.discourse-cdn.com/v4/letter/b/bc8723/32.png) [@bradut](https://discuss.elastic.co/u/bradut)\
**Post date:** [November 22, 2018, 4:58pm UTC](https://discuss.elastic.co/t/unable-to-authenticate-as-any-built-in-user-elastic-kibana/157921/1 "2018-11-22T16:58:56Z")

</div>

I am no longer able to log in to elasticsearch using the builtin users. kibana.log also is showing that kibana user is not able to authenticate.  
Reseting the building passwords with  
bin/elasticsearch-setup-passwords auto -u "[http://localhost:9200](http://localhost:9200)"

also doesn't work, it throws an error saying:  
Exception in thread "main" java.lang.IllegalArgumentException: did not find a SSLContext

---

<div class="post-metadata">

**Author:** ![TimV](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/timv/32/13162_2.png) [@TimV](https://discuss.elastic.co/u/TimV)\
**Post date:** [November 23, 2018, 1:07am UTC](https://discuss.elastic.co/t/unable-to-authenticate-as-any-built-in-user-elastic-kibana/157921/2 "2018-11-23T01:07:30Z")

</div>

Please provide more details.

What changed? Did you do an upgrade, or make any configuration changes to your cluster?

You probably want to read this: [X-Pack Authentication issue - #7 by TimV](https://discuss.elastic.co/t/x-pack-authentication-issue/121632/7)

> [@bradut](#):
>
> Reseting the building passwords with bin/elasticsearch-setup-passwords ...

`bin/elasticsearch-setup-passwords` can only be run once (unless you have complete deleted all security informtion from your cluster). Regardless of the error you are currently receiving, this is not a viable solution.

> [@bradut](#):
>
> Exception in thread "main" java.lang.IllegalArgumentException: did not find a SSLContext

That doesn't really make sense - if you're trying to access `http` rather than `https`, it shouldn't be trying to find a SSLContext. Can you provide the full error trace? I'd like to understand what's going on here.

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [December 21, 2018, 1:07am UTC](https://discuss.elastic.co/t/unable-to-authenticate-as-any-built-in-user-elastic-kibana/157921/3 "2018-12-21T01:07:30Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
