# Unable to authenticate as any built-in user (elastic, kibana)

**URL:** <https://discuss.elastic.co/t/unable-to-authenticate-as-any-built-in-user-elastic-kibana/157921>\
**Category:** Elasticsearch\
**Tags:** elastic-stack-security\
**Created:** [November 22, 2018, 4:58pm UTC](https://discuss.elastic.co/t/unable-to-authenticate-as-any-built-in-user-elastic-kibana/157921 "2018-11-22T16:58:56Z")\
**Posts on this page:** 1\
**Showing post:** 2

<div class="post-metadata">

**Author:** ![TimV](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/timv/32/13162_2.png) [@TimV](https://discuss.elastic.co/u/TimV)\
**Post date:** [November 23, 2018, 1:07am UTC](https://discuss.elastic.co/t/unable-to-authenticate-as-any-built-in-user-elastic-kibana/157921/2 "2018-11-23T01:07:30Z")

</div>

Please provide more details.

What changed? Did you do an upgrade, or make any configuration changes to your cluster?

You probably want to read this: [X-Pack Authentication issue - #7 by TimV](https://discuss.elastic.co/t/x-pack-authentication-issue/121632/7)

> [@bradut](#):
>
> Reseting the building passwords with bin/elasticsearch-setup-passwords ...

`bin/elasticsearch-setup-passwords` can only be run once (unless you have complete deleted all security informtion from your cluster). Regardless of the error you are currently receiving, this is not a viable solution.

> [@bradut](#):
>
> Exception in thread "main" java.lang.IllegalArgumentException: did not find a SSLContext

That doesn't really make sense - if you're trying to access `http` rather than `https`, it shouldn't be trying to find a SSLContext. Can you provide the full error trace? I'd like to understand what's going on here.

---

_[View the full topic](https://discuss.elastic.co/t/unable-to-authenticate-as-any-built-in-user-elastic-kibana/157921)._
