# Unable to authenticate roles for ldap users

**URL:** <https://discuss.elastic.co/t/unable-to-authenticate-roles-for-ldap-users/204619>\
**Category:** Elasticsearch\
**Tags:** elastic-stack-security\
**Created:** [October 22, 2019, 9:56am UTC](https://discuss.elastic.co/t/unable-to-authenticate-roles-for-ldap-users/204619 "2019-10-22T09:56:32Z")\
**Posts on this page:** 3\
**Page:** 1

<div class="post-metadata">

**Author:** ![sanket07](https://avatars.discourse-cdn.com/v4/letter/s/a587f6/32.png) [@sanket07](https://discuss.elastic.co/u/sanket07)\
**Post date:** [October 22, 2019, 9:56am UTC](https://discuss.elastic.co/t/unable-to-authenticate-roles-for-ldap-users/204619/1 "2019-10-22T09:56:32Z")

</div>

I am able to authenticate the user but not the role assigned to it in role\_mapping.yml file. Getting following error

> {"error":{"root\_cause":[{"type":"security\_exception","reason":"action [cluster:monitor/main] is unauthorized for user [sanket07@detaropwmail2com.onmicrosoft.com]"}],"type":"security\_exception","reason":"action [cluster:monitor/main] is unauthorized for user [sanket07@detaropwmail2com.onmicrosoft.com]"},"status":403}

AD Domain service : [prospera.onmicrosoft.com](http://prospera.onmicrosoft.com)  
Azure AD default : [detaropwmail2com.onmicrosoft.com](http://detaropwmail2com.onmicrosoft.com/)  
users:  
name: sanket username: sanket07

role\_mapping.yml

```auto
superuser:
  - "cn=sanket07,dc=prospera,dc=onmicrosoft,dc=com"

```

elasticsearch.yml

```auto
xpack:
  security:
    authc:
      realms:
        active_directory:
          my_ad:
            order: 0
            domain_name: prospera.onmicrosoft.com
            files:
              role_mapping: "/etc/elasticsearch/role_mapping.yml"

```

---

<div class="post-metadata">

**Author:** ![ikakavas](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/ikakavas/32/34430_2.png) [@ikakavas](https://discuss.elastic.co/u/ikakavas)\
**Post date:** [October 22, 2019, 11:12am UTC](https://discuss.elastic.co/t/unable-to-authenticate-roles-for-ldap-users/204619/2 "2019-10-22T11:12:37Z")

</div>

@sanket07 can you close this since your issue was resolved in [Azure active directory integration with elasticsearch](https://discuss.elastic.co/t/azure-active-directory-integration-with-elasticsearch/204023) ?

In general, please dont open multiple topics for the same issue.

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [November 19, 2019, 11:27am UTC](https://discuss.elastic.co/t/unable-to-authenticate-roles-for-ldap-users/204619/3 "2019-11-19T11:27:13Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
