# Unable to authenticate user \[kibana\_system\]

**URL:** <https://discuss.elastic.co/t/unable-to-authenticate-user-kibana-system/344192>\
**Category:** Kibana\
**Tags:** docker\
**Created:** [October 1, 2023, 6:45pm UTC](https://discuss.elastic.co/t/unable-to-authenticate-user-kibana-system/344192 "2023-10-01T18:45:46Z")\
**Posts on this page:** 10\
**Page:** 1

<div class="post-metadata">

**Author:** ![MdRashid](https://avatars.discourse-cdn.com/v4/letter/m/839c29/32.png) [@MdRashid](https://discuss.elastic.co/u/MdRashid)\
**Post date:** [October 1, 2023, 6:45pm UTC](https://discuss.elastic.co/t/unable-to-authenticate-user-kibana-system/344192/1 "2023-10-01T18:45:46Z")

</div>

Hi,

Error

```auto
"type":"log","@timestamp":"2023-10-01T18:33:17+00:00","tags":["info","plugins-service"],"pid":1219,"message":"Plugin \"metricsEntities\" is disabled."}
{"type":"log","@timestamp":"2023-10-01T18:33:17+00:00","tags":["info","http","server","Preboot"],"pid":1219,"message":"http server running at http://0.0.0.0:5601"}
{"type":"log","@timestamp":"2023-10-01T18:33:17+00:00","tags":["warning","config","deprecation"],"pid":1219,"message":"plugins.scanDirs is deprecated and is no longer used"}
{"type":"log","@timestamp":"2023-10-01T18:33:17+00:00","tags":["warning","config","deprecation"],"pid":1219,"message":"Config key [monitoring.cluster_alerts.email_notifications.email_address] will be required for email notifications to work in 8.0.\""}
{"type":"log","@timestamp":"2023-10-01T18:33:17+00:00","tags":["warning","config","deprecation"],"pid":1219,"message":"\"xpack.reporting.roles\" is deprecated. Granting reporting privilege through a \"reporting_user\" role will not be supported starting in 8.0. Please set \"xpack.reporting.roles.enabled\" to \"false\" and grant reporting privileges to users using Kibana application privileges **Management > Security > Roles**."}
type":"log","@timestamp":"2023-10-01T18:33:18+00:00","tags":["info","plugins","ruleRegistry"],"pid":1219,"message":"Write is disabled; not installing resources for index .alerts-observability.metrics.alerts"}
{"type":"log","@timestamp":"2023-10-01T18:33:18+00:00","tags":["info","plugins","ruleRegistry"],"pid":1219,"message":"Write is disabled; not installing resources for index .alerts-observability.apm.alerts"}
{"type":"log","@timestamp":"2023-10-01T18:33:18+00:00","tags":["info","savedobjects-service"],"pid":1219,"message":"Waiting until all Elasticsearch nodes are compatible with Kibana before starting saved objects migrations..."}

type":"log","@timestamp":"2023-10-01T18:48:54+00:00","tags":["error","savedobjects-service"],"pid":1218,"message":"Unable to retrieve version information from Elasticsearch nodes. write EPROTO 140514194433920:error:1408F10B:SSL routines:ssl3_get_record:wrong version number:../deps/openssl/openssl/ssl/record/ssl3_record.c:332:\n"}
root@Testing:~/ELK/elk-stack-dockercompose# 

```

Here is the kibana.yml

```auto
---
## Default Kibana configuration from Kibana base image.
## https://github.com/elastic/kibana/blob/master/src/dev/build/tasks/os_packages/docker_generator/templates/kibana_yml.template.ts
#
server.name: kibana
server.host: 0.0.0.0
elasticsearch.hosts: ["http://elasticsearch:9200"]
monitoring.ui.container.elasticsearch.enabled: false

## X-Pack security credentials

elasticsearch.username: kibana_system
elasticsearch.password: changeme
#elasticsearch.ssl.certificateAuthorities: "/usr/share/kibana/config/elasticsearch-ca.pem"
#elasticsearch.ssl.verificationMode: none

#xpack.encryptedSavedObjects.encryptionKey: jlkaj29iopashajlseomby7238galkja

```

Here is the elasticsearch.yml

```auto
---
## Default Elasticsearch configuration from Elasticsearch base image.
## https://github.com/elastic/elasticsearch/blob/master/distribution/docker/src/docker/config/elasticsearch.yml
#
cluster.name: "docker-cluster"
network.host: 0.0.0.0

## X-Pack settings
## see https://www.elastic.co/guide/en/elasticsearch/reference/current/setup-xpack.html
#
xpack.license.self_generated.type: basic
xpack.security.enabled: true
xpack.monitoring.collection.enabled: false

#xpack.security.transport.ssl.enabled: true
#xpack.security.transport.ssl.verification_mode: certificate
#xpack.security.transport.ssl.keystore.path: elastic-certificates.p12
#xpack.security.transport.ssl.truststore.path: elastic-certificates.p12
#xpack.security.http.ssl.enabled: true
#xpack.security.http.ssl.keystore.path: "http.p12"

```

please help im new to ELK stack

Im running command  
docker stack deploy -c docker-compose.yml elk

---

<div class="post-metadata">

**Author:** ![stephenb](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/stephenb/32/40856_2.png) [@stephenb](https://discuss.elastic.co/u/stephenb)\
**Post date:** [October 1, 2023, 6:54pm UTC](https://discuss.elastic.co/t/unable-to-authenticate-user-kibana-system/344192/2 "2023-10-01T18:54:13Z")

</div>

Hi @MdRashid  
What version are you running?

---

<div class="post-metadata">

**Author:** ![MdRashid](https://avatars.discourse-cdn.com/v4/letter/m/839c29/32.png) [@MdRashid](https://discuss.elastic.co/u/MdRashid)\
**Post date:** [October 1, 2023, 6:56pm UTC](https://discuss.elastic.co/t/unable-to-authenticate-user-kibana-system/344192/3 "2023-10-01T18:56:58Z")

</div>

@stephenb  
Im following this person repo for install elk stack

```auto
https://github.com/talhayameen/elk-stack-dockercompose

```

i got this error

```auto
{"type":"log","@timestamp":"2023-10-01T18:54:39+00:00","tags":["error","savedobjects-service"],"pid":1218,"message":"Unable to retrieve version information from Elasticsearch nodes. write EPROTO 140384725612416:error:1408F10B:SSL routines:ssl3_get_record:wrong version number:../deps/openssl/openssl/ssl/record/ssl3_record.c:332:\n"}

```

---

<div class="post-metadata">

**Author:** ![stephenb](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/stephenb/32/40856_2.png) [@stephenb](https://discuss.elastic.co/u/stephenb)\
**Post date:** [October 1, 2023, 7:01pm UTC](https://discuss.elastic.co/t/unable-to-authenticate-user-kibana-system/344192/4 "2023-10-01T19:01:02Z")

</div>

Hi @MdRashid I would strongly recommend following our official documentation, we prefer not to debug 3rd party instructions that may be inaccurate or out of date... a quick look at that shows it is nearly a year old and does not work with the latest 8.x versions.

Please refer to :

> **[Install Elasticsearch with Docker | Elasticsearch Guide \[8.10\] | Elastic](https://www.elastic.co/guide/en/elasticsearch/reference/current/docker.html?#docker-compose-file)**

---

<div class="post-metadata">

**Author:** ![MdRashid](https://avatars.discourse-cdn.com/v4/letter/m/839c29/32.png) [@MdRashid](https://discuss.elastic.co/u/MdRashid)\
**Post date:** [October 1, 2023, 7:04pm UTC](https://discuss.elastic.co/t/unable-to-authenticate-user-kibana-system/344192/5 "2023-10-01T19:04:52Z")

</div>

Hmmm,

u r right and i have that also ...

right now if u find any clue for that error me i can move to other task above link once i get free time i will do that

---

<div class="post-metadata">

**Author:** ![stephenb](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/stephenb/32/40856_2.png) [@stephenb](https://discuss.elastic.co/u/stephenb)\
**Post date:** [October 1, 2023, 7:14pm UTC](https://discuss.elastic.co/t/unable-to-authenticate-user-kibana-system/344192/6 "2023-10-01T19:14:41Z")

</div>

Besides our documentation

Here is a recent blog on our site for deploying the Stack

> **[Getting started with the Elastic Stack and Docker-Compose](https://www.elastic.co/blog/getting-started-with-the-elastic-stack-and-docker-compose)**
>
> In part one of this two-part series, we’ll dive into configuring the components of a standard Elastic Stack consisting of Elasticsearch, Logstash, Kibana, and Beats (ELK-B), on which we can immediately begin developing.

And here is a very popular and active repo for deploying the stack

> **[GitHub - deviantony/docker-elk: The Elastic stack (ELK) powered by Docker and...](https://github.com/deviantony/docker-elk)**
>
> The Elastic stack (ELK) powered by Docker and Compose. - GitHub - deviantony/docker-elk: The Elastic stack (ELK) powered by Docker and Compose.

So apologies. Spending time fixing errors on a repo with little or no support is not a good use of time.

---

<div class="post-metadata">

**Author:** ![stephenb](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/stephenb/32/40856_2.png) [@stephenb](https://discuss.elastic.co/u/stephenb)\
**Post date:** [October 1, 2023, 7:22pm UTC](https://discuss.elastic.co/t/unable-to-authenticate-user-kibana-system/344192/7 "2023-10-01T19:22:02Z")

</div>

For example in the compose, you are looking at if you changed the versions

` image: docker.elastic.co/elasticsearch/elasticsearch:7.15.0`

to 8.x or something this compose will never work  
Also, the error is about SSL but it looks like SSL is not enabled so I have no idea... well that may be related to changing to 8.x.  
You should really start from one of the approved sources.

Not to mention you have changes

```auto
elasticsearch.username: kibana_system
elasticsearch.password: changeme

```

Which makes me think you are trying 8.x ...

So again this compose will not work...

---

<div class="post-metadata">

**Author:** ![MdRashid](https://avatars.discourse-cdn.com/v4/letter/m/839c29/32.png) [@MdRashid](https://discuss.elastic.co/u/MdRashid)\
**Post date:** [October 2, 2023, 8:34am UTC](https://discuss.elastic.co/t/unable-to-authenticate-user-kibana-system/344192/9 "2023-10-02T08:34:11Z")

</div>

Thanks for all that u provided

But i follow this active and popular repo ([GitHub - deviantony/docker-elk: The Elastic stack (ELK) powered by Docker and Compose.](https://github.com/deviantony/docker-elk))  
and Got error in

```auto
root@Testing:~/ELK/docker-elk# docker-compose up setup
ERROR: The Compose file './docker-compose.yml' is invalid because:
Unsupported config option for services.setup: 'profiles'
root@Testing:~/ELK/docker-elk# docker stack deploy -c docker-compose.yml elk
services.setup Additional property profiles is not allowed

```

And I didnt make any changes in docker-compose.yml file

```auto
 # '--profile=setup' CLI flag to Compose commands, or "up" the service by name
  # such as 'docker compose up setup'.
  setup:
    profiles:
      - setup
    build:
      context: setup/
      args:
        ELASTIC_VERSION: ${ELASTIC_VERSION}
    init: true

```

And if i follow this link [Getting started with the Elastic Stack and Docker-Compose | Elastic Blog](https://www.elastic.co/blog/getting-started-with-the-elastic-stack-and-docker-compose)  
i got error and follow same procedure which showing in above link

root@Testing:~/ELK/ELK-B# docker stack deploy -c docker-compose.yml elk

```auto
Compose file contains unsupported options:

mem_limit: Set resource limits using deploy.resources

```

root@Testing:~/ELK/ELK-B# docker-compose up -d

```auto
ERROR: The Compose file './docker-compose.yml' is invalid because:
Unsupported config option for services.es01: 'mem_limit'
Unsupported config option for services.kibana: 'mem_limit'
services.logstash01.depends_on contains an invalid type, it should be an array
services.metricbeat01.depends_on contains an invalid type, it should be an array
services.filebeat01.depends_on contains an invalid type, it should be an array
services.kibana.depends_on contains an invalid type, it should be an array
services.es01.depends_on contains an invalid type, it should be an array

```

root@Testing:~/ELK/ELK-B# docker-compose version

```auto
docker-compose version 1.25.0, build unknown
docker-py version: 4.1.0
CPython version: 3.8.10
OpenSSL version: OpenSSL 1.1.1f 31 Mar 2020

```

And Im using ubuntu 18.04

```auto
16 GB	8VCPU	240 GB HDD

```

Im executing using docker stack deploy NOT docker-compose up

---

<div class="post-metadata">

**Author:** ![stephenb](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/stephenb/32/40856_2.png) [@stephenb](https://discuss.elastic.co/u/stephenb)\
**Post date:** [October 2, 2023, 2:41pm UTC](https://discuss.elastic.co/t/unable-to-authenticate-user-kibana-system/344192/10 "2023-10-02T14:41:53Z")

</div>

@MdRashid

I think you are on an ancient version of docker-compose 1.25.0 is like 2019 🙂

It should be like 2.21 or 2.22

> **[Docker Compose release notes](https://docs.docker.com/compose/release-notes/#120)**
>
> Release notes for Docker Compose

That is why I think all those settings are not supported.

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [October 30, 2023, 2:42pm UTC](https://discuss.elastic.co/t/unable-to-authenticate-user-kibana-system/344192/11 "2023-10-30T14:42:00Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
