# Unable to configure elastic search apt repository as a remote repository in Artifactory

**URL:** <https://discuss.elastic.co/t/unable-to-configure-elastic-search-apt-repository-as-a-remote-repository-in-artifactory/330286>\
**Category:** Elasticsearch\
**Created:** [April 19, 2023, 9:20am UTC](https://discuss.elastic.co/t/unable-to-configure-elastic-search-apt-repository-as-a-remote-repository-in-artifactory/330286 "2023-04-19T09:20:49Z")\
**Posts on this page:** 6\
**Page:** 1

<div class="post-metadata">

**Author:** ![joaobaptista](https://avatars.discourse-cdn.com/v4/letter/j/6de8d8/32.png) [@joaobaptista](https://discuss.elastic.co/u/joaobaptista)\
**Post date:** [April 19, 2023, 9:20am UTC](https://discuss.elastic.co/t/unable-to-configure-elastic-search-apt-repository-as-a-remote-repository-in-artifactory/330286/1 "2023-04-19T09:20:49Z")

</div>

Hi all,

We are trying to configure Elasticsearch apt repository in Artifactory, but it always fails due to a error: "HTTP ERROR 404"

We are using the following URL: [https://artifacts.elastic.co/packages/8.x/apt](https://artifacts.elastic.co/packages/8.x/apt)

The same issue occur if i try to setup the rpm remote repository with the following URL: [https://artifacts.elastic.co/packages/8.x/yum/](https://artifacts.elastic.co/packages/8.x/yum/)

Does anyone knows why this happens? Isn't it possible to set the apt repository this way, or there's another URL to do it?

Thank you very much

---

<div class="post-metadata">

**Author:** ![warkolm](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/warkolm/32/39224_2.png) [@warkolm](https://discuss.elastic.co/u/warkolm)\
**Post date:** [April 19, 2023, 11:54pm UTC](https://discuss.elastic.co/t/unable-to-configure-elastic-search-apt-repository-as-a-remote-repository-in-artifactory/330286/2 "2023-04-19T23:54:07Z")

</div>

Welcome to our community! 😃

Please see [Are you getting 403's when downloading? Please read here first](https://discuss.elastic.co/t/are-you-getting-403s-when-downloading-please-read-here-first/307340/)

---

<div class="post-metadata">

**Author:** ![joaobaptista](https://avatars.discourse-cdn.com/v4/letter/j/6de8d8/32.png) [@joaobaptista](https://discuss.elastic.co/u/joaobaptista)\
**Post date:** [April 20, 2023, 1:44pm UTC](https://discuss.elastic.co/t/unable-to-configure-elastic-search-apt-repository-as-a-remote-repository-in-artifactory/330286/3 "2023-04-20T13:44:13Z")

</div>

Hi,

Thanks for your reply.

It isn't **403 error** when downloading, it's **HTTP ERROR 404** when trying to setup the repository using the URL: [https://artifacts.elastic.co/packages/8.x/apt](https://artifacts.elastic.co/packages/8.x/apt) or the yum.

Since it can't find the page, we just can't setup it as a remote repository in Jfrog artifactory.

I wonder if someone had a similar problem and how it was fixed (or if even possible).

Thanks!

---

<div class="post-metadata">

**Author:** ![warkolm](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/warkolm/32/39224_2.png) [@warkolm](https://discuss.elastic.co/u/warkolm)\
**Post date:** [April 20, 2023, 9:58pm UTC](https://discuss.elastic.co/t/unable-to-configure-elastic-search-apt-repository-as-a-remote-repository-in-artifactory/330286/4 "2023-04-20T21:58:20Z")

</div>

Ahh sorry, I am used to seeing so many 403s I misread that.

Our RPM repo instructions are at [Install Elasticsearch with RPM | Elasticsearch Guide [8.7] | Elastic](https://www.elastic.co/guide/en/elasticsearch/reference/8.7/rpm.html). If this is what you are doing then it'd be good to see the commands you are running to set it up, the install commands you are running and the output.

---

<div class="post-metadata">

**Author:** ![joaobaptista](https://avatars.discourse-cdn.com/v4/letter/j/6de8d8/32.png) [@joaobaptista](https://discuss.elastic.co/u/joaobaptista)\
**Post date:** [April 24, 2023, 9:00am UTC](https://discuss.elastic.co/t/unable-to-configure-elastic-search-apt-repository-as-a-remote-repository-in-artifactory/330286/5 "2023-04-24T09:00:57Z")

</div>

> [@warkolm](#):
>
> what

Hey there,

Thanks again for your reply.

Maybe i didn't explain my self properly 😀.

My goal here's to setup the Elastic Search APT package repository as a "[Remote Repository](https://jfrog.com/knowledge-base/remote-repositories-and-how-they-work/)" (caching proxy for a repository located on a remote server).

If i use the URL provided in Elasticsearch documentation to setup the remote repository i get HTTP ERROR 404 (this can be reproduced by simply using a browser and try to open: [https://artifacts.elastic.co/packages/8.x/apt](https://artifacts.elastic.co/packages/8.x/apt)).

Experts from Artifactory say they can't setup the repo with this URL, and after some research in the web, i see some people refering to Elasticsearch repositories as "non browsable" because it doesn't generate the index files ... this explains the issue while trying to setup the caching proxy.

And so, what i want to know is if there's an URL or other alternative to set this up? or if anyone experienced this kind of issue? and how they overcome/workaround it?

Please note, i don't have any issues setting up the repo as explained in the ES documentation on a endpoint or system, but i do have a scenario where i can't set this up this way because the systems aren't able to reach the internet, but they are able to reach the Artifactory instance.

Thank you very much

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [May 22, 2023, 9:01am UTC](https://discuss.elastic.co/t/unable-to-configure-elastic-search-apt-repository-as-a-remote-repository-in-artifactory/330286/6 "2023-05-22T09:01:29Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
