# Unable to configure SMTP on elasticsearch(7.5)

**URL:** <https://discuss.elastic.co/t/unable-to-configure-smtp-on-elasticsearch-7-5/214389>\
**Category:** Elasticsearch\
**Tags:** elastic-stack-alerting\
**Created:** [January 9, 2020, 9:29am UTC](https://discuss.elastic.co/t/unable-to-configure-smtp-on-elasticsearch-7-5/214389 "2020-01-09T09:29:11Z")\
**Posts on this page:** 3\
**Page:** 1

<div class="post-metadata">

**Author:** ![tahseen\_fatima](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/tahseen_fatima/32/67789_2.png) [@tahseen\_fatima](https://discuss.elastic.co/u/tahseen_fatima)\
**Post date:** [January 9, 2020, 9:29am UTC](https://discuss.elastic.co/t/unable-to-configure-smtp-on-elasticsearch-7-5/214389/1 "2020-01-09T09:29:11Z")

</div>

Hi,

I have a setup of elk on centos with a version of 7.5, and I am trying to configure SMTP but I am unable to do it.  
I have my 1 year license enabled.  
Due to the following error:

```
   [2020-01-09T20:21:13,278][WARN][o.e.b.ElasticsearchUncaughtExceptionHandler] [localhost.localdomain] uncaught exception in thread [main]
org.elasticsearch.bootstrap.StartupException: java.lang.IllegalArgumentException: unknown secure setting [xpack.notification.email.account.company_account.smtp.password] please check that any required plugins are installed, or check the breaking changes documentation for removed settings
	at org.elasticsearch.bootstrap.Elasticsearch.init(Elasticsearch.java:163) ~[elasticsearch-7.5.1.jar:7.5.1]
	at org.elasticsearch.bootstrap.Elasticsearch.execute(Elasticsearch.java:150) ~[elasticsearch-7.5.1.jar:7.5.1]
	at org.elasticsearch.cli.EnvironmentAwareCommand.execute(EnvironmentAwareCommand.java:86) ~[elasticsearch-7.5.1.jar:7.5.1]
	at org.elasticsearch.cli.Command.mainWithoutErrorHandling(Command.java:125) ~[elasticsearch-cli-7.5.1.jar:7.5.1]
	at org.elasticsearch.cli.Command.main(Command.java:90) ~[elasticsearch-cli-7.5.1.jar:7.5.1]
	at org.elasticsearch.bootstrap.Elasticsearch.main(Elasticsearch.java:115) ~[elasticsearch-7.5.1.jar:7.5.1]
	at org.elasticsearch.bootstrap.Elasticsearch.main(Elasticsearch.java:92) ~[elasticsearch-7.5.1.jar:7.5.1]

```

And here is my elastic config file:

```
xpack.watcher.enabled: true
xpack.notification.email.account:
    company_account:
        profile: company
        smtp:
            auth: true
            starttls.enable: true
            host: smtp.company.in
            port: 25
            user: abc@company.com

```

I have added this line as well

```
bin/elasticsearch-keystore add xpack.notification.email.account.comapny_account.smtp.secure_password

```

Please help,

Thanks,  
Tahseen

---

<div class="post-metadata">

**Author:** ![tahseen\_fatima](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/tahseen_fatima/32/67789_2.png) [@tahseen\_fatima](https://discuss.elastic.co/u/tahseen_fatima)\
**Post date:** [January 9, 2020, 11:41am UTC](https://discuss.elastic.co/t/unable-to-configure-smtp-on-elasticsearch-7-5/214389/2 "2020-01-09T11:41:16Z")

</div>

Hello,

Error got solved.

I downloaded the new elasticsearch and configure the same log path, log data and follow the following step of this below link.  
[https://www.elastic.co/guide/en/elasticsearch/reference/7.0/actions-email.html#configuring-email](https://www.elastic.co/guide/en/elasticsearch/reference/7.0/actions-email.html#configuring-email)

Thanks,  
Tahseen

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [February 6, 2020, 11:41am UTC](https://discuss.elastic.co/t/unable-to-configure-smtp-on-elasticsearch-7-5/214389/3 "2020-02-06T11:41:24Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
