# Unable to connect ElasticSearch using a IP address

**URL:** <https://discuss.elastic.co/t/unable-to-connect-elasticsearch-using-a-ip-address/43926>\
**Category:** Elasticsearch\
**Created:** [March 9, 2016, 6:05pm UTC](https://discuss.elastic.co/t/unable-to-connect-elasticsearch-using-a-ip-address/43926 "2016-03-09T18:05:47Z")\
**Posts on this page:** 4\
**Page:** 1

<div class="post-metadata">

**Author:** ![Sameer\_Panicker](https://avatars.discourse-cdn.com/v4/letter/s/d9b06d/32.png) [@Sameer\_Panicker](https://discuss.elastic.co/u/Sameer_Panicker)\
**Post date:** [March 9, 2016, 6:05pm UTC](https://discuss.elastic.co/t/unable-to-connect-elasticsearch-using-a-ip-address/43926/1 "2016-03-09T18:05:47Z")

</div>

I am able to run ES using [http://localhost:9200/](http://localhost:9200/). But unable to search using my own IP address instead of localhost  
i.e. [http://123.123.123.123:9200](http://123.123.123.123:9200)

Hence, I am unable to send logs from other servers(remotely). This works fine with Kibana.

What am I missing here...Any help would be great inorder for me to proceed further

---

<div class="post-metadata">

**Author:** ![magnusbaeck](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/magnusbaeck/32/44943_2.png) [@magnusbaeck](https://discuss.elastic.co/u/magnusbaeck)\
**Post date:** [March 9, 2016, 8:28pm UTC](https://discuss.elastic.co/t/unable-to-connect-elasticsearch-using-a-ip-address/43926/2 "2016-03-09T20:28:15Z")

</div>

By default ES 2.0 only binds to localhost. Look at the network.host setting in elasticsearch.yml.

---

<div class="post-metadata">

**Author:** ![Sameer\_Panicker](https://avatars.discourse-cdn.com/v4/letter/s/d9b06d/32.png) [@Sameer\_Panicker](https://discuss.elastic.co/u/Sameer_Panicker)\
**Post date:** [March 10, 2016, 4:18am UTC](https://discuss.elastic.co/t/unable-to-connect-elasticsearch-using-a-ip-address/43926/3 "2016-03-10T04:18:14Z")

</div>

Got the issue resolved. Thanks

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [July 5, 2017, 11:09pm UTC](https://discuss.elastic.co/t/unable-to-connect-elasticsearch-using-a-ip-address/43926/4 "2017-07-05T23:09:43Z")

</div>


