# Unable to connect filbeat to logstash

**URL:** <https://discuss.elastic.co/t/unable-to-connect-filbeat-to-logstash/350912>\
**Category:** Elasticsearch\
**Tags:** elastic-stack-monitoring, elastic-stack-alerting, ilm-index-lifecycle-management\
**Created:** [January 12, 2024, 7:32am UTC](https://discuss.elastic.co/t/unable-to-connect-filbeat-to-logstash/350912 "2024-01-12T07:32:56Z")\
**Posts on this page:** 2\
**Page:** 1

<div class="post-metadata">

**Author:** ![dark\_header](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/dark_header/32/130733_2.png) [@dark\_header](https://discuss.elastic.co/u/dark_header)\
**Post date:** [January 12, 2024, 7:32am UTC](https://discuss.elastic.co/t/unable-to-connect-filbeat-to-logstash/350912/1 "2024-01-12T07:32:56Z")

</div>

hi team , installed in ELK ( Elasticsearch , logstash , kibana and filebeat ) in same server  
unable to connect from filebeat to logstash , getting error below  
{"log.level":"error","timestamp":"2024-01-11T17:49:55.606+0530","log.logger":"publisher\_pipeline\_output","log.origin":{"file.name":"pipeline/client\_worker.go","file.line":148},"message":"Failed to connect to backoff(async(tcp://127.0.0.1:5044)): read tcp 127.0.0.1:13860-\>127.0.0.1:5044: read: connection reset by peer","service.name":"filebeat","ecs.version":"1.6.0"}  
filbeat.yml  
filebeat.inputs:

- type: log  
enabled: true  
paths:
  - /var/log/varnish/varnishncsa.lstat  
scan\_frequency: 2s  
tail\_files: false  
backoff: 0.5s  
max\_backoff: 1s  
tags: ['iad1']  
exclude\_lines: ['PURGE', 'healthcheck.txt', '- - -']  
output.logstash:  
hosts: ["127.0.0.1:5044"]  
loadbalance: true  
pipelining: 0  
ttl: 300s  
ssl.certificate\_authorities: ["/etc/filebeat/ca.crt"]  
logging:  
level: info  
to\_files: true  
to\_syslog: false  
logstash file :  
input {  
beats {  
port =\> 5044  
}  
}  
output {  
elasticsearch {  
hosts =\> [" [http://localhost:9200](http://localhost:9200)"]  
index =\> "%{[@ metadata][beat]}-%{[@ metadata][version]}"  
}  
}  
all services are running fine , even firewall also allowed  
i was trying since 3 days to resolve this iissue , if u solve this issue, u will get reward

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [February 9, 2024, 7:33am UTC](https://discuss.elastic.co/t/unable-to-connect-filbeat-to-logstash/350912/2 "2024-02-09T07:33:31Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
