# Unable to connect filebeat with kibana to load dashboard

**URL:** <https://discuss.elastic.co/t/unable-to-connect-filebeat-with-kibana-to-load-dashboard/313300>\
**Category:** Beats\
**Tags:** filebeat\
**Created:** [August 30, 2022, 10:39pm UTC](https://discuss.elastic.co/t/unable-to-connect-filebeat-with-kibana-to-load-dashboard/313300 "2022-08-30T22:39:18Z")\
**Posts on this page:** 7\
**Page:** 1

<div class="post-metadata">

**Author:** ![Ahlam\_Abubaker](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/ahlam_abubaker/32/97607_2.png) [@Ahlam\_Abubaker](https://discuss.elastic.co/u/Ahlam_Abubaker)\
**Post date:** [August 30, 2022, 10:39pm UTC](https://discuss.elastic.co/t/unable-to-connect-filebeat-with-kibana-to-load-dashboard/313300/1 "2022-08-30T22:39:18Z")

</div>

Hi there,  
I'm running kibana behind apache2 proxy  
kibana is running in localhost port 5601  
and my apache2 IP & port as 46.246.x.x:yyyy

when I ran **./filebeat setup -e** command in order to connect filebeat on client server to kibana on host server  
I'm getting this result

```auto
Index setup finished.
Loading dashboards (Kibana must be running and reachable)
Exiting: error connecting to Kibana: fail to get the Kibana version: HTTP GET request to http://46.246.x.x:yyyy/api/status fails: fail to execute the HTTP GET request: Get "http://46.246.x.x:yyyy/api/status": net/http: request canceled while waiting for connection (Client.Timeout exceeded while awaiting headers). Response: 

```

my filebeat.yml as below

```auto
setup.kibana:
   host: "46.246.x.x:yyyy" 
   username: "username"
   password: "password"

```

my kibana.yml

```auto
# =================== System: Kibana Server ===================
# Kibana is served by a back end server. This setting specifies the port to use.
#server.port: 5601

# Specifies the address to which the Kibana server will bind. IP addresses and host names are both valid values.
# The default is 'localhost', which usually means remote machines will not be able to connect.
# To allow connections from remote users, set this parameter to a non-loopback address.
#server.host: "0.0.0.0"

# Enables you to specify a path to mount Kibana at if you are running behind a proxy.
# Use the `server.rewriteBasePath` setting to tell Kibana if it should remove the basePath
# from requests it receives, and to prevent a deprecation warning at startup.
# This setting cannot end in a slash.
#server.basePath: ""

# Specifies whether Kibana should rewrite requests that are prefixed with
# `server.basePath` or require that they are rewritten by your reverse proxy.
# Defaults to `false`.
#server.rewriteBasePath: false

# Specifies the public URL at which Kibana is available for end users. If
# `server.basePath` is configured this URL should end with the same basePath.
#server.publicBaseUrl: ""

# The maximum payload size in bytes for incoming server requests.
#server.maxPayload: 1048576

# The Kibana server's name. This is used for display purposes.
#server.name: "your-hostname"

```

---

<div class="post-metadata">

**Author:** ![Rios](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/rios/32/95745_2.png) [@Rios](https://discuss.elastic.co/u/Rios)\
**Post date:** [August 31, 2022, 6:53am UTC](https://discuss.elastic.co/t/unable-to-connect-filebeat-with-kibana-to-load-dashboard/313300/2 "2022-08-31T06:53:34Z")

</div>

> [@Ahlam\_Abubaker](#):
>
> `setup.kibana`

Default protocol is http, might be you need https. Read [this](https://www.elastic.co/guide/en/beats/filebeat/current/setup-kibana-endpoint.html)

---

<div class="post-metadata">

**Author:** ![Ahlam\_Abubaker](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/ahlam_abubaker/32/97607_2.png) [@Ahlam\_Abubaker](https://discuss.elastic.co/u/Ahlam_Abubaker)\
**Post date:** [August 31, 2022, 7:16am UTC](https://discuss.elastic.co/t/unable-to-connect-filebeat-with-kibana-to-load-dashboard/313300/3 "2022-08-31T07:16:03Z")

</div>

could you tell me why would I use https if I can access kibana from browser using [http://46.246.x.x](http://46.246.x.x):yyyy  
I didn't use https protocol in kibana.yml nor in apache2

---

<div class="post-metadata">

**Author:** ![Rios](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/rios/32/95745_2.png) [@Rios](https://discuss.elastic.co/u/Rios)\
**Post date:** [August 31, 2022, 7:47am UTC](https://discuss.elastic.co/t/unable-to-connect-filebeat-with-kibana-to-load-dashboard/313300/4 "2022-08-31T07:47:35Z")

</div>

HTTPS is not mandatory, just recommended.  
Your filebeat host must see Kibana over port yyyy. Check with telnet or curl.  
Does your kibana user, have rights to trigger APIs? Test with  
_curl -u username [http://46.246.x.x](http://46.246.x.x):yyyy/api/status_

---

<div class="post-metadata">

**Author:** ![Ahlam\_Abubaker](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/ahlam_abubaker/32/97607_2.png) [@Ahlam\_Abubaker](https://discuss.elastic.co/u/Ahlam_Abubaker)\
**Post date:** [August 31, 2022, 8:28am UTC](https://discuss.elastic.co/t/unable-to-connect-filebeat-with-kibana-to-load-dashboard/313300/5 "2022-08-31T08:28:57Z")

</div>

I tried to curl with kibana user on my local machine and on on filebeat host

on my local machine I could obtain results  
but on my filebeat host I got

```auto
curl: (28) Failed to connect to 46.246.x.x port yyyy: Connection timed out

```

---

<div class="post-metadata">

**Author:** ![Rios](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/rios/32/95745_2.png) [@Rios](https://discuss.elastic.co/u/Rios)\
**Post date:** [August 31, 2022, 9:01am UTC](https://discuss.elastic.co/t/unable-to-connect-filebeat-with-kibana-to-load-dashboard/313300/6 "2022-08-31T09:01:11Z")

</div>

The TCP connection is not opened from the filebeat server to Kibana. Firewall issue.

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [September 28, 2022, 11:01am UTC](https://discuss.elastic.co/t/unable-to-connect-filebeat-with-kibana-to-load-dashboard/313300/7 "2022-09-28T11:01:29Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
