# Unable to connect logstash with SQLSERVER

**URL:** <https://discuss.elastic.co/t/unable-to-connect-logstash-with-sqlserver/92642>\
**Category:** Logstash\
**Created:** [July 11, 2017, 12:30pm UTC](https://discuss.elastic.co/t/unable-to-connect-logstash-with-sqlserver/92642 "2017-07-11T12:30:59Z")\
**Posts on this page:** 3\
**Page:** 1

<div class="post-metadata">

**Author:** ![Blue\_Moon](https://avatars.discourse-cdn.com/v4/letter/b/919ad9/32.png) [@Blue\_Moon](https://discuss.elastic.co/u/Blue_Moon)\
**Post date:** [July 11, 2017, 12:30pm UTC](https://discuss.elastic.co/t/unable-to-connect-logstash-with-sqlserver/92642/1 "2017-07-11T12:30:59Z")

</div>

i am using the below configuration.  
input{  
jdbc {  
jdbc\_connection\_string =\> "jdbc:sqlserver:rpdidbtest.database.windows.net;databaseName=TEST\_DB;integratedSecurity=false;user= **_;password=_** _;"  
jdbc\_user =\> "_**"  
jdbc\_password =\> "**\*_"  
jdbc\_driver\_library =\> "../../../../etc/logstash/driver/sqljdbc\_6.0/enu/jre8/sqljdbc42.jar"  
jdbc\_driver\_class =\> "com.microsoft.sqlserver.jdbc.SQLServerDriver"  
# Shedule is once per hour or customise in cron type syntax  
schedule =\> "_ \* \* \* \*"  
statement =\> "SELECT \* FROM dbo.CUSTOMERS"  
# Uncomment and experiement for large tables  
#jdbc\_paging\_enabled =\> true  
#jdbc\_page\_size =\> 15000  
#jdbc\_fetch\_size =\> 5000  
}  
}

output {  
elasticsearch {  
hosts =\> "localhost:9200"  
index =\> "rpdi-lc-data"  
document\_type =\> "customers"  
document\_id =\> "%{ID}"  
}  
stdout {  
codec =\> rubydebug  
}  
}

but getting connection error.  
10:47:00.265 [Ruby-0-Thread-16: /usr/share/logstash/vendor/bundle/jruby/1.9/gems/rufus-scheduler-3.0.9/lib/rufus/scheduler/jobs.rb:283] WARN logstash.inputs. jdbc - Exception when executing JDBC query {:exception=\>#\<Sequel::DatabaseConnectionError: Sequel::DatabaseError: driver.new.connect returned nil: probably ba d JDBC connection string\>}  
10:47:00.265 [Ruby-0-Thread-16: /usr/share/logstash/vendor/bundle/jruby/1.9/gems/rufus-scheduler-3.0.9/lib/rufus/scheduler/jobs.rb:283] WARN logstash.inputs. jdbc - Attempt reconnection.  
10:47:00.269 [Ruby-0-Thread-16: /usr/share/logstash/vendor/bundle/jruby/1.9/gems/rufus-scheduler-3.0.9/lib/rufus/scheduler/jobs.rb:283] WARN logstash.inputs. jdbc - Failed test\_connection.  
{ 420476 rufus-scheduler intercepted an error:  
420476 job:  
420476 Rufus::Scheduler::CronJob "\* \* \* \* \*" {}  
420476 error:  
420476 420476  
420476 NoMethodError  
420476 undefined method `close_jdbc_connection' for #<Sequel::JDBC::Database:0x589530a1> 420476 /usr/share/logstash/vendor/bundle/jruby/1.9/gems/logstash-input-jdbc-4.2.0/lib/logstash/plugin_mixins/jdbc.rb:174:in`open\_jdbc\_connection'  
420476 /usr/share/logstash/vendor/bundle/jruby/1.9/gems/logstash-input-jdbc-4.2.0/lib/logstash/plugin\_mixins/jdbc.rb:247:in `execute_statement' 420476 /usr/share/logstash/vendor/bundle/jruby/1.9/gems/logstash-input-jdbc-4.2.0/lib/logstash/inputs/jdbc.rb:272:in`execute\_query'  
420476 /usr/share/logstash/vendor/bundle/jruby/1.9/gems/logstash-input-jdbc-4.2.0/lib/logstash/inputs/jdbc.rb:250:in `run' 420476 org/jruby/RubyProc.java:281:in`call'  
420476 /usr/share/logstash/vendor/bundle/jruby/1.9/gems/rufus-scheduler-3.0.9/lib/rufus/scheduler/jobs.rb:234:in `do_call' 420476 /usr/share/logstash/vendor/bundle/jruby/1.9/gems/rufus-scheduler-3.0.9/lib/rufus/scheduler/jobs.rb:258:in`do\_trigger'  
420476 /usr/share/logstash/vendor/bundle/jruby/1.9/gems/rufus-scheduler-3.0.9/lib/rufus/scheduler/jobs.rb:300:in `start_work_thread' 420476 org/jruby/RubyProc.java:281:in`call'  
420476 /usr/share/logstash/vendor/bundle/jruby/1.9/gems/rufus-scheduler-3.0.9/lib/rufus/scheduler/jobs.rb:299:in `start_work_thread' 420476 org/jruby/RubyKernel.java:1479:in`loop'  
420476 /usr/share/logstash/vendor/bundle/jruby/1.9/gems/rufus-scheduler-3.0.9/lib/rufus/scheduler/jobs.rb:289:in `start\_work\_thread'

---

<div class="post-metadata">

**Author:** ![Blue\_Moon](https://avatars.discourse-cdn.com/v4/letter/b/919ad9/32.png) [@Blue\_Moon](https://discuss.elastic.co/u/Blue_Moon)\
**Post date:** [July 13, 2017, 1:44pm UTC](https://discuss.elastic.co/t/unable-to-connect-logstash-with-sqlserver/92642/2 "2017-07-13T13:44:46Z")

</div>

Issue has been resolved. I have a problem with connection string.

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [August 10, 2017, 1:44pm UTC](https://discuss.elastic.co/t/unable-to-connect-logstash-with-sqlserver/92642/3 "2017-08-10T13:44:52Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
