# Unable to connect to elastic search server connection refused

**URL:** https://discuss.elastic.co/t/unable-to-connect-to-elastic-search-server-connection-refused/157041
**Category:** Elasticsearch
**Created:** [November 16, 2018, 11:41am UTC](https://discuss.elastic.co/t/unable-to-connect-to-elastic-search-server-connection-refused/157041 "2018-11-16T11:41:22Z")
**Posts on this page:** 4
**Page:** 1

<div class="post-metadata">

### Author: ![unnikrishnan\_b](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/unnikrishnan_b/32/37734_2.png) [@unnikrishnan\_b](https://discuss.elastic.co/u/unnikrishnan_b)
#### Post date: [November 16, 2018, 11:41am UTC](https://discuss.elastic.co/t/unable-to-connect-to-elastic-search-server-connection-refused/157041/1 "2018-11-16T11:41:22Z")

</div>

I'm unable to connect to elasticsearch server form my browser. Connection get refusing.

There is no error in the log file

see the following elastic search config file:

`# ======================== Elasticsearch Configuration =========================

# 

# NOTE: Elasticsearch comes with reasonable defaults for most settings.

# Before you set out to tweak and tune the configuration, make sure you

# understand what are you trying to accomplish and the consequences.

# 

# The primary way of configuring a node is via this file. This template lists

# the most important settings you may want to configure for a production cluster.

# 

# Please consult the documentation for further information on configuration options:

# [https://www.elastic.co/guide/en/elasticsearch/reference/index.html](https://www.elastic.co/guide/en/elasticsearch/reference/index.html)

# 

# ---------------------------------- Cluster -----------------------------------

# 

# Use a descriptive name for your cluster:

# 

cluster.name: elasticsearch\_loipl

# 

# ------------------------------------ Node ------------------------------------

# 

# Use a descriptive name for the node:

# 

#node.name: node-1

# 

# Add custom attributes to the node:

# 

#node.attr.rack: r1

# 

# ----------------------------------- Paths ------------------------------------

# 

# Path to directory where to store the data (separate multiple locations by comma):

# 

path.data: /usr/local/var/lib/elasticsearch/

# 

# Path to log files:

# 

path.logs: /usr/local/var/log/elasticsearch/

# 

# ----------------------------------- Memory -----------------------------------

# 

# Lock the memory on startup:

# 

#bootstrap.memory\_lock: true

# 

# Make sure that the heap size is set to about half the memory available

# on the system and that the owner of the process is allowed to use this

# limit.

# 

# Elasticsearch performs poorly when the system is swapping the memory.

# 

# ---------------------------------- Network -----------------------------------

# 

# Set the bind address to a specific IP (IPv4 or IPv6):

# 

# 

# network.host: 192.168.0.1

# Set a custom port for HTTP:

# 

# http.port: 9200

# 

# For more information, consult the network module documentation.

# 

# --------------------------------- Discovery ----------------------------------

# 

# Pass an initial list of hosts to perform discovery when new node is started:

# The default list of hosts is ["127.0.0.1", "[::1]"]

# 

#discovery.zen.ping.unicast.hosts: ["host1", "host2"]

# 

# Prevent the "split brain" by configuring the majority of nodes (total number of master-eligible nodes / 2 + 1):

# 

#discovery.zen.minimum\_master\_nodes:

# 

# For more information, consult the zen discovery module documentation.

# 

# ---------------------------------- Gateway -----------------------------------

# 

# Block initial recovery after a full cluster restart until N nodes are started:

# 

#gateway.recover\_after\_nodes: 3

# 

# For more information, consult the gateway module documentation.

# 

# ---------------------------------- Various -----------------------------------

# 

# Require explicit names when deleting indices:

# 

#action.destructive\_requires\_name: true`

---

<div class="post-metadata">

### Author: ![Jaspreet\_Singh](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/jaspreet_singh/32/58296_2.png) [@Jaspreet\_Singh](https://discuss.elastic.co/u/Jaspreet_Singh)
#### Post date: [November 19, 2018, 5:52pm UTC](https://discuss.elastic.co/t/unable-to-connect-to-elastic-search-server-connection-refused/157041/2 "2018-11-19T17:52:40Z")

</div>

What is your browser calling?  
Is there a server API that in turn goes to elasticsearch(ES)? Or is the browser calling out to ES directly?  
Can you also share the exact error you are seeing on browser?

---

<div class="post-metadata">

### Author: ![TimV](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/timv/32/13162_2.png) [@TimV](https://discuss.elastic.co/u/TimV)
#### Post date: [November 20, 2018, 4:56am UTC](https://discuss.elastic.co/t/unable-to-connect-to-elastic-search-server-connection-refused/157041/3 "2018-11-20T04:56:57Z")

</div>

Please make the effort to format your post to be as readable as possible.

In particular, when posting configuration files, or code blocks, please use the `</>` button to pre-format the content. Without this, the forums will present your post as if it were in markdown format, which will obscure your content and make it harder to help you.

---

<div class="post-metadata">

### Author: ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)
#### Post date: [December 18, 2018, 4:57am UTC](https://discuss.elastic.co/t/unable-to-connect-to-elastic-search-server-connection-refused/157041/4 "2018-12-18T04:57:01Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
