# Unable to connect to Elastic-Search Server

**URL:** <https://discuss.elastic.co/t/unable-to-connect-to-elastic-search-server/308804>\
**Category:** Elasticsearch\
**Created:** [July 4, 2022, 9:52am UTC](https://discuss.elastic.co/t/unable-to-connect-to-elastic-search-server/308804 "2022-07-04T09:52:38Z")\
**Posts on this page:** 2\
**Page:** 1

<div class="post-metadata">

**Author:** ![Shobhit\_Jain1](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/shobhit_jain1/32/97834_2.png) [@Shobhit\_Jain1](https://discuss.elastic.co/u/Shobhit_Jain1)\
**Post date:** [July 4, 2022, 9:52am UTC](https://discuss.elastic.co/t/unable-to-connect-to-elastic-search-server/308804/1 "2022-07-04T09:52:38Z")

</div>

A few months back, I deployed the Elastic-Search(version - 8.0.1) on Kubernetes as a service as External load balancer using this [guide](https://www.elastic.co/guide/en/cloud-on-k8s/master/k8s-deploy-elasticsearch.html).  
Now, I am unable to perform any read or write operation on ES. I checked the logs, in which I found that memory of the node is almost full.  
Here are some logs which support this analysis -

- flood stage disk watermark [95%] exceeded on [hulk-es-default-0][/usr/share/elasticsearch/data] free: 18.5mb[1.8%], all indices on this node will be marked read-only
- Cluster health status changed from [YELLOW] to [RED] (reason: [shards failed [[1][0]]]).
- This node is unhealthy: health check failed on [/usr/share/elasticsearch/data].

Here are the errors that are coming when performing any read/write operation -

- elasticsearch.exceptions.TransportError: TransportError(503, 'master\_not\_discovered\_exception', None)
- elasticsearch.exceptions.ConnectionTimeout: ConnectionTimeout caused by - ReadTimeoutError(HTTPSConnectionPool(host=' **.** _._ **.**', port=\*\*\*\*): Read timed out. (read timeout=30))

I don't think increasing the allocated storage space to the ES node is a long-term solution. Rather auto-scaling should be enabled.  
Can anyone guide me how to resolve this issue and whether my approach towards solution is correct or not?

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [August 1, 2022, 9:52am UTC](https://discuss.elastic.co/t/unable-to-connect-to-elastic-search-server/308804/2 "2022-08-01T09:52:39Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
