# Unable to connect to Elasticsearch. Error: index\_not\_found\_exception index\_not\_found\_exception: no such index \[.kibana\]

**URL:** https://discuss.elastic.co/t/unable-to-connect-to-elasticsearch-error-index-not-found-exception-index-not-found-exception-no-such-index-kibana/348026
**Category:** Elasticsearch
**Tags:** docker
**Created:** [November 27, 2023, 9:14am UTC](https://discuss.elastic.co/t/unable-to-connect-to-elasticsearch-error-index-not-found-exception-index-not-found-exception-no-such-index-kibana/348026 "2023-11-27T09:14:49Z")
**Posts on this page:** 3
**Page:** 1

<div class="post-metadata">

### Author: ![abkrim](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/abkrim/32/20217_2.png) [@abkrim](https://discuss.elastic.co/u/abkrim)
#### Post date: [November 27, 2023, 9:14am UTC](https://discuss.elastic.co/t/unable-to-connect-to-elasticsearch-error-index-not-found-exception-index-not-found-exception-no-such-index-kibana/348026/1 "2023-11-27T09:14:49Z")

</div>

I'm trying to install and configure a simple node on my local machine using Docker, following the [documentation](https://www.elastic.co/guide/en/elasticsearch/reference/current/docker.html).

However, when I try to execute the first step of the Kibana configuration and paste the enrollment token, it just hangs.

Upon checking the logs, I see there's a preceding issue:

```auto
2023-11-27 09:50:49 [2023-11-27T08:50:49.112+00:00][WARN][savedobjects-service] Unable to connect to Elasticsearch. Error: index_not_found_exception
2023-11-27 09:50:49 Root causes:
2023-11-27 09:50:49 index_not_found_exception: no such index [.kibana]
2023-11-27 09:50:49 [2023-11-27T08:50:49.141+00:00][INFO][savedobjects-service] [.kibana] INIT -> CREATE_NEW_TARGET. took: 25ms.

```

After this, there's nothing more to do but delete the container and try again. But still, no luck.

 ![CastrisElastic1127100035](https://us1.discourse-cdn.com/elastic/original/3X/d/8/d8d72b8854b9f5ca087cd76635461e079938f655.jpeg)

---

<div class="post-metadata">

### Author: ![abkrim](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/abkrim/32/20217_2.png) [@abkrim](https://discuss.elastic.co/u/abkrim)
#### Post date: [November 27, 2023, 6:31pm UTC](https://discuss.elastic.co/t/unable-to-connect-to-elasticsearch-error-index-not-found-exception-index-not-found-exception-no-such-index-kibana/348026/2 "2023-11-27T18:31:54Z")

</div>

Incredible.

I'm very stubborn, and it's already been four versions with ELK.

I'm not sure if it was the solution or if there have been changes, as when executing the container creation I've noticed that some layers have been updated since this morning.

But what I do know is that, by mistake, I regenerated the token with

```bash
docker exec -it es01 /usr/share/elasticsearch/bin/elasticsearch-create-enrollment-token -s kibana

```

And lo and behold, it worked.

Certainly, each ELK installation is quite a challenge.

---

<div class="post-metadata">

### Author: ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)
#### Post date: [December 25, 2023, 6:32pm UTC](https://discuss.elastic.co/t/unable-to-connect-to-elasticsearch-error-index-not-found-exception-index-not-found-exception-no-such-index-kibana/348026/3 "2023-12-25T18:32:41Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
