# Unable to connect to Elasticsearch. Error: Request Timeout

**URL:** <https://discuss.elastic.co/t/unable-to-connect-to-elasticsearch-error-request-timeout/261276>\
**Category:** Kibana\
**Created:** [January 15, 2021, 3:07pm UTC](https://discuss.elastic.co/t/unable-to-connect-to-elasticsearch-error-request-timeout/261276 "2021-01-15T15:07:35Z")\
**Posts on this page:** 4\
**Page:** 1

<div class="post-metadata">

**Author:** ![first100](https://avatars.discourse-cdn.com/v4/letter/f/6a8cbe/32.png) [@first100](https://discuss.elastic.co/u/first100)\
**Post date:** [January 15, 2021, 3:07pm UTC](https://discuss.elastic.co/t/unable-to-connect-to-elasticsearch-error-request-timeout/261276/1 "2021-01-15T15:07:35Z")

</div>

I tried to delete kibana\_1 index as stated in the previuos elastic log:

```
(Cluster health status changed from [RED] to [YELLOW] (reason: [shards started [[.kibana_1] ) :

```

so i ran:

```
DELETE /.kibana_1

```

and i received a success message.

this is my kibana.yml file:

```auto
     server.port: 5601
     server.host: [ipaddress]
     server.name: "servername"
     elasticsearch.hosts: [ipnode1, ipnode2, ipnode3]

```

and this is the log file of kibana:

```auto
    {"type":"log","@timestamp":"2021-01-15T14:26:14Z","tags":["warning","plugins- 
    discovery"],"pid":3176,"message":"Expect plugin \"id\" in camelCase, but found: 
    apm_oss"}
    {"type":"log","@timestamp":"2021-01-15T14:26:17Z","tags":["info","plugins- 
    service"],"pid":3176,"message":"Plugin \"visTypeXy\" is disabled."}
    {"type":"log","@timestamp":"2021-01-15T14:26:18Z","tags":["warning","legacy- 
    service"],"pid":3176,"message":"Some installed third party plugin(s) [apm_oss, 
    console_legacy, elasticsearch, kibana, newsfeed, region_map, status_page, 
    tile_map, timelion, ui_metric] are using the legacy plugin format and will no 
    longer work in a future Kibana release. Please refer to https://ela.st/kibana- 
    breaking-changes-8-0 for a list of breaking changes and https://ela.st/kibana- 
    platform-migration for documentation on how to migrate legacy plugins."}
   {"type":"log","@timestamp":"2021-01-15T14:26:18Z","tags":["info","plugins- 
   system"],"pid":3176,"message":"Setting up [42] plugins: 
   [usageCollection,telemetryCollectionManager,telemetry,kibanaLegacy,devTools,ui 
 Actions,statusPage,share,newsfeed,mapsLegacy,kibanaUtils,kibanaReact,inspector,embeddable,indexPatternManagement,esUiShared,discover,charts,bfetch,expressions,data,home,console,apm_oss,management,advancedSettings,telemetryManagementSection,visualizations,visTypeVislib,visTypeVega,visTypeTimeseries,visTypeTi 
 melion,visTypeTagcloud,visTypeTable,visTypeMetric,visTypeMarkdown,inputContr 
   olVis,savedObjects,navigation,visualize,dashboard,savedObjectsManagement]"}
   {"type":"log","@timestamp":"2021-01-15T14:26:19Z","tags":["info","savedobjects- 
   service"],"pid":3176,"message":"Waiting until all Elasticsearch nodes are 
   compatible with Kibana before starting saved objects migrations..."}
   {"type":"log","@timestamp":"2021-01-15T14:26:24Z","tags":["info","savedobjects- 
   service"],"pid":3176,"message":"Starting saved objects migrations"}
   {"type":"log","@timestamp":"2021-01-15T14:26:54Z","tags": 
   ["warning","savedobjects-service"],"pid":3176,"message":"Unable to connect to 
    Elasticsearch. Error: Request Timeout after 30000ms"}

```

this is the last part of the log of elastic cluster:

```auto
[2021-01-15T13:58:24,995][INFO][o.e.c.r.a.AllocationService] [cluster-node-1] Cluster health status changed from [RED] to [GREEN] (reason: [shards started [[index_att][0]]]).
[2021-01-15T14:40:48,800][INFO][o.e.c.m.MetadataDeleteIndexService] [elastic-cluster-node-1] [.kibana_2/21NiblINQRiAuG3kTEREhA] deleting index
[2021-01-15T14:44:29,509][INFO][o.e.c.m.MetadataCreateIndexService] [elastic-cluster-node-1] [.kibana_2] creating index, cause [api], templates [], shards [1]/[1], mappings [_doc]
[2021-01-15T14:44:29,525][INFO][o.e.c.r.a.AllocationService] [cluster-node-1] updating number_of_replicas to [0] for indices [.kibana_2]
[2021-01-15T14:44:29,884][INFO][o.e.c.r.a.AllocationService] [cluster-node-1] Cluster health status changed from [YELLOW] to [GREEN] (reason: [shards started [[.kibana_2][0]]])

```

this is elasticsearch.yml

```auto
cluster.name: elastic-cluster
node.name: cluster-node-1
path.data: H:\Elastic\data
path.logs: H:\Elastic\logs
network.host: 0.0.0.0
http.port: 9200
discovery.seed_hosts: ["srvenv1", "srvenv2", "srvenv3"]
cluster.initial_master_nodes: ["cluster-node-1", "cluster-node-2", "cluster-node-3"]

```

Can anyone help me?  
Thanks

---

<div class="post-metadata">

**Author:** ![Nathan\_Reese](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/nathan_reese/32/84829_2.png) [@Nathan\_Reese](https://discuss.elastic.co/u/Nathan_Reese)\
**Post date:** [January 15, 2021, 5:55pm UTC](https://discuss.elastic.co/t/unable-to-connect-to-elasticsearch-error-request-timeout/261276/2 "2021-01-15T17:55:59Z")

</div>

Can you ping elasticsearch nodes from your server running kibana? What is the response of running `curl http://your_es_ip:9200/`?

---

<div class="post-metadata">

**Author:** ![first100](https://avatars.discourse-cdn.com/v4/letter/f/6a8cbe/32.png) [@first100](https://discuss.elastic.co/u/first100)\
**Post date:** [January 15, 2021, 8:28pm UTC](https://discuss.elastic.co/t/unable-to-connect-to-elasticsearch-error-request-timeout/261276/3 "2021-01-15T20:28:11Z")

</div>

thanks for reply, i execute command in server where have node 1 of elastic and kibana , the response is:

```auto
{
  "name" : "cluster-node-1",
  "cluster_name" : "elastic-cluster",
  "cluster_uuid" : "[someid]",
  "version" : {
    "number" : "7.8.1",
    "build_flavor" : "default",
    "build_type" : "zip",
    "build_hash" : "[somehash]",
    "build_date" : "2020-07-21T16:40:44.668009Z",
    "build_snapshot" : false,
    "lucene_version" : "8.5.1",
    "minimum_wire_compatibility_version" : "6.8.0",
    "minimum_index_compatibility_version" : "6.0.0-beta1"
  },
  "tagline" : "You Know, for Search"
}

```

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [February 12, 2021, 8:28pm UTC](https://discuss.elastic.co/t/unable-to-connect-to-elasticsearch-error-request-timeout/261276/4 "2021-02-12T20:28:31Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
