# Unable to connect to Elasticsearch from Kibana

**URL:** <https://discuss.elastic.co/t/unable-to-connect-to-elasticsearch-from-kibana/174587>\
**Category:** Kibana\
**Created:** [March 29, 2019, 5:41pm UTC](https://discuss.elastic.co/t/unable-to-connect-to-elasticsearch-from-kibana/174587 "2019-03-29T17:41:55Z")\
**Posts on this page:** 8\
**Page:** 1

<div class="post-metadata">

**Author:** ![surya2](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/surya2/32/43120_2.png) [@surya2](https://discuss.elastic.co/u/surya2)\
**Post date:** [March 29, 2019, 5:41pm UTC](https://discuss.elastic.co/t/unable-to-connect-to-elasticsearch-from-kibana/174587/1 "2019-03-29T17:41:55Z")

</div>

Hello,

I am getting below error in kibana 6.5.4

"message":"Rejecting mapping update to [.kibana\_1] as the final mapping would have more than 1 type: [doc, type]: [illegal\_argument\_exception] Rejecting mapping update to [.kibana\_1] as the final mapping would have more than 1 type: [doc, type]"}

Both Kibana and ES are in same version.  
Help please.

Thanks,  
Surya

---

<div class="post-metadata">

**Author:** ![tsullivan](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/tsullivan/32/31077_2.png) [@tsullivan](https://discuss.elastic.co/u/tsullivan)\
**Post date:** [March 29, 2019, 9:52pm UTC](https://discuss.elastic.co/t/unable-to-connect-to-elasticsearch-from-kibana/174587/2 "2019-03-29T21:52:55Z")

</div>

Hi, which version did you upgrade from? Did you refer to the upgrade guide beforehand? [https://www.elastic.co/guide/en/elastic-stack/6.5/upgrading-elastic-stack.html](https://www.elastic.co/guide/en/elastic-stack/6.5/upgrading-elastic-stack.html)

This is a case of internal indices not having gone through migration, so double-check the steps about using the Reindex helper and the migration/upgrade API.

---

<div class="post-metadata">

**Author:** ![tsullivan](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/tsullivan/32/31077_2.png) [@tsullivan](https://discuss.elastic.co/u/tsullivan)\
**Post date:** [March 29, 2019, 9:54pm UTC](https://discuss.elastic.co/t/unable-to-connect-to-elasticsearch-from-kibana/174587/3 "2019-03-29T21:54:09Z")

</div>

Follow up question in case there wasn't an upgrade or the upgrade went ok:

Does Elasticsearch have an index template that adds `type` or `doc` as a type to every index?

---

<div class="post-metadata">

**Author:** ![surya2](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/surya2/32/43120_2.png) [@surya2](https://discuss.elastic.co/u/surya2)\
**Post date:** [March 29, 2019, 10:34pm UTC](https://discuss.elastic.co/t/unable-to-connect-to-elasticsearch-from-kibana/174587/4 "2019-03-29T22:34:12Z")

</div>

We did not upgrade. its a strainght ES and kibana 6.5.4 installation

name index\_patterns order version  
.management-beats [.management-beats] 0 65000  
.ml-anomalies- [.ml-anomalies-_] 0 6050499  
.ml-meta [.ml-meta] 0 6050499  
.ml-notifications [.ml-notifications] 0 6050499  
.ml-state [.ml-state] 0 6050499  
.monitoring-alerts [.monitoring-alerts-6] 0 6050399  
.monitoring-beats [.monitoring-beats-6-_] 0 6050399  
.monitoring-es [.monitoring-es-6-_] 0 6050399  
.monitoring-logstash [.monitoring-logstash-6-_] 0 6050399  
.triggered\_watches [.triggered\_watches\*] 2147483647  
.watch-history-9 [.watcher-history-9\*] 2147483647  
.watches [.watches\*] 2147483647  
default\_template [_] 0  
logstash-index-template [.logstash] 0  
security-index-template [.security-_] 1000  
security\_audit\_log [.security\_audit\_log\*] 1000

These are the index templates we have. All these are 6.x template’s i believe none of them should have type since they are deprecated from 6.x

---

<div class="post-metadata">

**Author:** ![surya2](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/surya2/32/43120_2.png) [@surya2](https://discuss.elastic.co/u/surya2)\
**Post date:** [April 1, 2019, 2:45pm UTC](https://discuss.elastic.co/t/unable-to-connect-to-elasticsearch-from-kibana/174587/5 "2019-04-01T14:45:38Z")

</div>

All the indices are created on 6.5.4 and no templates are used @tsullivan

---

<div class="post-metadata">

**Author:** ![tsullivan](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/tsullivan/32/31077_2.png) [@tsullivan](https://discuss.elastic.co/u/tsullivan)\
**Post date:** [April 1, 2019, 6:00pm UTC](https://discuss.elastic.co/t/unable-to-connect-to-elasticsearch-from-kibana/174587/6 "2019-04-01T18:00:11Z")

</div>

Hm, try using the migration assistant here. Your data came from somewhere else, maybe an import from another version. When you import saved objects, you can not just save the JSON directly to Elasticsearch. See [Rejecting mapping update to [.kibana] as the final mapping would have more than 1 type: [visualization, doc]" error](https://discuss.elastic.co/t/rejecting-mapping-update-to-kibana-as-the-final-mapping-would-have-more-than-1-type-visualization-doc-error/133557/8?u=tsullivan)

---

<div class="post-metadata">

**Author:** ![surya2](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/surya2/32/43120_2.png) [@surya2](https://discuss.elastic.co/u/surya2)\
**Post date:** [April 1, 2019, 6:42pm UTC](https://discuss.elastic.co/t/unable-to-connect-to-elasticsearch-from-kibana/174587/7 "2019-04-01T18:42:16Z")

</div>

i figured out

kibana is using default index template to create mapping  
i deleted that index template and restarted Kibana and it worked fine

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [April 29, 2019, 6:42pm UTC](https://discuss.elastic.co/t/unable-to-connect-to-elasticsearch-from-kibana/174587/8 "2019-04-29T18:42:17Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
