# Unable to connect to elasticsearch from other machine

**URL:** <https://discuss.elastic.co/t/unable-to-connect-to-elasticsearch-from-other-machine/101594>\
**Category:** Elasticsearch\
**Created:** [September 24, 2017, 7:36am UTC](https://discuss.elastic.co/t/unable-to-connect-to-elasticsearch-from-other-machine/101594 "2017-09-24T07:36:14Z")\
**Posts on this page:** 3\
**Page:** 1

<div class="post-metadata">

**Author:** ![yevsh](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/yevsh/32/20938_2.png) [@yevsh](https://discuss.elastic.co/u/yevsh)\
**Post date:** [September 24, 2017, 7:36am UTC](https://discuss.elastic.co/t/unable-to-connect-to-elasticsearch-from-other-machine/101594/1 "2017-09-24T07:36:14Z")

</div>

I copied elasticsearch to a unix machine, and started it  
../elasticsearch-5.6.1/bin\>./elasticsearch

tested the connection:

> curl 'localhost:9200/\_cat/health?v'

and got

elasticsearch green

when I tired to connect remotely from windows machine , with ip of the machine I am getting error  
This site can’t be reached

Also tried to modify elasticsearch.yml

and set

network.host: ip\_of\_the machine

Then, when I tried to start the elasticsearch got this error:

ERROR: [3] bootstrap checks failed  
[1]: max file descriptors [16384] for elasticsearch process is too low, increase to at least [65536]  
[2]: max virtual memory areas vm.max\_map\_count [65530] is too low, increase to at least [262144]  
[3]: system call filters failed to install; check the logs and fix your configuration or disable system call filters at your own risk

---

<div class="post-metadata">

**Author:** ![Christian\_Dahlqvist](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/christian_dahlqvist/32/4617_2.png) [@Christian\_Dahlqvist](https://discuss.elastic.co/u/Christian_Dahlqvist)\
**Post date:** [September 24, 2017, 10:33am UTC](https://discuss.elastic.co/t/unable-to-connect-to-elasticsearch-from-other-machine/101594/2 "2017-09-24T10:33:57Z")

</div>

Your installation is failing [the bootstrap checks](https://www.elastic.co/blog/bootstrap_checks_annoying_instead_of_devastating), so you will need to fix that before you will be able to access it remotely. There is more information available in the [documentation](https://www.elastic.co/guide/en/elasticsearch/reference/5.6/bootstrap-checks.html).

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [October 22, 2017, 10:34am UTC](https://discuss.elastic.co/t/unable-to-connect-to-elasticsearch-from-other-machine/101594/3 "2017-10-22T10:34:03Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
