# Unable to connect to elasticsearch: resource 'filebeat-7.14.0' exists, but it is not an alias

**URL:** https://discuss.elastic.co/t/unable-to-connect-to-elasticsearch-resource-filebeat-7-14-0-exists-but-it-is-not-an-alias/365802
**Category:** Beats
**Tags:** elastic-stack-monitoring, filebeat
**Created:** [August 30, 2024, 7:29am UTC](https://discuss.elastic.co/t/unable-to-connect-to-elasticsearch-resource-filebeat-7-14-0-exists-but-it-is-not-an-alias/365802 "2024-08-30T07:29:20Z")
**Posts on this page:** 1
**Page:** 1

<div class="post-metadata">

### Author: ![shiva9](https://avatars.discourse-cdn.com/v4/letter/s/a5b964/32.png) [@shiva9](https://discuss.elastic.co/u/shiva9)
#### Post date: [August 30, 2024, 7:29am UTC](https://discuss.elastic.co/t/unable-to-connect-to-elasticsearch-resource-filebeat-7-14-0-exists-but-it-is-not-an-alias/365802/1 "2024-08-30T07:29:20Z")

</div>

I am getting an error like this Unable to connect to elasticsearch: resource 'filebeat-7.14.0' exists, but it is not an alias. I had given the elasticsearch credentials correctly in the configuration file. I can't see the logs for the filebeat\* indexpattern in kibana. Any help on how to do this without losing the existing data.
