# Unable to create a fleet server with SSL certificates configured

**URL:** <https://discuss.elastic.co/t/unable-to-create-a-fleet-server-with-ssl-certificates-configured/364610>\
**Category:** Elastic Agent\
**Created:** [August 8, 2024, 1:58pm UTC](https://discuss.elastic.co/t/unable-to-create-a-fleet-server-with-ssl-certificates-configured/364610 "2024-08-08T13:58:01Z")\
**Posts on this page:** 5\
**Page:** 1

<div class="post-metadata">

**Author:** ![martianzz](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/martianzz/32/136041_2.png) [@martianzz](https://discuss.elastic.co/u/martianzz)\
**Post date:** [August 8, 2024, 1:58pm UTC](https://discuss.elastic.co/t/unable-to-create-a-fleet-server-with-ssl-certificates-configured/364610/1 "2024-08-08T13:58:01Z")

</div>

Unable to create a fleet server with SSL certificates configured.  
the below error is coming. Please tell why ?

```auto

```

./elastic-agent install --url=[https://10.0.30.129:8220](https://10.0.30.129:8220)  
Elastic Agent will be installed at /opt/Elastic/Agent and will run as a service. Do you want to continue? [Y/n]:y  
Do you want to enroll this Agent into Fleet? [Y/n]:y  
Fleet enrollment token: AAEAAWVsYXN0aWMvZmxlZXQtc2VydmVyL3Rva2VuLTE3MjMxMjQyNDE2Njk6M1RDVEZmblRSN3loWVpzV212ZDRsdw  
[====] Service Started [6s] Elastic Agent successfully installed, starting enrollment.  
[===] Waiting For Enroll... [7s] {"log.level":"info","@timestamp":"2024-08-08T19:08:24.302+0530","log.origin":{"file.name":"cmd/enroll\_cmd.go","file.line":517},"message":"Starting enrollment to URL: [https://10.0.30.129:8220/","ecs.version":"1.6.0](https://10.0.30.129:8220/%22,%22ecs.version%22:%221.6.0)"}  
[==] Waiting For Enroll... [7s] {"log.level":"info","@timestamp":"2024-08-08T19:08:24.593+0530","log.origin":{"file.name":"cmd/enroll\_cmd.go","file.line":523},"message":"1st enrollment attempt failed, retrying enrolling to URL: [https://10.0.30.129:8220/](https://10.0.30.129:8220/) with exponential backoff (init 1s, max 10s)","ecs.version":"1.6.0"}  
Error: fail to enroll: fail to execute request to fleet-server: dial tcp 10.0.30.129:8220: connect: connection refused  
For help, please see our troubleshooting guide at [Troubleshoot common problems | Fleet and Elastic Agent Guide [8.14] | Elastic](https://www.elastic.co/guide/en/fleet/8.14/fleet-troubleshooting.html)  
[==] Uninstalled [9s] Error uninstalling. Printing logs  
2024-08-08T13:38:24.947Z DEBUG [install] Loaded configuration from /home/fmsadmin/elastic-agent-8.14.3-linux-x86\_64/elastic-agent.yml  
2024-08-08T13:38:24.947Z DEBUG [install] Merged configuration from /home/fmsadmin/elastic-agent-8.14.3-linux-x86\_64/elastic-agent.yml into result  
2024-08-08T13:38:24.947Z DEBUG [install] Merged all configuration files from [/home/fmsadmin/elastic-agent-8.14.3-linux-x86\_64/elastic-agent.yml], no external input files  
2024-08-08T13:38:24.948Z DEBUG [install.composable] Starting controller for composable inputs  
2024-08-08T13:38:24.948Z DEBUG [install.composable] Started controller for composable inputs  
2024-08-08T13:38:24.948Z DEBUG [install.composable] Variable state changed for composable inputs; debounce started  
2024-08-08T13:38:24.949Z DEBUG [install.composable] Kubernetes leaderelection provider skipped, unable to connect: unable to build kfig duefig due to error: invalid configuration: no configuration has been provided, try setting KUBERNETES\_MASTER environment variable  
2024-08-08T13:38:24.949Z INFO [install.composable.providers.docker] Docker provider skipped, unable to connect: Cannot connect to the Docker daemon at unix:///var/run/docker.sock. Is the docker daemon running?  
2024-08-08T13:38:24.949Z DEBUG [install.composable.providers.kubernetes] Kubernetes provider for resource pod skipped, unable to connect: unable to build kube config due to error: invalid configuration: no configuration has been provided, try setting KUBERNETES\_MASTER environment variable  
2024-08-08T13:38:24.949Z DEBUG [install.composable.providers.kubernetes] Kubernetes provider for resource node skipped, unable to connect: unable to build kube config due to error: invalid configuration: no configuration has been provided, try setting KUBERNETES\_MASTER environment variable  
2024-08-08T13:38:25.077Z DEBUG [install.composable] Computing new variable state for composable inputs  
2024-08-08T13:38:25.077Z DEBUG [install.composable] Stopping controller for composable inputs  
2024-08-08T13:38:25.327Z DEBUG [install.composable] Stopped controller for composable inputs  
Error: enroll command failed for unknown reason: exit status 1

---

<div class="post-metadata">

**Author:** ![TimV](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/timv/32/13162_2.png) [@TimV](https://discuss.elastic.co/u/TimV)\
**Post date:** [August 9, 2024, 12:20am UTC](https://discuss.elastic.co/t/unable-to-create-a-fleet-server-with-ssl-certificates-configured/364610/2 "2024-08-09T00:20:53Z")

</div>

From #Elasticsearch to #Elastic Agent

---

<div class="post-metadata">

**Author:** ![TimV](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/timv/32/13162_2.png) [@TimV](https://discuss.elastic.co/u/TimV)\
**Post date:** [August 9, 2024, 12:20am UTC](https://discuss.elastic.co/t/unable-to-create-a-fleet-server-with-ssl-certificates-configured/364610/3 "2024-08-09T00:20:53Z")

</div>

Removed #docker

---

<div class="post-metadata">

**Author:** ![TimV](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/timv/32/13162_2.png) [@TimV](https://discuss.elastic.co/u/TimV)\
**Post date:** [August 9, 2024, 12:22am UTC](https://discuss.elastic.co/t/unable-to-create-a-fleet-server-with-ssl-certificates-configured/364610/4 "2024-08-09T00:22:15Z")

</div>

_I've move this to the agent forum, it's not an Elasticsearch issue_

> [@martianzz](#):
>
> ./elastic-agent install --url=[https://10.0.30.129:8220](https://10.0.30.129:8220)

> [@](#):
>
> Error: fail to enroll: fail to execute request to fleet-server: dial tcp 10.0.30.129:8220: connect: connection refused

It appears that the URL you are trying to use is incorrect - there does not seem to be anything listening on that address.

---

<div class="post-metadata">

**Author:** ![martianzz](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/martianzz/32/136041_2.png) [@martianzz](https://discuss.elastic.co/u/martianzz)\
**Post date:** [August 9, 2024, 4:57am UTC](https://discuss.elastic.co/t/unable-to-create-a-fleet-server-with-ssl-certificates-configured/364610/5 "2024-08-09T04:57:33Z")

</div>

I have followed the exact steps mentioned in the elastic portal for creating a three node elk cluster and implementing ssl between the nodes and kibana. No where in the portal it is mentioned of creating a port that needs to listen. Kindly help with a documentation that telling to make the port listen for fleet server.
