# Unable to create alert rule under synthetics and uptime

**URL:** https://discuss.elastic.co/t/unable-to-create-alert-rule-under-synthetics-and-uptime/374424
**Category:** Synthetics
**Created:** [February 12, 2025, 12:24pm UTC](https://discuss.elastic.co/t/unable-to-create-alert-rule-under-synthetics-and-uptime/374424 "2025-02-12T12:24:39Z")
**Posts on this page:** 3
**Page:** 1

<div class="post-metadata">

### Author: ![AVarkey\_athene](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/avarkey_athene/32/141322_2.png) [@AVarkey\_athene](https://discuss.elastic.co/u/AVarkey_athene)
#### Post date: [February 12, 2025, 12:24pm UTC](https://discuss.elastic.co/t/unable-to-create-alert-rule-under-synthetics-and-uptime/374424/1 "2025-02-12T12:24:39Z")

</div>

![error while creating test rule](https://us1.discourse-cdn.com/elastic/original/3X/8/3/83c0a0fc9d6731ef9bec5e0d6d97f9b988a70e02.jpeg)  
unable to create new alert rule in under synthetics and uptime showing following error.

"security\_exception Caused by: illegal\_argument\_exception: expected ')' at position 24 Root causes: security\_exception: The set of patterns [/~((([.]|ilm-history-).\*)/] is invalid, caused by: "expected ')' at position 24""

this error is showing even without any action to perform for the alert rule

---

<div class="post-metadata">

### Author: ![AVarkey\_athene](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/avarkey_athene/32/141322_2.png) [@AVarkey\_athene](https://discuss.elastic.co/u/AVarkey_athene)
#### Post date: [February 12, 2025, 1:24pm UTC](https://discuss.elastic.co/t/unable-to-create-alert-rule-under-synthetics-and-uptime/374424/2 "2025-02-12T13:24:08Z")

</div>

This was due to some permission issue, when we saved with super user the issue got resolved

---

<div class="post-metadata">

### Author: ![AVarkey\_athene](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/avarkey_athene/32/141322_2.png) [@AVarkey\_athene](https://discuss.elastic.co/u/AVarkey_athene)
#### Post date: [February 24, 2025, 1:41pm UTC](https://discuss.elastic.co/t/unable-to-create-alert-rule-under-synthetics-and-uptime/374424/3 "2025-02-24T13:41:24Z")

</div>

i am getting same error even when i create a new rule. only i have the issue. rest of the users are able to create the rules.
