# Unable to create new indices

**URL:** https://discuss.elastic.co/t/unable-to-create-new-indices/142471
**Category:** Elasticsearch
**Created:** [August 1, 2018, 6:15am UTC](https://discuss.elastic.co/t/unable-to-create-new-indices/142471 "2018-08-01T06:15:23Z")
**Posts on this page:** 10
**Page:** 1

<div class="post-metadata">

### Author: ![ganessen23](https://avatars.discourse-cdn.com/v4/letter/g/b5a626/32.png) [@ganessen23](https://discuss.elastic.co/u/ganessen23)
#### Post date: [August 1, 2018, 6:15am UTC](https://discuss.elastic.co/t/unable-to-create-new-indices/142471/1 "2018-08-01T06:15:24Z")

</div>

Hello,

My present scenario is that I am using ELK on a linux machine and it turns out that my trial license has been expired since April 27, 2018 7:19 PM MUT, but I am still able to send logs files/data to my previously created index.

 ![License%20expired](https://us1.discourse-cdn.com/elastic/original/3X/c/5/c5ab42f5da917a8e3e3f736683b97900976f13c7.PNG)

But I realized that now I am unable to send logs file to a new index to be created. My question would be: Is it due to the fact that my trial license has been expired, which is preventing me to create new indices?

Note: No error found in Logstash logs.

Error/warning in Elasticsearch log:

 ![error%20warning%20in%20ES](https://us1.discourse-cdn.com/elastic/original/3X/f/b/fb8148cb2332bb2e6e98842d315ade1d94fcca51.PNG)

Kind regards,  
Ganessen.

---

<div class="post-metadata">

### Author: ![TimV](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/timv/32/13162_2.png) [@TimV](https://discuss.elastic.co/u/TimV)
#### Post date: [August 1, 2018, 6:21am UTC](https://discuss.elastic.co/t/unable-to-create-new-indices/142471/2 "2018-08-01T06:21:55Z")

</div>

Please do not post screenshots of log files. They cannot be searched and are difficult to read on mobile devices.

Just copy-and-paste the text content, and format as a code block (use the `</>` button, or surround the text with "```" markers).

---

<div class="post-metadata">

### Author: ![TimV](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/timv/32/13162_2.png) [@TimV](https://discuss.elastic.co/u/TimV)
#### Post date: [August 1, 2018, 6:24am UTC](https://discuss.elastic.co/t/unable-to-create-new-indices/142471/3 "2018-08-01T06:24:15Z")

</div>

> [@ganessen23](#):
>
> Is it due to the fact that my trial license has been expired, which is preventing me to create new indices?

An expired license does not prevent you from creating new indicies, but it will block some cluster APIs that Logstash may be depending upon.

---

<div class="post-metadata">

### Author: ![ganessen23](https://avatars.discourse-cdn.com/v4/letter/g/b5a626/32.png) [@ganessen23](https://discuss.elastic.co/u/ganessen23)
#### Post date: [August 1, 2018, 6:24am UTC](https://discuss.elastic.co/t/unable-to-create-new-indices/142471/4 "2018-08-01T06:24:19Z")

</div>

Hello Tim,

Sorry for this mistake:

Here you go:

```
        at org.elasticsearch.xpack.monitoring.MonitoringService$MonitoringExecution$1.doRun(MonitoringService.java:221) [x-pack-monitoring-6.2.4.jar:6.2.4]
        at org.elasticsearch.common.util.concurrent.AbstractRunnable.run(AbstractRunnable.java:37) [elasticsearch-6.2.4.jar:6.2.4]
        at java.util.concurrent.Executors$RunnableAdapter.call(Executors.java:511) [?:1.8.0_181]
        at java.util.concurrent.FutureTask.run(FutureTask.java:266) [?:1.8.0_181]
        at org.elasticsearch.common.util.concurrent.ThreadContext$ContextPreservingRunnable.run(ThreadContext.java:573) [elasticsearch-6.2.4.jar:6.2.4]
        at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1149) [?:1.8.0_181]
        at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:624) [?:1.8.0_181]
        at java.lang.Thread.run(Thread.java:748) [?:1.8.0_181]
[2018-08-01T04:08:51,593][ERROR][o.e.x.s.a.f.SecurityActionFilter] [Tod-q-F] blocking [cluster:monitor/stats] operation due to expired license. Cluster health, cluster stats and indices stats
operations are blocked on license expiration. All data operations (read and write) continue to work.
If you have a new license, please update it. Otherwise, please reach out to your support contact.
[2018-08-01T04:08:51,593][ERROR][o.e.x.m.c.c.ClusterStatsCollector] [Tod-q-F] collector [cluster_stats] failed to collect data
org.elasticsearch.ElasticsearchSecurityException: current license is non-compliant for [security]
        at org.elasticsearch.license.LicenseUtils.newComplianceException(LicenseUtils.java:35) ~[?:?]
        at org.elasticsearch.xpack.security.action.filter.SecurityActionFilter.apply(SecurityActionFilter.java:96) ~[?:?]
        at org.elasticsearch.action.support.TransportAction$RequestFilterChain.proceed(TransportAction.java:165) ~[elasticsearch-6.2.4.jar:6.2.4]
        at org.elasticsearch.action.support.TransportAction.execute(TransportAction.java:139) ~[elasticsearch-6.2.4.jar:6.2.4]
        at org.elasticsearch.action.support.TransportAction.execute(TransportAction.java:81) ~[elasticsearch-6.2.4.jar:6.2.4]
        at org.elasticsearch.client.node.NodeClient.executeLocally(NodeClient.java:83) ~[elasticsearch-6.2.4.jar:6.2.4]
        at org.elasticsearch.client.node.NodeClient.doExecute(NodeClient.java:72) ~[elasticsearch-6.2.4.jar:6.2.4]
        at org.elasticsearch.client.support.AbstractClient.execute(AbstractClient.java:405) ~[elasticsearch-6.2.4.jar:6.2.4]
        at org.elasticsearch.client.support.AbstractClient.execute(AbstractClient.java:394) ~[elasticsearch-6.2.4.jar:6.2.4]
        at org.elasticsearch.client.support.AbstractClient$ClusterAdmin.execute(AbstractClient.java:706) ~[elasticsearch-6.2.4.jar:6.2.4]
        at org.elasticsearch.action.ActionRequestBuilder.execute(ActionRequestBuilder.java:46) ~[elasticsearch-6.2.4.jar:6.2.4]
        at org.elasticsearch.action.ActionRequestBuilder.get(ActionRequestBuilder.java:60) ~[elasticsearch-6.2.4.jar:6.2.4]
        at org.elasticsearch.xpack.monitoring.collector.cluster.ClusterStatsCollector.lambda$doCollect$0(ClusterStatsCollector.java:106) ~[x-pack-monitoring-6.2.4.jar:6.2.4]
        at org.elasticsearch.xpack.monitoring.collector.cluster.ClusterStatsCollector.doCollect(ClusterStatsCollector.java:110) ~[x-pack-monitoring-6.2.4.jar:6.2.4]
        at org.elasticsearch.xpack.monitoring.collector.Collector.collect(Collector.java:99) [x-pack-monitoring-6.2.4.jar:6.2.4]
        at org.elasticsearch.xpack.monitoring.MonitoringService$MonitoringExecution$1.doRun(MonitoringService.java:221) [x-pack-monitoring-6.2.4.jar:6.2.4]
        at org.elasticsearch.common.util.concurrent.AbstractRunnable.run(AbstractRunnable.java:37) [elasticsearch-6.2.4.jar:6.2.4]
        at java.util.concurrent.Executors$RunnableAdapter.call(Executors.java:511) [?:1.8.0_181]
        at java.util.concurrent.FutureTask.run(FutureTask.java:266) [?:1.8.0_181]
        at org.elasticsearch.common.util.concurrent.ThreadContext$ContextPreservingRunnable.run(ThreadContext.java:573) [elasticsearch-6.2.4.jar:6.2.4]
        at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1149) [?:1.8.0_181]
        at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:624) [?:1.8.0_181]
        at java.lang.Thread.run(Thread.java:748) [?:1.8.0_181]
[2018-08-01T04:09:01,593][ERROR][o.e.x.s.a.f.SecurityActionFilter] [Tod-q-F] blocking [cluster:monitor/stats] operation due to expired license. Cluster health, cluster stats and indices stats
operations are blocked on license expiration. All data operations (read and write) continue to work.
If you have a new license, please update it. Otherwise, please reach out to your support contact.
[2018-08-01T04:09:01,593][ERROR][o.e.x.m.c.c.ClusterStatsCollector] [Tod-q-F] collector [cluster_stats] failed to collect data
org.elasticsearch.ElasticsearchSecurityException: current license is non-compliant for [security]
        at org.elasticsearch.license.LicenseUtils.newComplianceException(LicenseUtils.java:35) ~[?:?]
        at org.elasticsearch.xpack.security.action.filter.SecurityActionFilter.apply(SecurityActionFilter.java:96) ~[?:?]
        at org.elasticsearch.action.support.TransportAction$RequestFilterChain.proceed(TransportAction.java:165) ~[elasticsearch-6.2.4.jar:6.2.4]
        at org.elasticsearch.action.support.TransportAction.execute(TransportAction.java:139) ~[elasticsearch-6.2.4.jar:6.2.4]
        at org.elasticsearch.action.support.TransportAction.execute(TransportAction.java:81) ~[elasticsearch-6.2.4.jar:6.2.4]
        at org.elasticsearch.client.node.NodeClient.executeLocally(NodeClient.java:83) ~[elasticsearch-6.2.4.jar:6.2.4]
        at org.elasticsearch.client.node.NodeClient.doExecute(NodeClient.java:72) ~[elasticsearch-6.2.4.jar:6.2.4]
        at org.elasticsearch.client.support.AbstractClient.execute(AbstractClient.java:405) ~[elasticsearch-6.2.4.jar:6.2.4]
        at org.elasticsearch.client.support.AbstractClient.execute(AbstractClient.java:394) ~[elasticsearch-6.2.4.jar:6.2.4]
        at org.elasticsearch.client.support.AbstractClient$ClusterAdmin.execute(AbstractClient.java:706) ~[elasticsearch-6.2.4.jar:6.2.4]
        at org.elasticsearch.action.ActionRequestBuilder.execute(ActionRequestBuilder.java:46) ~[elasticsearch-6.2.4.jar:6.2.4]
```

---

<div class="post-metadata">

### Author: ![zqc0512](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/zqc0512/32/32141_2.png) [@zqc0512](https://discuss.elastic.co/u/zqc0512)
#### Post date: [August 1, 2018, 6:28am UTC](https://discuss.elastic.co/t/unable-to-create-new-indices/142471/5 "2018-08-01T06:28:52Z")

</div>

> [@ganessen23](#):
>
> expired license.

get a new license at

> **[Register | Elastic](https://register.elastic.co/xpack_register)**

---

<div class="post-metadata">

### Author: ![ganessen23](https://avatars.discourse-cdn.com/v4/letter/g/b5a626/32.png) [@ganessen23](https://discuss.elastic.co/u/ganessen23)
#### Post date: [August 1, 2018, 10:00am UTC](https://discuss.elastic.co/t/unable-to-create-new-indices/142471/6 "2018-08-01T10:00:05Z")

</div>

> An expired license does not prevent you from creating new indicies, but it will block some cluster APIs that Logstash may be depending upon.

Hello Tim,  
Is there a way to identify which cluster APIs are being blocked that Logstash depends on.  
If that is not the root of problem, how should i proceed to identify why the new index is not being created.  
(in my case, logs are not revealing anything).

Thanks in advance.  
Ganessen.

---

<div class="post-metadata">

### Author: ![ganessen23](https://avatars.discourse-cdn.com/v4/letter/g/b5a626/32.png) [@ganessen23](https://discuss.elastic.co/u/ganessen23)
#### Post date: [August 2, 2018, 5:56am UTC](https://discuss.elastic.co/t/unable-to-create-new-indices/142471/7 "2018-08-02T05:56:29Z")

</div>

Hello Andy,

> get a new license at  
> [Register | Elastic](https://register.elastic.co/xpack_register) 2

I did update my expired trial license to a basic one, but still I am unable to create a new index.  
Any thoughts about that?

Ganessen.

---

<div class="post-metadata">

### Author: ![TimV](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/timv/32/13162_2.png) [@TimV](https://discuss.elastic.co/u/TimV)
#### Post date: [August 2, 2018, 7:44am UTC](https://discuss.elastic.co/t/unable-to-create-new-indices/142471/8 "2018-08-02T07:44:16Z")

</div>

> [@ganessen23](#):
>
> still I am unable to create a new index.

I think you need to diagnose this a bit more.  
Is it that you are unable to create _any_ index? Or is it that logstash cannot create indices? Or ...

I would suggest you start with trying to use the [Create Index API](https://www.elastic.co/guide/en/elasticsearch/reference/6.3/indices-create-index.html) via `curl` and see what happens.

---

<div class="post-metadata">

### Author: ![zqc0512](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/zqc0512/32/32141_2.png) [@zqc0512](https://discuss.elastic.co/u/zqc0512)
#### Post date: [August 3, 2018, 12:31am UTC](https://discuss.elastic.co/t/unable-to-create-new-indices/142471/9 "2018-08-03T00:31:04Z")

</div>

show more log.

---

<div class="post-metadata">

### Author: ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)
#### Post date: [August 31, 2018, 12:31am UTC](https://discuss.elastic.co/t/unable-to-create-new-indices/142471/10 "2018-08-31T00:31:07Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
