# Unable to delete indexes - "failed to process cluster event (acquire index lock) within 30s"

**URL:** https://discuss.elastic.co/t/unable-to-delete-indexes-failed-to-process-cluster-event-acquire-index-lock-within-30s/16899
**Category:** Elasticsearch
**Created:** [April 9, 2014, 2:10pm UTC](https://discuss.elastic.co/t/unable-to-delete-indexes-failed-to-process-cluster-event-acquire-index-lock-within-30s/16899 "2014-04-09T14:10:25Z")
**Posts on this page:** 8
**Page:** 1

<div class="post-metadata">

### Author: ![Zachary\_Lammers](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/zachary_lammers/32/1651_2.png) [@Zachary\_Lammers](https://discuss.elastic.co/u/Zachary_Lammers)
#### Post date: [April 9, 2014, 2:10pm UTC](https://discuss.elastic.co/t/unable-to-delete-indexes-failed-to-process-cluster-event-acquire-index-lock-within-30s/16899/1 "2014-04-09T14:10:25Z")

</div>

I am unable to delete certain indexes in my cluster - using it for logging,  
new indexes per day:

curl -XDELETE [http://172.16.1.100:9200/2014\_03\_27](http://172.16.1.100:9200/2014_03_27)  
{"error":"ProcessClusterEventTimeoutException[failed to process cluster  
event (acquire index lock) within 30s]","status":503}

curl -XDELETE [http://172.16.1.100:9200/2014\_04\_01](http://172.16.1.100:9200/2014_04_01)  
{"ok":true,"acknowledged":true}

curl -XDELETE [http://172.16.1.100:9200/2014\_03\_28](http://172.16.1.100:9200/2014_03_28)  
{"error":"ProcessClusterEventTimeoutException[failed to process cluster  
event (acquire index lock) within 30s]","status":503}

curl -XDELETE [http://172.16.1.100:9200/2014\_04\_02](http://172.16.1.100:9200/2014_04_02)  
{"ok":true,"acknowledged":true}

curl -XDELETE [http://172.16.1.100:9200/2014\_04\_03](http://172.16.1.100:9200/2014_04_03)  
{"ok":true,"acknowledged":true}

However, I could deleted my 2014\_04\_01 and \_02/\_03 index just fine. Here  
are logs (showing two errors above and successful delete of 2014\_04\_01/2/3):

[2014-04-09 13:56:56,323][DEBUG][action.admin.indices.delete] [bAggregator00  
] [2014\_03\_27] failed to delete index  
org.elasticsearch.cluster.metadata.ProcessClusterEventTimeoutException:failed to process cluster  
event (acquire index lock) within 30s  
at org.elasticsearch.cluster.metadata.MetaDataDeleteIndexService$1.  
run(MetaDataDeleteIndexService.java:88)  
at java.util.concurrent.ThreadPoolExecutor.runWorker(  
ThreadPoolExecutor.java:1145)  
at java.util.concurrent.ThreadPoolExecutor$Worker.run(  
ThreadPoolExecutor.java:615)  
at java.lang.Thread.run(Thread.java:744)  
[2014-04-09 13:59:21,140][INFO][cluster.metadata] [bAggregator00]  
[2014\_04\_01] deleting index  
[2014-04-09 14:00:29,773][DEBUG][action.admin.indices.delete] [bAggregator00  
] [2014\_03\_28] failed to delete index  
org.elasticsearch.cluster.metadata.ProcessClusterEventTimeoutException:failed to process cluster  
event (acquire index lock) within 30s  
at org.elasticsearch.cluster.metadata.MetaDataDeleteIndexService$1.  
run(MetaDataDeleteIndexService.java:88)  
at java.util.concurrent.ThreadPoolExecutor.runWorker(  
ThreadPoolExecutor.java:1145)  
at java.util.concurrent.ThreadPoolExecutor$Worker.run(  
ThreadPoolExecutor.java:615)  
at java.lang.Thread.run(Thread.java:744)  
[2014-04-09 14:03:29,350][INFO][cluster.metadata] [bAggregator00]  
[2014\_04\_02] deleting index  
[2014-04-09 14:05:03,164][INFO][cluster.metadata] [bAggregator00]  
[2014\_04\_03] deleting index

Any ideas/help would be appreciated, thanks!

--  
You received this message because you are subscribed to the Google Groups "elasticsearch" group.  
To unsubscribe from this group and stop receiving emails from it, send an email to [elasticsearch+unsubscribe@googlegroups.com](mailto:elasticsearch+unsubscribe@googlegroups.com).  
To view this discussion on the web visit [https://groups.google.com/d/msgid/elasticsearch/fe3471ea-34e6-4cd1-b8d4-042607555eda%40googlegroups.com](https://groups.google.com/d/msgid/elasticsearch/fe3471ea-34e6-4cd1-b8d4-042607555eda%40googlegroups.com).  
For more options, visit [https://groups.google.com/d/optout](https://groups.google.com/d/optout).

---

<div class="post-metadata">

### Author: ![nicktgr15](https://avatars.discourse-cdn.com/v4/letter/n/65b543/32.png) [@nicktgr15](https://discuss.elastic.co/u/nicktgr15)
#### Post date: [April 16, 2014, 4:58pm UTC](https://discuss.elastic.co/t/unable-to-delete-indexes-failed-to-process-cluster-event-acquire-index-lock-within-30s/16899/2 "2014-04-16T16:58:39Z")

</div>

Similar error

[2014-04-16 16:57:08,464][DEBUG][action.admin.indices.create] [Jerry Jaxon]  
[myindex-2014.04.16] failed to create  
org.elasticsearch.cluster.metadata.ProcessClusterEventTimeoutException:  
failed to process cluster event (acquire index lock) within 30s  
at  
org.elasticsearch.cluster.metadata.MetaDataCreateIndexService$1.run(MetaDataCreateIndexService.java:141)  
at  
java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1145)  
at  
java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:615)  
at java.lang.Thread.run(Thread.java:744)

On Wednesday, April 9, 2014 3:10:25 PM UTC+1, Zachary Lammers wrote:

> I am unable to delete certain indexes in my cluster - using it for  
> logging, new indexes per day:
> 
> curl -XDELETE [http://172.16.1.100:9200/2014\_03\_27](http://172.16.1.100:9200/2014_03_27)  
> {"error":"ProcessClusterEventTimeoutException[failed to process cluster  
> event (acquire index lock) within 30s]","status":503}
> 
> curl -XDELETE [http://172.16.1.100:9200/2014\_04\_01](http://172.16.1.100:9200/2014_04_01)  
> {"ok":true,"acknowledged":true}
> 
> curl -XDELETE [http://172.16.1.100:9200/2014\_03\_28](http://172.16.1.100:9200/2014_03_28)  
> {"error":"ProcessClusterEventTimeoutException[failed to process cluster  
> event (acquire index lock) within 30s]","status":503}
> 
> curl -XDELETE [http://172.16.1.100:9200/2014\_04\_02](http://172.16.1.100:9200/2014_04_02)  
> {"ok":true,"acknowledged":true}
> 
> curl -XDELETE [http://172.16.1.100:9200/2014\_04\_03](http://172.16.1.100:9200/2014_04_03)  
> {"ok":true,"acknowledged":true}
> 
> However, I could deleted my 2014\_04\_01 and \_02/\_03 index just fine. Here  
> are logs (showing two errors above and successful delete of 2014\_04\_01/2/3):
> 
> [2014-04-09 13:56:56,323][DEBUG][action.admin.indices.delete] [  
> bAggregator00] [2014\_03\_27] failed to delete index  
> org.elasticsearch.cluster.metadata.ProcessClusterEventTimeoutException:failed to process cluster  
> event (acquire index lock) within 30s  
> at org.elasticsearch.cluster.metadata.MetaDataDeleteIndexService$1  
> .run(MetaDataDeleteIndexService.java:88)  
> at java.util.concurrent.ThreadPoolExecutor.runWorker(  
> ThreadPoolExecutor.java:1145)  
> at java.util.concurrent.ThreadPoolExecutor$Worker.run(  
> ThreadPoolExecutor.java:615)  
> at java.lang.Thread.run(Thread.java:744)  
> [2014-04-09 13:59:21,140][INFO][cluster.metadata] [bAggregator00  
> ] [2014\_04\_01] deleting index  
> [2014-04-09 14:00:29,773][DEBUG][action.admin.indices.delete] [  
> bAggregator00] [2014\_03\_28] failed to delete index  
> org.elasticsearch.cluster.metadata.ProcessClusterEventTimeoutException:failed to process cluster  
> event (acquire index lock) within 30s  
> at org.elasticsearch.cluster.metadata.MetaDataDeleteIndexService$1  
> .run(MetaDataDeleteIndexService.java:88)  
> at java.util.concurrent.ThreadPoolExecutor.runWorker(  
> ThreadPoolExecutor.java:1145)  
> at java.util.concurrent.ThreadPoolExecutor$Worker.run(  
> ThreadPoolExecutor.java:615)  
> at java.lang.Thread.run(Thread.java:744)  
> [2014-04-09 14:03:29,350][INFO][cluster.metadata] [bAggregator00  
> ] [2014\_04\_02] deleting index  
> [2014-04-09 14:05:03,164][INFO][cluster.metadata] [bAggregator00  
> ] [2014\_04\_03] deleting index
> 
> Any ideas/help would be appreciated, thanks!

--  
You received this message because you are subscribed to the Google Groups "elasticsearch" group.  
To unsubscribe from this group and stop receiving emails from it, send an email to [elasticsearch+unsubscribe@googlegroups.com](mailto:elasticsearch+unsubscribe@googlegroups.com).  
To view this discussion on the web visit [https://groups.google.com/d/msgid/elasticsearch/a21a8618-2ec5-40c3-a410-5a301c876ff0%40googlegroups.com](https://groups.google.com/d/msgid/elasticsearch/a21a8618-2ec5-40c3-a410-5a301c876ff0%40googlegroups.com).  
For more options, visit [https://groups.google.com/d/optout](https://groups.google.com/d/optout).

---

<div class="post-metadata">

### Author: ![Rafi\_Aroch](https://avatars.discourse-cdn.com/v4/letter/r/ce7236/32.png) [@Rafi\_Aroch](https://discuss.elastic.co/u/Rafi_Aroch)
#### Post date: [June 3, 2014, 8:10am UTC](https://discuss.elastic.co/t/unable-to-delete-indexes-failed-to-process-cluster-event-acquire-index-lock-within-30s/16899/3 "2014-06-03T08:10:14Z")

</div>

Hi,

I'm also seeing the same issue as described. Does anyone know what may be  
causing this?

Would appreciate your assistance.

Rafi

On Wednesday, April 16, 2014 7:58:39 PM UTC+3, nicktgr15 wrote:

> Similar error
> 
> [2014-04-16 16:57:08,464][DEBUG][action.admin.indices.create] [Jerry  
> Jaxon] [myindex-2014.04.16] failed to create  
> org.elasticsearch.cluster.metadata.ProcessClusterEventTimeoutException:  
> failed to process cluster event (acquire index lock) within 30s  
> at  
> org.elasticsearch.cluster.metadata.MetaDataCreateIndexService$1.run(MetaDataCreateIndexService.java:141)  
> at  
> java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1145)  
> at  
> java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:615)  
> at java.lang.Thread.run(Thread.java:744)
> 
> On Wednesday, April 9, 2014 3:10:25 PM UTC+1, Zachary Lammers wrote:
> 
> > I am unable to delete certain indexes in my cluster - using it for  
> > logging, new indexes per day:
> > 
> > curl -XDELETE [http://172.16.1.100:9200/2014\_03\_27](http://172.16.1.100:9200/2014_03_27)  
> > {"error":"ProcessClusterEventTimeoutException[failed to process cluster  
> > event (acquire index lock) within 30s]","status":503}
> > 
> > curl -XDELETE [http://172.16.1.100:9200/2014\_04\_01](http://172.16.1.100:9200/2014_04_01)  
> > {"ok":true,"acknowledged":true}
> > 
> > curl -XDELETE [http://172.16.1.100:9200/2014\_03\_28](http://172.16.1.100:9200/2014_03_28)  
> > {"error":"ProcessClusterEventTimeoutException[failed to process cluster  
> > event (acquire index lock) within 30s]","status":503}
> > 
> > curl -XDELETE [http://172.16.1.100:9200/2014\_04\_02](http://172.16.1.100:9200/2014_04_02)  
> > {"ok":true,"acknowledged":true}
> > 
> > curl -XDELETE [http://172.16.1.100:9200/2014\_04\_03](http://172.16.1.100:9200/2014_04_03)  
> > {"ok":true,"acknowledged":true}
> > 
> > However, I could deleted my 2014\_04\_01 and \_02/\_03 index just fine. Here  
> > are logs (showing two errors above and successful delete of 2014\_04\_01/2/3):
> > 
> > [2014-04-09 13:56:56,323][DEBUG][action.admin.indices.delete] [  
> > bAggregator00] [2014\_03\_27] failed to delete index  
> > org.elasticsearch.cluster.metadata.ProcessClusterEventTimeoutException:  
> > failed to process cluster event (acquire index lock) within 30s  
> > at org.elasticsearch.cluster.metadata.  
> > MetaDataDeleteIndexService$1.run(MetaDataDeleteIndexService.java:88)  
> > at java.util.concurrent.ThreadPoolExecutor.runWorker(  
> > ThreadPoolExecutor.java:1145)  
> > at java.util.concurrent.ThreadPoolExecutor$Worker.run(  
> > ThreadPoolExecutor.java:615)  
> > at java.lang.Thread.run(Thread.java:744)  
> > [2014-04-09 13:59:21,140][INFO][cluster.metadata] [  
> > bAggregator00] [2014\_04\_01] deleting index  
> > [2014-04-09 14:00:29,773][DEBUG][action.admin.indices.delete] [  
> > bAggregator00] [2014\_03\_28] failed to delete index  
> > org.elasticsearch.cluster.metadata.ProcessClusterEventTimeoutException:  
> > failed to process cluster event (acquire index lock) within 30s  
> > at org.elasticsearch.cluster.metadata.  
> > MetaDataDeleteIndexService$1.run(MetaDataDeleteIndexService.java:88)  
> > at java.util.concurrent.ThreadPoolExecutor.runWorker(  
> > ThreadPoolExecutor.java:1145)  
> > at java.util.concurrent.ThreadPoolExecutor$Worker.run(  
> > ThreadPoolExecutor.java:615)  
> > at java.lang.Thread.run(Thread.java:744)  
> > [2014-04-09 14:03:29,350][INFO][cluster.metadata] [  
> > bAggregator00] [2014\_04\_02] deleting index  
> > [2014-04-09 14:05:03,164][INFO][cluster.metadata] [  
> > bAggregator00] [2014\_04\_03] deleting index
> > 
> > Any ideas/help would be appreciated, thanks!

--  
You received this message because you are subscribed to the Google Groups "elasticsearch" group.  
To unsubscribe from this group and stop receiving emails from it, send an email to [elasticsearch+unsubscribe@googlegroups.com](mailto:elasticsearch+unsubscribe@googlegroups.com).  
To view this discussion on the web visit [https://groups.google.com/d/msgid/elasticsearch/944353d4-f9af-44f2-8ed2-20393e2c328f%40googlegroups.com](https://groups.google.com/d/msgid/elasticsearch/944353d4-f9af-44f2-8ed2-20393e2c328f%40googlegroups.com).  
For more options, visit [https://groups.google.com/d/optout](https://groups.google.com/d/optout).

---

<div class="post-metadata">

### Author: ![Nikhil\_Mulley](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/nikhil_mulley/32/1401_2.png) [@Nikhil\_Mulley](https://discuss.elastic.co/u/Nikhil_Mulley)
#### Post date: [July 14, 2014, 10:08pm UTC](https://discuss.elastic.co/t/unable-to-delete-indexes-failed-to-process-cluster-event-acquire-index-lock-within-30s/16899/4 "2014-07-14T22:08:54Z")

</div>

Hi,

I am facing similar exceptions with elasticsearch 0.90. Wondering if there  
was any follow up on this in the community.

thanks,  
Nikhil

On Wednesday, April 16, 2014 9:58:39 AM UTC-7, nicktgr15 wrote:

> Similar error
> 
> [2014-04-16 16:57:08,464][DEBUG][action.admin.indices.create] [Jerry  
> Jaxon] [myindex-2014.04.16] failed to create  
> org.elasticsearch.cluster.metadata.ProcessClusterEventTimeoutException:  
> failed to process cluster event (acquire index lock) within 30s  
> at  
> org.elasticsearch.cluster.metadata.MetaDataCreateIndexService$1.run(MetaDataCreateIndexService.java:141)  
> at  
> java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1145)  
> at  
> java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:615)  
> at java.lang.Thread.run(Thread.java:744)
> 
> On Wednesday, April 9, 2014 3:10:25 PM UTC+1, Zachary Lammers wrote:
> 
> > I am unable to delete certain indexes in my cluster - using it for  
> > logging, new indexes per day:
> > 
> > curl -XDELETE [http://172.16.1.100:9200/2014\_03\_27](http://172.16.1.100:9200/2014_03_27)  
> > {"error":"ProcessClusterEventTimeoutException[failed to process cluster  
> > event (acquire index lock) within 30s]","status":503}
> > 
> > curl -XDELETE [http://172.16.1.100:9200/2014\_04\_01](http://172.16.1.100:9200/2014_04_01)  
> > {"ok":true,"acknowledged":true}
> > 
> > curl -XDELETE [http://172.16.1.100:9200/2014\_03\_28](http://172.16.1.100:9200/2014_03_28)  
> > {"error":"ProcessClusterEventTimeoutException[failed to process cluster  
> > event (acquire index lock) within 30s]","status":503}
> > 
> > curl -XDELETE [http://172.16.1.100:9200/2014\_04\_02](http://172.16.1.100:9200/2014_04_02)  
> > {"ok":true,"acknowledged":true}
> > 
> > curl -XDELETE [http://172.16.1.100:9200/2014\_04\_03](http://172.16.1.100:9200/2014_04_03)  
> > {"ok":true,"acknowledged":true}
> > 
> > However, I could deleted my 2014\_04\_01 and \_02/\_03 index just fine. Here  
> > are logs (showing two errors above and successful delete of 2014\_04\_01/2/3):
> > 
> > [2014-04-09 13:56:56,323][DEBUG][action.admin.indices.delete] [  
> > bAggregator00] [2014\_03\_27] failed to delete index  
> > org.elasticsearch.cluster.metadata.ProcessClusterEventTimeoutException:  
> > failed to process cluster event (acquire index lock) within 30s  
> > at org.elasticsearch.cluster.metadata.  
> > MetaDataDeleteIndexService$1.run(MetaDataDeleteIndexService.java:88)  
> > at java.util.concurrent.ThreadPoolExecutor.runWorker(  
> > ThreadPoolExecutor.java:1145)  
> > at java.util.concurrent.ThreadPoolExecutor$Worker.run(  
> > ThreadPoolExecutor.java:615)  
> > at java.lang.Thread.run(Thread.java:744)  
> > [2014-04-09 13:59:21,140][INFO][cluster.metadata] [  
> > bAggregator00] [2014\_04\_01] deleting index  
> > [2014-04-09 14:00:29,773][DEBUG][action.admin.indices.delete] [  
> > bAggregator00] [2014\_03\_28] failed to delete index  
> > org.elasticsearch.cluster.metadata.ProcessClusterEventTimeoutException:  
> > failed to process cluster event (acquire index lock) within 30s  
> > at org.elasticsearch.cluster.metadata.  
> > MetaDataDeleteIndexService$1.run(MetaDataDeleteIndexService.java:88)  
> > at java.util.concurrent.ThreadPoolExecutor.runWorker(  
> > ThreadPoolExecutor.java:1145)  
> > at java.util.concurrent.ThreadPoolExecutor$Worker.run(  
> > ThreadPoolExecutor.java:615)  
> > at java.lang.Thread.run(Thread.java:744)  
> > [2014-04-09 14:03:29,350][INFO][cluster.metadata] [  
> > bAggregator00] [2014\_04\_02] deleting index  
> > [2014-04-09 14:05:03,164][INFO][cluster.metadata] [  
> > bAggregator00] [2014\_04\_03] deleting index
> > 
> > Any ideas/help would be appreciated, thanks!

--  
You received this message because you are subscribed to the Google Groups "elasticsearch" group.  
To unsubscribe from this group and stop receiving emails from it, send an email to [elasticsearch+unsubscribe@googlegroups.com](mailto:elasticsearch+unsubscribe@googlegroups.com).  
To view this discussion on the web visit [https://groups.google.com/d/msgid/elasticsearch/cb3e291f-8646-4c26-927d-26242b930d1d%40googlegroups.com](https://groups.google.com/d/msgid/elasticsearch/cb3e291f-8646-4c26-927d-26242b930d1d%40googlegroups.com).  
For more options, visit [https://groups.google.com/d/optout](https://groups.google.com/d/optout).

---

<div class="post-metadata">

### Author: ![dany](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/dany/32/8131_2.png) [@dany](https://discuss.elastic.co/u/dany)
#### Post date: [June 16, 2016, 4:23am UTC](https://discuss.elastic.co/t/unable-to-delete-indexes-failed-to-process-cluster-event-acquire-index-lock-within-30s/16899/5 "2016-06-16T04:23:53Z")

</div>

I am getting the same issue . Is there a way to force delete the index through API or from the disk?

Any suggestions would be really helpful.

---

<div class="post-metadata">

### Author: ![dany](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/dany/32/8131_2.png) [@dany](https://discuss.elastic.co/u/dany)
#### Post date: [June 29, 2016, 1:06am UTC](https://discuss.elastic.co/t/unable-to-delete-indexes-failed-to-process-cluster-event-acquire-index-lock-within-30s/16899/6 "2016-06-29T01:06:49Z")

</div>

We found the issue. Just restart the master node and force the cluster to choose different master.

In my case the issue was something went wrong while acquiring lock from master. So I changed the master. It worked 🙂

---

<div class="post-metadata">

### Author: ![bistuXu](https://avatars.discourse-cdn.com/v4/letter/b/e9bcb4/32.png) [@bistuXu](https://discuss.elastic.co/u/bistuXu)
#### Post date: [July 25, 2016, 10:35am UTC](https://discuss.elastic.co/t/unable-to-delete-indexes-failed-to-process-cluster-event-acquire-index-lock-within-30s/16899/7 "2016-07-25T10:35:27Z")

</div>

I met the issus too ,but how to solve the probem .when my machine met the problem ,the systemctl is disabled and timeout

---

<div class="post-metadata">

### Author: ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)
#### Post date: [July 5, 2017, 10:33pm UTC](https://discuss.elastic.co/t/unable-to-delete-indexes-failed-to-process-cluster-event-acquire-index-lock-within-30s/16899/8 "2017-07-05T22:33:11Z")

</div>


