# Unable to download kibana dashboard

**URL:** <https://discuss.elastic.co/t/unable-to-download-kibana-dashboard/93381>\
**Category:** Beats\
**Tags:** winlogbeat\
**Created:** [July 17, 2017, 10:59am UTC](https://discuss.elastic.co/t/unable-to-download-kibana-dashboard/93381 "2017-07-17T10:59:58Z")\
**Posts on this page:** 11\
**Page:** 1

<div class="post-metadata">

**Author:** ![SFace](https://avatars.discourse-cdn.com/v4/letter/s/ea5d25/32.png) [@SFace](https://discuss.elastic.co/u/SFace)\
**Post date:** [July 17, 2017, 10:59am UTC](https://discuss.elastic.co/t/unable-to-download-kibana-dashboard/93381/1 "2017-07-17T10:59:58Z")

</div>

Hi  
im having issues in setting up winlogbeats, i cant seem to get past the point ( currently following official logstash tutorial) of installing the kibana dash board

whenever i run this command:

scripts\import\_dashboards.exe

i get the following error:

PS C:\Program files\winlogbeat\> scripts\import\_dashboards.exe  
Failed to set the mapping: Put [http://127.0.0.1:9200/.kibana/\_mapping/search:](http://127.0.0.1:9200/.kibana/_mapping/search:) dial tcp 127.0.0.1:9200: connectex: No con  
nection could be made because the target machine actively refused it.  
Created temporary directory C:\Users\RS1\AppData\Local\Temp\tmp760503195  
Downloading [https://artifacts.elastic.co/downloads/beats/beats-dashboards/beats-dashboards-5.4.3.zip](https://artifacts.elastic.co/downloads/beats/beats-dashboards/beats-dashboards-5.4.3.zip)  
Unzip archive C:\Users\RS1\AppData\Local\Temp\tmp760503195  
Importing Kibana from C:\Users\RS1\AppData\Local\Temp\tmp760503195\beats-dashboards-5.4.3\filebeat  
Importing Kibana from C:\Users\RS1\AppData\Local\Temp\tmp760503195\beats-dashboards-5.4.3\heartbeat  
Importing Kibana from C:\Users\RS1\AppData\Local\Temp\tmp760503195\beats-dashboards-5.4.3\metricbeat  
Importing Kibana from C:\Users\RS1\AppData\Local\Temp\tmp760503195\beats-dashboards-5.4.3\packetbeat  
Importing Kibana from C:\Users\RS1\AppData\Local\Temp\tmp760503195\beats-dashboards-5.4.3\winlogbeat  
Import directory C:\Users\RS1\AppData\Local\Temp\tmp760503195\beats-dashboards-5.4.3\winlogbeat/index-pattern  
Import index to /.kibana/index-pattern/winlogbeat-\* from C:\Users\RS1\AppData\Local\Temp\tmp760503195\beats-dashboards-5  
.4.3\winlogbeat\index-pattern\winlogbeat.json

Error importing URL/file: Failed to import index-pattern: Failed to load directory C:\Users\RS1\AppData\Local\Temp\tmp76  
0503195\beats-dashboards-5.4.3\winlogbeat/index-pattern:  
error loading C:\Users\RS1\AppData\Local\Temp\tmp760503195\beats-dashboards-5.4.3\winlogbeat\index-pattern\winlogbeat.  
json: couldn't load json. Error: Put [http://127.0.0.1:9200/.kibana/index-pattern/winlogbeat-\*:](http://127.0.0.1:9200/.kibana/index-pattern/winlogbeat-*:) dial tcp 127.0.0.1:9200:  
connectex: No connection could be made because the target machine actively refused it.  
Exiting

---

<div class="post-metadata">

**Author:** ![magnusbaeck](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/magnusbaeck/32/44943_2.png) [@magnusbaeck](https://discuss.elastic.co/u/magnusbaeck)\
**Post date:** [July 18, 2017, 2:21pm UTC](https://discuss.elastic.co/t/unable-to-download-kibana-dashboard/93381/2 "2017-07-18T14:21:02Z")

</div>

As this is more of a Winlogbeat question I suspect you'll get better help in the Beats group.

---

<div class="post-metadata">

**Author:** ![SFace](https://avatars.discourse-cdn.com/v4/letter/s/ea5d25/32.png) [@SFace](https://discuss.elastic.co/u/SFace)\
**Post date:** [July 18, 2017, 3:28pm UTC](https://discuss.elastic.co/t/unable-to-download-kibana-dashboard/93381/3 "2017-07-18T15:28:42Z")

</div>

how do i put this forward in the beats group ?

---

<div class="post-metadata">

**Author:** ![magnusbaeck](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/magnusbaeck/32/44943_2.png) [@magnusbaeck](https://discuss.elastic.co/u/magnusbaeck)\
**Post date:** [July 18, 2017, 5:23pm UTC](https://discuss.elastic.co/t/unable-to-download-kibana-dashboard/93381/4 "2017-07-18T17:23:14Z")

</div>

Edit your post and change its category.

---

<div class="post-metadata">

**Author:** ![steffens](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/steffens/32/79630_2.png) [@steffens](https://discuss.elastic.co/u/steffens)\
**Post date:** [July 19, 2017, 1:44pm UTC](https://discuss.elastic.co/t/unable-to-download-kibana-dashboard/93381/5 "2017-07-19T13:44:20Z")

</div>

Error message: `No connection could be made because the target machine actively refused it.`

Is Elasticsearch running, using port 9200 and reachable?

---

<div class="post-metadata">

**Author:** ![SFace](https://avatars.discourse-cdn.com/v4/letter/s/ea5d25/32.png) [@SFace](https://discuss.elastic.co/u/SFace)\
**Post date:** [July 20, 2017, 11:00am UTC](https://discuss.elastic.co/t/unable-to-download-kibana-dashboard/93381/6 "2017-07-20T11:00:08Z")

</div>

At the time yes, elasticsearch was running on my Ubuntu machine perfectly fine, along with logstash and kibana. Had to do a fresh install recently so im going to reconfigure everything and then get back to you and see if i have the same issues.

---

<div class="post-metadata">

**Author:** ![SFace](https://avatars.discourse-cdn.com/v4/letter/s/ea5d25/32.png) [@SFace](https://discuss.elastic.co/u/SFace)\
**Post date:** [July 21, 2017, 1:24pm UTC](https://discuss.elastic.co/t/unable-to-download-kibana-dashboard/93381/7 "2017-07-21T13:24:21Z")

</div>

I've got everything up and running and i can confirm that elasticsearch is running using port 9200 and is reachable (Used curl to check)

By the way i am new to ubuntu and logstash so clear steps would be appreciated.

---

<div class="post-metadata">

**Author:** ![steffens](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/steffens/32/79630_2.png) [@steffens](https://discuss.elastic.co/u/steffens)\
**Post date:** [July 21, 2017, 2:22pm UTC](https://discuss.elastic.co/t/unable-to-download-kibana-dashboard/93381/8 "2017-07-21T14:22:53Z")

</div>

Doing `curl http://<esip>:9200/.kibana` from the machine filebeat is running on works?  
You still get the same error?

Thing is, the TCP connect (that has been refused) is basically created by the OS. There shouldn't be a difference between curl and beats here.

---

<div class="post-metadata">

**Author:** ![SFace](https://avatars.discourse-cdn.com/v4/letter/s/ea5d25/32.png) [@SFace](https://discuss.elastic.co/u/SFace)\
**Post date:** [July 21, 2017, 2:25pm UTC](https://discuss.elastic.co/t/unable-to-download-kibana-dashboard/93381/9 "2017-07-21T14:25:55Z")

</div>

its winlogbeats im trying to make work. The Elk stack is installed on Ubuntu and i have whereas ive got winlogbeats on a windows 7 machine. Is there more information you need from me ? i can get it if it helps.

---

<div class="post-metadata">

**Author:** ![steffens](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/steffens/32/79630_2.png) [@steffens](https://discuss.elastic.co/u/steffens)\
**Post date:** [July 24, 2017, 1:11pm UTC](https://discuss.elastic.co/t/unable-to-download-kibana-dashboard/93381/10 "2017-07-24T13:11:11Z")

</div>

So, from which machine did you run curl? Can you check Elasticsearch is reachable from your windows machine? Depending on the configuration in elasticsearch, it might only bind to the host machine (that is, it's only accessible from the ubuntu server).

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [August 21, 2017, 1:11pm UTC](https://discuss.elastic.co/t/unable-to-download-kibana-dashboard/93381/11 "2017-08-21T13:11:21Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
