# Unable to enable alerting feature in kibana 7.7

**URL:** https://discuss.elastic.co/t/unable-to-enable-alerting-feature-in-kibana-7-7/233582
**Category:** Kibana
**Tags:** elastic-stack-security
**Created:** [May 20, 2020, 5:24pm UTC](https://discuss.elastic.co/t/unable-to-enable-alerting-feature-in-kibana-7-7/233582 "2020-05-20T17:24:06Z")
**Posts on this page:** 5
**Page:** 1

<div class="post-metadata">

### Author: ![keerthikar](https://avatars.discourse-cdn.com/v4/letter/k/cab0a1/32.png) [@keerthikar](https://discuss.elastic.co/u/keerthikar)
#### Post date: [May 20, 2020, 5:24pm UTC](https://discuss.elastic.co/t/unable-to-enable-alerting-feature-in-kibana-7-7/233582/1 "2020-05-20T17:24:06Z")

</div>

Enabling the xpack.encryptedSavedObjects.encryptionKey : xxxx in kibana.yml and elasticsearch fails.

```auto
kibana.stderr log:

Could not create APM Agent configuration: No Living connections

 FATAL Error: Cluster client cannot be used after it has been closed.

 FATAL Error: [config validation of [xpack.security].transport]: definition for this key is missing

{"type":"log","@timestamp":"2020-05-18T11:47:58Z","tags":["fatal","root"],"pid":19138,"message":"{ Error: [config validation of [xpack.security].transport]: definition for this key is missing\n at ObjectType.validate (/usr/share/kibana/node_modules/@kbn/config-schema/target/out/types/type.js:59:19)\n at ConfigService.validateAtPath (/usr/share/kibana/src/core/server/config/config_service.js:188:19)\n at MapSubscriber.getDistinctConfig.pipe.config [as project] (/usr/share/kibana/src/core/server/config/config_service.js:196:81)\n at MapSubscriber._next (/usr/share/kibana/node_modules/rxjs/internal/operators/map.js:49:35)\n at MapSubscriber.Subscriber.next (/usr/share/kibana/node_modules/rxjs/internal/Subscriber.js:66:18)\n at DistinctUntilChangedSubscriber._next (/usr/share/kibana/node_modules/rxjs/internal/operators/distinctUntilChanged.js:69:30)\n at DistinctUntilChangedSubscriber.Subscriber.next (/usr/share/kibana/node_modules/rxjs/internal/Subscriber.js:66:18)\n at MapSubscriber._next (/usr/share/kibana/node_modules/rxjs/internal/operators/map.js:55:26)\n at MapSubscriber.Subscriber.next (/usr/share/kibana/node_modules/rxjs/internal/Subscriber.js:66:18)\n at ReplaySubject._subscribe (/usr/share/kibana/node_modules/rxjs/internal/ReplaySubject.js:76:28)\n at ReplaySubject.Observable._trySubscribe (/usr/share/kibana/node_modules/rxjs/internal/Observable.js:44:25)\n at ReplaySubject.Subject._trySubscribe (/usr/share/kibana/node_modules/rxjs/internal/Subject.js:102:51)\n at ReplaySubject.Observable.subscribe (/usr/share/kibana/node_modules/rxjs/internal/Observable.js:30:22)\n at MapSubscriber.shareReplayOperation (/usr/share/kibana/node_modules/rxjs/internal/operators/shareReplay.js:44:32)\n at Observable.subscribe (/usr/share/kibana/node_modules/rxjs/internal/Observable.js:25:31)\n at MapOperator.call (/usr/share/kibana/node_modules/rxjs/internal/operators/map.js:32:23)\n cause:\n { Error: definition for this key is missing\n at ObjectType.onError (/usr/share/kibana/node_modules/@kbn/config-schema/target/out/types/type.js:84:20)\n at type.Type.schema.error (/usr/share/kibana/node_modules/@kbn/config-schema/target/out/types/type.js:49:53)\n at finish (/usr/share/kibana/node_modules/joi/lib/types/any/index.js:529:50)\n at type._validate (/usr/share/kibana/node_modules/joi/lib/types/any/index.js:618:24)\n at type._validateWithOptions (/usr/share/kibana/node_modules/joi/lib/types/any/index.js:674:29)\n at module.exports.internals.Any.root.validate (/usr/share/kibana/node_modules/joi/lib/index.js:146:23)\n at ObjectType.validate (/usr/share/kibana/node_modules/@kbn/config-schema/target/out/types/type.js:54:72)\n at ConfigService.validateAtPath (/usr/share/kibana/src/core/server/config/config_service.js:188:19)\n at MapSubscriber.getDistinctConfig.pipe.config [as project] (/usr/share/kibana/src/core/server/config/config_service.js:196:81)\n at MapSubscriber._next (/usr/share/kibana/node_modules/rxjs/internal/operators/map.js:49:35)\n at MapSubscriber.Subscriber.next (/usr/share/kibana/node_modules/rxjs/internal/Subscriber.js:66:18)\n at DistinctUntilChangedSubscriber._next (/usr/share/kibana/node_modules/rxjs/internal/operators/distinctUntilChanged.js:69:30)\n at DistinctUntilChangedSubscriber.Subscriber.next (/usr/share/kibana/node_modules/rxjs/internal/Subscriber.js:66:18)\n at MapSubscriber._next (/usr/share/kibana/node_modules/rxjs/internal/operators/map.js:55:26)\n at MapSubscriber.Subscriber.next (/usr/share/kibana/node_modules/rxjs/internal/Subscriber.js:66:18)\n at ReplaySubject._subscribe (/usr/share/kibana/node_modules/rxjs/internal/ReplaySubject.js:76:28) cause: undefined, path: ['transport'] } }"}

elasticsearch logs:
-------------------
uncaught exception in thread [main]
java.lang.IllegalArgumentException: unknown setting [xpack.encryptedSavedObjects.encryptionKey] please check that any required plugins are installed, or check the breaking changes documentation for removed settings
        at org.elasticsearch.common.settings.AbstractScopedSettings.validate(AbstractScopedSettings.java:544)
        at org.elasticsearch.common.settings.AbstractScopedSettings.validate(AbstractScopedSettings.java:489)
        at org.elasticsearch.common.settings.AbstractScopedSettings.validate(AbstractScopedSettings.java:460)
        at org.elasticsearch.common.settings.AbstractScopedSettings.validate(AbstractScopedSettings.java:431)
        at org.elasticsearch.common.settings.SettingsModule.<init>(SettingsModule.java:149)
        at org.elasticsearch.node.Node.<init>(Node.java:365)
        at org.elasticsearch.node.Node.<init>(Node.java:264)
        at org.elasticsearch.bootstrap.Bootstrap$5.<init>(Bootstrap.java:227)
        at org.elasticsearch.bootstrap.Bootstrap.setup(Bootstrap.java:227)
        at org.elasticsearch.bootstrap.Bootstrap.init(Bootstrap.java:393)
        at org.elasticsearch.bootstrap.Elasticsearch.init(Elasticsearch.java:170)
        at org.elasticsearch.bootstrap.Elasticsearch.execute(Elasticsearch.java:161)
        at org.elasticsearch.cli.EnvironmentAwareCommand.execute(EnvironmentAwareCommand.java:86)
        at org.elasticsearch.cli.Command.mainWithoutErrorHandling(Command.java:127)
        at org.elasticsearch.cli.Command.main(Command.java:90)
        at org.elasticsearch.bootstrap.Elasticsearch.main(Elasticsearch.java:126)
        at org.elasticsearch.bootstrap.Elasticsearch.main(Elasticsearch.java:92)

Below setting added in yml. 

xpack.security.enabled: true
xpack.security.transport.ssl.enabled: true
xpack.security.transport.ssl.verification_mode: certificate
xpack.security.transport.ssl.keystore.path: /etc/elasticsearch/certs/elastic-certificates.p12
xpack.security.transport.ssl.truststore.path: /etc/elasticsearch/certs/elastic-certificates.p12
xpack.encryptedSavedObjects.encryptionKey : xxxx

```

---

<div class="post-metadata">

### Author: ![joshdover](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/joshdover/32/42020_2.png) [@joshdover](https://discuss.elastic.co/u/joshdover)
#### Post date: [May 21, 2020, 3:44pm UTC](https://discuss.elastic.co/t/unable-to-enable-alerting-feature-in-kibana-7-7/233582/2 "2020-05-21T15:44:21Z")

</div>

Hi there!

I think you may have mixed up your config keys for Kibana and Elasticsearch.

`xpack.security.transport` is an Elasticsearch setting and should not be in the kibana.yml config  
`xpack.encryptedSavedObjects.encryptionKey` is a Kibana setting and should not be in the elasticsearch.yml config.

Let me know if there's any other help I can provide!

---

<div class="post-metadata">

### Author: ![keerthikar](https://avatars.discourse-cdn.com/v4/letter/k/cab0a1/32.png) [@keerthikar](https://discuss.elastic.co/u/keerthikar)
#### Post date: [May 22, 2020, 9:47am UTC](https://discuss.elastic.co/t/unable-to-enable-alerting-feature-in-kibana-7-7/233582/3 "2020-05-22T09:47:25Z")

</div>

```auto
Hi,

These are the setting enabled in kibana.yml

xpack.security.enabled: true
xpack.security.transport.ssl.enabled: false
xpack.security.transport.ssl.verification_mode: certificate
xpack.security.transport.ssl.keystore.path: /etc/elasticsearch/certs/elastic-certificates.p12
xpack.security.transport.ssl.truststore.path: /etc/elasticsearch/certs/elastic-certificates.p12
xpack.encryptedSavedObjects.encryptionKey : va&TD^Vxx24mNeDDCDde2P5K#srj7#C8

and these settings in elasticsearch.yml

xpack.security.enabled: true
xpack.security.transport.ssl.enabled: true
xpack.security.transport.ssl.verification_mode: certificate
xpack.security.transport.ssl.keystore.path: /etc/elasticsearch/certs/elastic-certificates.p12
xpack.security.transport.ssl.truststore.path: /etc/elasticsearch/certs/elastic-certificates.p12

I am getting below error in kibana logs. 

{"type":"log","@timestamp":"2020-05-22T06:49:34Z","tags":["fatal","root"],"pid":20433,"message":"{ Error: [config validation of [xpack.security].transport]: definition for this key is missing\n at ObjectType.validate (/usr/share/kibana/node_modules/@kbn/config-schema/target/out/types/type.js:59:19)\n at ConfigService.validateAtPath (/usr/share/kibana/src/core/server/config/config_service.js:188:19)\n at MapSubscriber.getDistinctConfig.pipe.config [as project] (/usr/share/kibana/src/core/server/config/config_service.js:196:81)\n at MapSubscriber._next (/usr/share/kibana/node_modules/rxjs/internal/operators/map.js:49:35)\n at MapSubscriber.Subscriber.next (/usr/share/kibana/node_modules/rxjs/internal/Subscriber.js:66:18)\n at DistinctUntilChangedSubscriber._next (/usr/share/kibana/node_modules/rxjs/internal/operators/distinctUntilChanged.js:69:30)\n at DistinctUntilChangedSubscriber.Subscriber.next (/usr/share/kibana/node_modules/rxjs/internal/Subscriber.js:66:18)\n at MapSubscriber._next (/usr/share/kibana/node_modules/rxjs/internal/operators/map.js:55:26)\n at MapSubscriber.Subscriber.next (/usr/share/kibana/node_modules/rxjs/internal/Subscriber.js:66:18)\n at ReplaySubject._subscribe (/usr/share/kibana/node_modules/rxjs/internal/ReplaySubject.js:76:28)\n at ReplaySubject.Observable._trySubscribe (/usr/share/kibana/node_modules/rxjs/internal/Observable.js:44:25)\n at ReplaySubject.Subject._trySubscribe (/usr/share/kibana/node_modules/rxjs/internal/Subject.js:102:51)\n at ReplaySubject.Observable.subscribe (/usr/share/kibana/node_modules/rxjs/internal/Observable.js:30:22)\n at MapSubscriber.shareReplayOperation (/usr/share/kibana/node_modules/rxjs/internal/operators/shareReplay.js:44:32)\n at Observable.subscribe (/usr/share/kibana/node_modules/rxjs/internal/Observable.js:25:31)\n at MapOperator.call (/usr/share/kibana/node_modules/rxjs/internal/operators/map.js:32:23)\n cause:\n { Error: definition for this key is missing\n at ObjectType.onError (/usr/share/kibana/node_modules/@kbn/config-schema/target/out/types/type.js:84:20)\n at type.Type.schema.error (/usr/share/kibana/node_modules/@kbn/config-schema/target/out/types/type.js:49:53)\n at finish (/usr/share/kibana/node_modules/joi/lib/types/any/index.js:529:50)\n at type._validate (/usr/share/kibana/node_modules/joi/lib/types/any/index.js:618:24)\n at type._validateWithOptions (/usr/share/kibana/node_modules/joi/lib/types/any/index.js:674:29)\n at module.exports.internals.Any.root.validate (/usr/share/kibana/node_modules/joi/lib/index.js:146:23)\n at ObjectType.validate (/usr/share/kibana/node_modules/@kbn/config-schema/target/out/types/type.js:54:72)\n at ConfigService.validateAtPath (/usr/share/kibana/src/core/server/config/config_service.js:188:19)\n at MapSubscriber.getDistinctConfig.pipe.config [as project] (/usr/share/kibana/src/core/server/config/config_service.js:196:81)\n at MapSubscriber._next (/usr/share/kibana/node_modules/rxjs/internal/operators/map.js:49:35)\n at MapSubscriber.Subscriber.next (/usr/share/kibana/node_modules/rxjs/internal/Subscriber.js:66:18)\n at DistinctUntilChangedSubscriber._next (/usr/share/kibana/node_modules/rxjs/internal/operators/distinctUntilChanged.js:69:30)\n at DistinctUntilChangedSubscriber.Subscriber.next (/usr/share/kibana/node_modules/rxjs/internal/Subscriber.js:66:18)\n at MapSubscriber._next (/usr/share/kibana/node_modules/rxjs/internal/operators/map.js:55:26)\n at MapSubscriber.Subscriber.next (/usr/share/kibana/node_modules/rxjs/internal/Subscriber.js:66:18)\n at ReplaySubject._subscribe (/usr/share/kibana/node_modules/rxjs/internal/ReplaySubject.js:76:28) cause: undefined, path: ['transport'] } }"}
===============================
FATAL ValidationError: child "server" fails because [child "host" fails because ["host" must be a valid hostname]]

 FATAL ValidationError: child "server" fails because [child "host" fails because ["host" must be a valid hostname]]

 FATAL Error: [config validation of [xpack.security].transport]: definition for this key is missing

 FATAL Error: [config validation of [xpack.security].transport]: definition for this key is missing

 FATAL Error: [config validation of [xpack.security].transport]: definition for this key is missing

kibana is upgraded to 7.7.0.

Could you please let me know what is wrong? 

```

---

<div class="post-metadata">

### Author: ![joshdover](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/joshdover/32/42020_2.png) [@joshdover](https://discuss.elastic.co/u/joshdover)
#### Post date: [May 26, 2020, 6:00pm UTC](https://discuss.elastic.co/t/unable-to-enable-alerting-feature-in-kibana-7-7/233582/4 "2020-05-26T18:00:38Z")

</div>

The `xpack.security.transport.*` settings should not be in the kibana.yml file at all, just elasticsearch.yml.

It looks like you have a separate issue with your `server.host` configuration. Make sure it only includes the hostname, not the protocol or port.

---

<div class="post-metadata">

### Author: ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)
#### Post date: [June 23, 2020, 6:00pm UTC](https://discuss.elastic.co/t/unable-to-enable-alerting-feature-in-kibana-7-7/233582/5 "2020-06-23T18:00:40Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
