# Unable to enroll fleet server as assinged policy does not have fleet server input

**URL:** <https://discuss.elastic.co/t/unable-to-enroll-fleet-server-as-assinged-policy-does-not-have-fleet-server-input/277846>\
**Category:** Beats\
**Tags:** elastic-agent\
**Created:** [July 5, 2021, 2:45pm UTC](https://discuss.elastic.co/t/unable-to-enroll-fleet-server-as-assinged-policy-does-not-have-fleet-server-input/277846 "2021-07-05T14:45:09Z")\
**Posts on this page:** 20\
**Page:** 1

<div class="post-metadata">

**Author:** ![cheapsupps](https://avatars.discourse-cdn.com/v4/letter/c/3bc359/32.png) [@cheapsupps](https://discuss.elastic.co/u/cheapsupps)\
**Post date:** [July 5, 2021, 2:45pm UTC](https://discuss.elastic.co/t/unable-to-enroll-fleet-server-as-assinged-policy-does-not-have-fleet-server-input/277846/1 "2021-07-05T14:45:09Z")

</div>

Hi,

I am setting up fleet-server in air-gap environment. However, I am unable to enroll the fleet-server to elasticsearch. I am having the below error.

2021-07-05T22:37:11.552+0800 INFO cmd/enroll\_cmd.go:300 Generating self-signed certificate for Fleet Server  
2021-07-05T22:37:12.847+0800 INFO cmd/enroll\_cmd.go:643 Fleet Server - Starting  
2021-07-05T22:37:18.895+0800 INFO cmd/enroll\_cmd.go:648 Fleet Server - Starting  
2021-07-05T22:37:24.951+0800 INFO cmd/enroll\_cmd.go:648 Fleet Server - Starting  
2021-07-05T22:37:31.001+0800 INFO cmd/enroll\_cmd.go:648 Fleet Server - Starting  
2021-07-05T22:37:37.045+0800 INFO cmd/enroll\_cmd.go:648 Fleet Server - Starting  
2021-07-05T22:37:43.104+0800 INFO cmd/enroll\_cmd.go:648 Fleet Server - Starting  
2021-07-05T22:37:44.110+0800 INFO cmd/enroll\_cmd.go:643 Fleet Server - Error - assigned policy does not have fleet-server input  
2021-07-05T22:37:46.125+0800 INFO cmd/enroll\_cmd.go:643 Fleet Server - Starting  
2021-07-05T22:37:47.134+0800 INFO cmd/enroll\_cmd.go:643 Fleet Server - Error - assigned policy does not have fleet-server input  
2021-07-05T22:37:51.171+0800 INFO cmd/enroll\_cmd.go:643 Fleet Server - Starting  
2021-07-05T22:37:52.172+0800 INFO cmd/enroll\_cmd.go:643 Fleet Server - Error - assigned policy does not have fleet-server input  
2021-07-05T22:37:58.189+0800 INFO cmd/enroll\_cmd.go:643 Fleet Server - Starting  
2021-07-05T22:37:59.199+0800 INFO cmd/enroll\_cmd.go:643 Fleet Server - Error - assigned policy does not have fleet-server input  
2021-07-05T22:38:05.227+0800 INFO cmd/enroll\_cmd.go:648 Fleet Server - Error - assigned policy does not have fleet-server input  
2021-07-05T22:38:07.227+0800 INFO cmd/enroll\_cmd.go:643 Fleet Server - Starting  
2021-07-05T22:38:08.228+0800 INFO cmd/enroll\_cmd.go:643 Fleet Server - Error - assigned policy does not have fleet-server input  
2021-07-05T22:38:14.238+0800 INFO cmd/enroll\_cmd.go:643 Fleet Server - Starting  
2021-07-05T22:38:15.238+0800 INFO cmd/enroll\_cmd.go:643 Fleet Server - Error - assigned policy does not have fleet-server input  
2021-07-05T22:38:21.243+0800 INFO cmd/enroll\_cmd.go:648 Fleet Server - Error - assigned policy does not have fleet-server input  
2021-07-05T22:38:23.244+0800 INFO cmd/enroll\_cmd.go:643 Fleet Server - Starting  
2021-07-05T22:38:24.246+0800 INFO cmd/enroll\_cmd.go:643 Fleet Server - Error - assigned policy does not have fleet-server input  
2021-07-05T22:38:30.258+0800 INFO cmd/enroll\_cmd.go:643 Fleet Server - Starting  
2021-07-05T22:38:31.262+0800 INFO cmd/enroll\_cmd.go:643 Fleet Server - Error - assigned policy does not have fleet-server input  
2021-07-05T22:38:37.271+0800 INFO cmd/enroll\_cmd.go:648 Fleet Server - Error - assigned policy does not have fleet-server input  
2021-07-05T22:38:39.280+0800 INFO cmd/enroll\_cmd.go:643 Fleet Server - Starting  
2021-07-05T22:38:40.283+0800 INFO cmd/enroll\_cmd.go:643 Fleet Server - Error - assigned policy does not have fleet-server input  
2021-07-05T22:38:46.289+0800 INFO cmd/enroll\_cmd.go:643 Fleet Server - Starting  
2021-07-05T22:38:47.292+0800 INFO cmd/enroll\_cmd.go:643 Fleet Server - Error - assigned policy does not have fleet-server input  
2021-07-05T22:38:53.305+0800 INFO cmd/enroll\_cmd.go:643 Fleet Server - Starting  
2021-07-05T22:38:54.308+0800 INFO cmd/enroll\_cmd.go:643 Fleet Server - Error - assigned policy does not have fleet-server input  
2021-07-05T22:38:55.308+0800 INFO cmd/enroll\_cmd.go:643 Fleet Server - Starting  
2021-07-05T22:38:56.310+0800 INFO cmd/enroll\_cmd.go:643 Fleet Server - Error - assigned policy does not have fleet-server input  
2021-07-05T22:39:02.420+0800 INFO cmd/enroll\_cmd.go:643 Fleet Server - Starting  
2021-07-05T22:39:03.420+0800 INFO cmd/enroll\_cmd.go:643 Fleet Server - Error - assigned policy does not have fleet-server input  
2021-07-05T22:39:06.447+0800 INFO cmd/enroll\_cmd.go:643 Fleet Server - Starting  
2021-07-05T22:39:07.453+0800 INFO cmd/enroll\_cmd.go:643 Fleet Server - Error - assigned policy does not have fleet-server input  
Error: fleet-server never started by elastic-agent daemon: context canceled  
Error: enroll command failed with exit code: 12021-07-05T22:37:11.552+0800 INFO cmd/enroll\_cmd.go:300 Generating self-signed certificate for Fleet Server  
2021-07-05T22:37:12.847+0800 INFO cmd/enroll\_cmd.go:643 Fleet Server - Starting  
2021-07-05T22:37:18.895+0800 INFO cmd/enroll\_cmd.go:648 Fleet Server - Starting  
2021-07-05T22:37:24.951+0800 INFO cmd/enroll\_cmd.go:648 Fleet Server - Starting  
2021-07-05T22:37:31.001+0800 INFO cmd/enroll\_cmd.go:648 Fleet Server - Starting  
2021-07-05T22:37:37.045+0800 INFO cmd/enroll\_cmd.go:648 Fleet Server - Starting  
2021-07-05T22:37:43.104+0800 INFO cmd/enroll\_cmd.go:648 Fleet Server - Starting  
2021-07-05T22:37:44.110+0800 INFO cmd/enroll\_cmd.go:643 Fleet Server - Error - assigned policy does not have fleet-server input  
2021-07-05T22:37:46.125+0800 INFO cmd/enroll\_cmd.go:643 Fleet Server - Starting  
2021-07-05T22:37:47.134+0800 INFO cmd/enroll\_cmd.go:643 Fleet Server - Error - assigned policy does not have fleet-server input  
2021-07-05T22:37:51.171+0800 INFO cmd/enroll\_cmd.go:643 Fleet Server - Starting  
2021-07-05T22:37:52.172+0800 INFO cmd/enroll\_cmd.go:643 Fleet Server - Error - assigned policy does not have fleet-server input  
2021-07-05T22:37:58.189+0800 INFO cmd/enroll\_cmd.go:643 Fleet Server - Starting  
2021-07-05T22:37:59.199+0800 INFO cmd/enroll\_cmd.go:643 Fleet Server - Error - assigned policy does not have fleet-server input  
2021-07-05T22:38:05.227+0800 INFO cmd/enroll\_cmd.go:648 Fleet Server - Error - assigned policy does not have fleet-server input  
2021-07-05T22:38:07.227+0800 INFO cmd/enroll\_cmd.go:643 Fleet Server - Starting  
2021-07-05T22:38:08.228+0800 INFO cmd/enroll\_cmd.go:643 Fleet Server - Error - assigned policy does not have fleet-server input  
2021-07-05T22:38:14.238+0800 INFO cmd/enroll\_cmd.go:643 Fleet Server - Starting  
2021-07-05T22:38:15.238+0800 INFO cmd/enroll\_cmd.go:643 Fleet Server - Error - assigned policy does not have fleet-server input  
2021-07-05T22:38:21.243+0800 INFO cmd/enroll\_cmd.go:648 Fleet Server - Error - assigned policy does not have fleet-server input  
2021-07-05T22:38:23.244+0800 INFO cmd/enroll\_cmd.go:643 Fleet Server - Starting  
2021-07-05T22:38:24.246+0800 INFO cmd/enroll\_cmd.go:643 Fleet Server - Error - assigned policy does not have fleet-server input  
2021-07-05T22:38:30.258+0800 INFO cmd/enroll\_cmd.go:643 Fleet Server - Starting  
2021-07-05T22:38:31.262+0800 INFO cmd/enroll\_cmd.go:643 Fleet Server - Error - assigned policy does not have fleet-server input  
2021-07-05T22:38:37.271+0800 INFO cmd/enroll\_cmd.go:648 Fleet Server - Error - assigned policy does not have fleet-server input  
2021-07-05T22:38:39.280+0800 INFO cmd/enroll\_cmd.go:643 Fleet Server - Starting  
2021-07-05T22:38:40.283+0800 INFO cmd/enroll\_cmd.go:643 Fleet Server - Error - assigned policy does not have fleet-server input  
2021-07-05T22:38:46.289+0800 INFO cmd/enroll\_cmd.go:643 Fleet Server - Starting  
2021-07-05T22:38:47.292+0800 INFO cmd/enroll\_cmd.go:643 Fleet Server - Error - assigned policy does not have fleet-server input  
2021-07-05T22:38:53.305+0800 INFO cmd/enroll\_cmd.go:643 Fleet Server - Starting  
2021-07-05T22:38:54.308+0800 INFO cmd/enroll\_cmd.go:643 Fleet Server - Error - assigned policy does not have fleet-server input  
2021-07-05T22:38:55.308+0800 INFO cmd/enroll\_cmd.go:643 Fleet Server - Starting  
2021-07-05T22:38:56.310+0800 INFO cmd/enroll\_cmd.go:643 Fleet Server - Error - assigned policy does not have fleet-server input  
2021-07-05T22:39:02.420+0800 INFO cmd/enroll\_cmd.go:643 Fleet Server - Starting  
2021-07-05T22:39:03.420+0800 INFO cmd/enroll\_cmd.go:643 Fleet Server - Error - assigned policy does not have fleet-server input  
2021-07-05T22:39:06.447+0800 INFO cmd/enroll\_cmd.go:643 Fleet Server - Starting  
2021-07-05T22:39:07.453+0800 INFO cmd/enroll\_cmd.go:643 Fleet Server - Error - assigned policy does not have fleet-server input  
Error: fleet-server never started by elastic-agent daemon: context canceled  
Error: enroll command failed with exit code: 1

May I know where I can add the server input?

---

<div class="post-metadata">

**Author:** ![mtojek](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/mtojek/32/63863_2.png) [@mtojek](https://discuss.elastic.co/u/mtojek)\
**Post date:** [July 6, 2021, 8:17am UTC](https://discuss.elastic.co/t/unable-to-enroll-fleet-server-as-assinged-policy-does-not-have-fleet-server-input/277846/2 "2021-07-06T08:17:37Z")

</div>

I'm not sure if this error is related to the air-gapped environment. Did you run the Package Registry? Is it accessible?

---

<div class="post-metadata">

**Author:** ![blaker](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/blaker/32/65621_2.png) [@blaker](https://discuss.elastic.co/u/blaker)\
**Post date:** [July 6, 2021, 1:56pm UTC](https://discuss.elastic.co/t/unable-to-enroll-fleet-server-as-assinged-policy-does-not-have-fleet-server-input/277846/3 "2021-07-06T13:56:58Z")

</div>

Kibana should have added the `fleet-server` integration to the `Default Fleet Server policy`. Being air-gapped you will need to run the package registry as well (as @mtojek mentions).

You can manually add the integration by going to the `Default Fleet Server policy` and add the `fleet-server` integration.

---

<div class="post-metadata">

**Author:** ![cheapsupps](https://avatars.discourse-cdn.com/v4/letter/c/3bc359/32.png) [@cheapsupps](https://discuss.elastic.co/u/cheapsupps)\
**Post date:** [July 6, 2021, 2:28pm UTC](https://discuss.elastic.co/t/unable-to-enroll-fleet-server-as-assinged-policy-does-not-have-fleet-server-input/277846/4 "2021-07-06T14:28:22Z")

</div>

yes. I am running it in an air-gap environment. May I know how I can setup the package registry? The kibana and elasticsearch version i am using is 7.13.2

---

<div class="post-metadata">

**Author:** ![mtojek](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/mtojek/32/63863_2.png) [@mtojek](https://discuss.elastic.co/u/mtojek)\
**Post date:** [July 7, 2021, 8:46am UTC](https://discuss.elastic.co/t/unable-to-enroll-fleet-server-as-assinged-policy-does-not-have-fleet-server-input/277846/5 "2021-07-07T08:46:38Z")

</div>

Docs: [GitHub - elastic/package-storage: Package storage for packages served through the package registry service](https://github.com/elastic/package-storage#air-gapped-environments)

---

<div class="post-metadata">

**Author:** ![cheapsupps](https://avatars.discourse-cdn.com/v4/letter/c/3bc359/32.png) [@cheapsupps](https://discuss.elastic.co/u/cheapsupps)\
**Post date:** [July 11, 2021, 5:35pm UTC](https://discuss.elastic.co/t/unable-to-enroll-fleet-server-as-assinged-policy-does-not-have-fleet-server-input/277846/6 "2021-07-11T17:35:46Z")

</div>

I have run the docker run -it [docker.elastic.co/package-registry/distribution:production](http://docker.elastic.co/package-registry/distribution:production)  
below is the message generated  
...  
2021/07/11 17:31:19 zscaler 0.2.0 /packages/production/zscaler/0.2.0  
2021/07/11 17:31:22 368 package manifests loaded.

However, I cannot connect to the port  
curl -f [http://127.0.0.1:8080](http://127.0.0.1:8080)  
curl: (7) Failed to connect to 127.0.0.1 port 8080: Connection refused

May I know what is the error?

---

<div class="post-metadata">

**Author:** ![cheapsupps](https://avatars.discourse-cdn.com/v4/letter/c/3bc359/32.png) [@cheapsupps](https://discuss.elastic.co/u/cheapsupps)\
**Post date:** [July 12, 2021, 10:09am UTC](https://discuss.elastic.co/t/unable-to-enroll-fleet-server-as-assinged-policy-does-not-have-fleet-server-input/277846/7 "2021-07-12T10:09:30Z")

</div>

Hi I have managed to get my elastic package registry up and running. I have also changed the xpack.fleet.registryUrl: "[http://package-registry.corp.net:8080](http://package-registry.corp.net:8080)" in kibana config. However, I am still getting the following error:  
"Error connecting to package registry: request to [https://epr.elastic.co/search?package=system&internal=true&experimental=true&kibana.version=7.13.2](https://epr.elastic.co/search?package=system&internal=true&experimental=true&kibana.version=7.13.2) failed, reason: getaddrinfo ENOTFOUND [epr.elastic.co](http://epr.elastic.co)"

---

<div class="post-metadata">

**Author:** ![cheapsupps](https://avatars.discourse-cdn.com/v4/letter/c/3bc359/32.png) [@cheapsupps](https://discuss.elastic.co/u/cheapsupps)\
**Post date:** [July 13, 2021, 4:46am UTC](https://discuss.elastic.co/t/unable-to-enroll-fleet-server-as-assinged-policy-does-not-have-fleet-server-input/277846/8 "2021-07-13T04:46:17Z")

</div>

below is my kibana configmap file  
kibana.yml: |-  
server.host: 0.0.0.0  
server.ssl.enabled: true  
server.ssl.certificate: /usr/share/kibana/config/certs/kibana/tls.crt  
server.ssl.key: /usr/share/kibana/config/certs/kibana/tls.key  
xpack.encryptedSavedObjects.encryptionKey: ${ELASTICSEARCH\_OBJECT\_KEY}  
xpack.security.enabled: true  
xpack.fleet.enabled: true  
xpack.fleet.registryUrl: ${REGISTRY\_HOSTS}  
xpack.fleet.agents.enabled: true  
xpack.fleet.agents.tlsCheckDisabled: true  
elasticsearch:  
hosts: ${ELASTICSEARCH\_HOSTS}  
username: ${ELASTICSEARCH\_USER}  
password: ${ELASTICSEARCH\_PASSWORD}  
ssl:  
key: /usr/share/kibana/config/certs/es/tls.key  
certificate: /usr/share/kibana/config/certs/es/tls.crt

---

<div class="post-metadata">

**Author:** ![blaker](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/blaker/32/65621_2.png) [@blaker](https://discuss.elastic.co/u/blaker)\
**Post date:** [July 13, 2021, 4:13pm UTC](https://discuss.elastic.co/t/unable-to-enroll-fleet-server-as-assinged-policy-does-not-have-fleet-server-input/277846/9 "2021-07-13T16:13:25Z")

</div>

@nchaulet Any ideas on why that setting would not be picked up by Kibana? ^

---

<div class="post-metadata">

**Author:** ![nchaulet](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/nchaulet/32/77896_2.png) [@nchaulet](https://discuss.elastic.co/u/nchaulet)\
**Post date:** [July 19, 2021, 12:35pm UTC](https://discuss.elastic.co/t/unable-to-enroll-fleet-server-as-assinged-policy-does-not-have-fleet-server-input/277846/10 "2021-07-19T12:35:49Z")

</div>

@cheapsupps are you using an enterprise licence of Kibana? currently it's only possible to configure the registry url if you have an enterprise licence.

---

<div class="post-metadata">

**Author:** ![charliek17](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/charliek17/32/92357_2.png) [@charliek17](https://discuss.elastic.co/u/charliek17)\
**Post date:** [July 30, 2021, 11:37am UTC](https://discuss.elastic.co/t/unable-to-enroll-fleet-server-as-assinged-policy-does-not-have-fleet-server-input/277846/11 "2021-07-30T11:37:01Z")

</div>

I have the same issue, instead I don't have any access to the internet. Is there a way to curl the content down and move across?

---

<div class="post-metadata">

**Author:** ![blaker](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/blaker/32/65621_2.png) [@blaker](https://discuss.elastic.co/u/blaker)\
**Post date:** [July 30, 2021, 1:15pm UTC](https://discuss.elastic.co/t/unable-to-enroll-fleet-server-as-assinged-policy-does-not-have-fleet-server-input/277846/12 "2021-07-30T13:15:30Z")

</div>

@charliek17 The documentation linked below provides information (it was also linked above by @mtojek) on how to do it in environments without the internet.

> **[GitHub - elastic/package-storage: Package storage for packages served through...](https://github.com/elastic/package-storage#air-gapped-environments)**
>
> Package storage for packages served through the package registry service - GitHub - elastic/package-storage: Package storage for packages served through the package registry service

---

<div class="post-metadata">

**Author:** ![charliek17](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/charliek17/32/92357_2.png) [@charliek17](https://discuss.elastic.co/u/charliek17)\
**Post date:** [August 2, 2021, 10:05am UTC](https://discuss.elastic.co/t/unable-to-enroll-fleet-server-as-assinged-policy-does-not-have-fleet-server-input/277846/13 "2021-08-02T10:05:57Z")

</div>

Hi, had this issue too, ive open and closed an issue on the github page.

```auto
docker run --publish 8080:8080 -it docker.elastic.co/package-registry/distribution:production

```

That should work

But I'm running into the same issue where regardless of setting regurl it still defaults to [epr.elastic.co](http://epr.elastic.co)

---

<div class="post-metadata">

**Author:** ![charliek17](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/charliek17/32/92357_2.png) [@charliek17](https://discuss.elastic.co/u/charliek17)\
**Post date:** [August 2, 2021, 10:24am UTC](https://discuss.elastic.co/t/unable-to-enroll-fleet-server-as-assinged-policy-does-not-have-fleet-server-input/277846/14 "2021-08-02T10:24:58Z")

</div>

In update. We don't have a Elastic Enterprise to allow Custom EPR Registries. So that's why its not working.

---

<div class="post-metadata">

**Author:** ![cheapsupps](https://avatars.discourse-cdn.com/v4/letter/c/3bc359/32.png) [@cheapsupps](https://discuss.elastic.co/u/cheapsupps)\
**Post date:** [August 15, 2021, 2:22pm UTC](https://discuss.elastic.co/t/unable-to-enroll-fleet-server-as-assinged-policy-does-not-have-fleet-server-input/277846/15 "2021-08-15T14:22:12Z")

</div>

I managed to get the EPR registries by enabling trial. I wonder does the integration still works after the trial has expired.

---

<div class="post-metadata">

**Author:** ![Koji\_Kawamura](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/koji_kawamura/32/93938_2.png) [@Koji\_Kawamura](https://discuss.elastic.co/u/Koji_Kawamura)\
**Post date:** [August 31, 2021, 7:45am UTC](https://discuss.elastic.co/t/unable-to-enroll-fleet-server-as-assinged-policy-does-not-have-fleet-server-input/277846/16 "2021-08-31T07:45:38Z")

</div>

Hi, I've encountered the same error message.

> 2021-08-31T07:13:04.409Z ERROR log/reporter.go:36 2021-08-31T07:13:04Z - message: Application: fleet-server--7.14.0: State changed to FAILED: Error - assigned policy does not have fleet-server input - type: 'ERROR' - sub\_type: 'FAILED'

I've added fleet-server integration to Elastic Cloud Agent policy manually. Then after restarting the APM & Fleet server, it started up successfully.

I'm using an air-gapped ECE environment. Added following two settings in kibana.yml:

```auto
xpack.ingestManager.registryProxyUrl: http://proxy-host:3128
xpack.fleet.registryProxyUrl: http://proxy-host:3128

```

I wonder why the agent started by APM & Fleet server uses the Elastic Cloud Agent policy. Default Fleet Server policy should be assigned to the agent instead?

---

<div class="post-metadata">

**Author:** ![Jugsofbeer](https://avatars.discourse-cdn.com/v4/letter/j/9de0a6/32.png) [@Jugsofbeer](https://discuss.elastic.co/u/Jugsofbeer)\
**Post date:** [September 6, 2021, 6:29am UTC](https://discuss.elastic.co/t/unable-to-enroll-fleet-server-as-assinged-policy-does-not-have-fleet-server-input/277846/17 "2021-09-06T06:29:02Z")

</div>

> [@Koji\_Kawamura](#):
>
> ```auto
> xpack.ingestManager.registryProxyUrl: http://proxy-host:3128
> xpack.fleet.registryProxyUrl: http://proxy-host:3128
> 
> ```

We suffered this issue as well because we had recently removed "xpack.ingestManager.registryProxyUrl" as it was appearing in the deprecation logs as having been replaced by "xpack.fleet.registryProxyUrl".

Turns out both are needed under the covers, in v7.14.x possibly by accident...

We also discovered if upgrading from v7.13.x to v7.14.x that if the you hit the enrollment issue make sure both the settings are available in kibana ( and that your proxy allows you to connect to the [epr.elastic.co](http://epr.elastic.co) address ) that you may also need to run the 3 lines from this " Fleet Server fails with `assigned policy does not have fleet-server input` log error" from [Troubleshoot common problems | Fleet and Elastic Agent Guide [master] | Elastic](https://www.elastic.co/guide/en/fleet/master/fleet-troubleshooting.html)

---

<div class="post-metadata">

**Author:** ![joshdover](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/joshdover/32/42020_2.png) [@joshdover](https://discuss.elastic.co/u/joshdover)\
**Post date:** [September 6, 2021, 12:32pm UTC](https://discuss.elastic.co/t/unable-to-enroll-fleet-server-as-assinged-policy-does-not-have-fleet-server-input/277846/18 "2021-09-06T12:32:34Z")

</div>

> [@Jugsofbeer](#):
>
> Turns out both are needed under the covers, in v7.14.x possibly by accident...

@Jugsofbeer I'm curious, do you have any other configs still under the `xpack.ingestManager.*` key. I believe we do have a bug where if any configs are still under this old name, it will overwrite any configs under `xpack.fleet.*` when we translate the old settings over.

I've opened an issue with a test case to track the root problem [here](https://github.com/elastic/kibana/issues/111277), but we may need to workaround this in the meantime on the Fleet side.

---

<div class="post-metadata">

**Author:** ![Jugsofbeer](https://avatars.discourse-cdn.com/v4/letter/j/9de0a6/32.png) [@Jugsofbeer](https://discuss.elastic.co/u/Jugsofbeer)\
**Post date:** [September 6, 2021, 7:44pm UTC](https://discuss.elastic.co/t/unable-to-enroll-fleet-server-as-assinged-policy-does-not-have-fleet-server-input/277846/19 "2021-09-06T19:44:54Z")

</div>

Hi Josh, I have been working through this with a Elastic Support Case the past week, send me a PM if you want the number.

---

<div class="post-metadata">

**Author:** ![cheapsupps](https://avatars.discourse-cdn.com/v4/letter/c/3bc359/32.png) [@cheapsupps](https://discuss.elastic.co/u/cheapsupps)\
**Post date:** [September 28, 2021, 10:34am UTC](https://discuss.elastic.co/t/unable-to-enroll-fleet-server-as-assinged-policy-does-not-have-fleet-server-input/277846/20 "2021-09-28T10:34:10Z")

</div>

Hi,

notice Elasticsearch v 7.15.0 is out.

Based on below link, is enterprise license still required for the custom epr url?

> **[What’s new in Elasticsearch, Kibana, and Elastic Cloud for 7.15](https://www.elastic.co/blog/whats-new-elasticsearch-kibana-cloud-7-15-0)**
>
> Elastic Cloud customers can now ingest data more simply, quickly, and securely, and the latest updates to the core Elastic Stack provide users with new tools for maximizing performance and exploring their data.

thanks

[Next page](https://discuss.elastic.co/t/unable-to-enroll-fleet-server-as-assinged-policy-does-not-have-fleet-server-input/277846.md?page=2)
