# Unable to fetch data from kibana collector

**URL:** <https://discuss.elastic.co/t/unable-to-fetch-data-from-kibana-collector/142196>\
**Category:** Kibana\
**Created:** [July 30, 2018, 2:22pm UTC](https://discuss.elastic.co/t/unable-to-fetch-data-from-kibana-collector/142196 "2018-07-30T14:22:15Z")\
**Posts on this page:** 8\
**Page:** 1

<div class="post-metadata">

**Author:** ![alexus](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/alexus/32/12696_2.png) [@alexus](https://discuss.elastic.co/u/alexus)\
**Post date:** [July 30, 2018, 2:22pm UTC](https://discuss.elastic.co/t/unable-to-fetch-data-from-kibana-collector/142196/1 "2018-07-30T14:22:16Z")

</div>

I'm [Running Kibana on Docker](https://www.elastic.co/guide/en/kibana/current/docker.html) and seeing quite a lot following message in my logs:

> Unable to fetch data from kibana collector

Please advise.

---

<div class="post-metadata">

**Author:** ![Brandon\_Kobel](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/brandon_kobel/32/14829_2.png) [@Brandon\_Kobel](https://discuss.elastic.co/u/Brandon_Kobel)\
**Post date:** [July 30, 2018, 6:03pm UTC](https://discuss.elastic.co/t/unable-to-fetch-data-from-kibana-collector/142196/2 "2018-07-30T18:03:50Z")

</div>

> [@alexus](#):
>
> Unable to fetch data from kibana

Hey @alexus, is there an error printed before you see this message?

---

<div class="post-metadata">

**Author:** ![alexus](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/alexus/32/12696_2.png) [@alexus](https://discuss.elastic.co/u/alexus)\
**Post date:** [July 30, 2018, 7:03pm UTC](https://discuss.elastic.co/t/unable-to-fetch-data-from-kibana-collector/142196/3 "2018-07-30T19:03:02Z")

</div>

my logs are flooded with that message, one after another...

---

<div class="post-metadata">

**Author:** ![Brandon\_Kobel](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/brandon_kobel/32/14829_2.png) [@Brandon\_Kobel](https://discuss.elastic.co/u/Brandon_Kobel)\
**Post date:** [July 30, 2018, 7:33pm UTC](https://discuss.elastic.co/t/unable-to-fetch-data-from-kibana-collector/142196/4 "2018-07-30T19:33:20Z")

</div>

@alexus which version of Kibana are you running?

---

<div class="post-metadata">

**Author:** ![alexus](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/alexus/32/12696_2.png) [@alexus](https://discuss.elastic.co/u/alexus)\
**Post date:** [July 30, 2018, 7:34pm UTC](https://discuss.elastic.co/t/unable-to-fetch-data-from-kibana-collector/142196/5 "2018-07-30T19:34:51Z")

</div>

6.3.1

---

<div class="post-metadata">

**Author:** ![chrisronline](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/chrisronline/32/28230_2.png) [@chrisronline](https://discuss.elastic.co/u/chrisronline)\
**Post date:** [July 30, 2018, 7:55pm UTC](https://discuss.elastic.co/t/unable-to-fetch-data-from-kibana-collector/142196/6 "2018-07-30T19:55:53Z")

</div>

Hi @alexus,

Can you double check the log or paste the entire log in here? From [reading the code](https://github.com/elastic/kibana/blob/v6.3.1/x-pack/plugins/monitoring/server/kibana_monitoring/lib/type_collector.js#L134), the error should be logged as well.

---

<div class="post-metadata">

**Author:** ![philhagen](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/philhagen/32/96548_2.png) [@philhagen](https://discuss.elastic.co/u/philhagen)\
**Post date:** [August 9, 2018, 1:43pm UTC](https://discuss.elastic.co/t/unable-to-fetch-data-from-kibana-collector/142196/7 "2018-08-09T13:43:15Z")

</div>

Seeing this in 6.3.2 as well:

```auto
Aug 9 13:42:38 sof-elk kibana: {"type":"error","@timestamp":"2018-08-09T13:42:38Z","tags":["warning","monitoring-ui","kibana-monitoring"],"pid":772,"level":"error","error":{"message":"[illegal_argument_exception] Fielddata is disabled on text fields by default. Set fielddata=true on [type] in order to load fielddata in memory by uninverting the inverted index. Note that this can however use significant memory. Alternatively use a keyword field instead.","name":"Error","stack":"[illegal_argument_exception] Fielddata is disabled on text fields by default. Set fielddata=true on [type] in order to load fielddata in memory by uninverting the inverted index. Note that this can however use significant memory. Alternatively use a keyword field instead. :: {\"path\":\"/.kibana/_search\",\"query\":{\"ignore_unavailable\":true,\"filter_path\":\"aggregations.types.buckets\"},\"body\":\"{\\\"size\\\":0,\\\"query\\\":{\\\"terms\\\":{\\\"type\\\":[\\\"dashboard\\\",\\\"visualization\\\",\\\"search\\\",\\\"index-pattern\\\",\\\"graph-workspace\\\",\\\"timelion-sheet\\\"]}},\\\"aggs\\\":{\\\"types\\\":{\\\"terms\\\":{\\\"field\\\":\\\"type\\\",\\\"size\\\":6}}}}\",\"statusCode\":400,\"response\":\"{\\\"error\\\":{\\\"root_cause\\\":[{\\\"type\\\":\\\"illegal_argument_exception\\\",\\\"reason\\\":\\\"Fielddata is disabled on text fields by default. Set fielddata=true on [type] in order to load fielddata in memory by uninverting the inverted index. Note that this can however use significant memory. Alternatively use a keyword field instead.\\\"}],\\\"type\\\":\\\"search_phase_execution_exception\\\",\\\"reason\\\":\\\"all shards failed\\\",\\\"phase\\\":\\\"query\\\",\\\"grouped\\\":true,\\\"failed_shards\\\":[{\\\"shard\\\":0,\\\"index\\\":\\\".kibana\\\",\\\"node\\\":\\\"o_9gbcK8T_OhzcexvXzrmA\\\",\\\"reason\\\":{\\\"type\\\":\\\"illegal_argument_exception\\\",\\\"reason\\\":\\\"Fielddata is disabled on text fields by default. Set fielddata=true on [type] in order to load fielddata in memory by uninverting the inverted index. Note that this can however use significant memory. Alternatively use a keyword field instead.\\\"}}],\\\"caused_by\\\":{\\\"type\\\":\\\"illegal_argument_exception\\\",\\\"reason\\\":\\\"Fielddata is disabled on text fields by default. Set fielddata=true on [type] in order to load fielddata in memory by uninverting the inverted index. Note that this can however use significant memory. Alternatively use a keyword field instead.\\\",\\\"caused_by\\\":{\\\"type\\\":\\\"illegal_argument_exception\\\",\\\"reason\\\":\\\"Fielddata is disabled on text fields by default. Set fielddata=true on [type] in order to load fielddata in memory by uninverting the inverted index. Note that this can however use significant memory. Alternatively use a keyword field instead.\\\"}}},\\\"status\\\":400}\"}\n at respond (/usr/share/kibana/node_modules/elasticsearch/src/lib/transport.js:307:15)\n at checkRespForFailure (/usr/share/kibana/node_modules/elasticsearch/src/lib/transport.js:266:7)\n at HttpConnector.<anonymous> (/usr/share/kibana/node_modules/elasticsearch/src/lib/connectors/http.js:159:7)\n at IncomingMessage.bound (/usr/share/kibana/node_modules/elasticsearch/node_modules/lodash/dist/lodash.js:729:21)\n at emitNone (events.js:111:20)\n at IncomingMessage.emit (events.js:208:7)\n at endReadableNT (_stream_readable.js:1064:12)\n at _combinedTickCallback (internal/process/next_tick.js:138:11)\n at process._tickDomainCallback (internal/process/next_tick.js:218:9)"},"message":"[illegal_argument_exception] Fielddata is disabled on text fields by default. Set fielddata=true on [type] in order to load fielddata in memory by uninverting the inverted index. Note that this can however use significant memory. Alternatively use a keyword field instead."}
Aug 9 13:42:38 sof-elk kibana: {"type":"log","@timestamp":"2018-08-09T13:42:38Z","tags":["warning","monitoring-ui","kibana-monitoring"],"pid":772,"message":"Unable to fetch data from kibana collector"}

```

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [September 6, 2018, 1:43pm UTC](https://discuss.elastic.co/t/unable-to-fetch-data-from-kibana-collector/142196/8 "2018-09-06T13:43:19Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
